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Chapter 1 Installation 

1.1 System Requirement 

Richpeace Design Pro 2000 requires the operation system of 

Microsoft Windows 95/98/2000. It can be installed on any Personal 

Computer which satisfies the following requirements. 

Intel 80586 or Pentium processor； 

32 megabytes of memory； 

80 megabytes or more free hard disk space； 

Standard SVGA monitor or other compatible monitor； 

Richpeace Design Pro 2000 Dongle Card (provided with the 

software)； 

Microsoft mouse of other compatible mouse. 

1.2 Installing Richpeace Design Pro Dongle Key  

The Dongle Key should be installed properly before the setup of 

the software, otherwise, Richpeace Design Pro 2000 will not be able to 

work. 

To Install the Dongle Key  

1. Turn off the computer. 

2. Insert the Dongle Key into the series port of the computer. 

3. Turn the computer on. 

1.3 Setup Richpeace Design Pro 2000 

1. Exit all application programs. 
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2. Place the CDROM Disk in the CDROM Drive. 

3. The program will be automatically installed, or else run Setup in 

the CDROM to install the program. 

Installation information and instructions will be displayed on the 

screen, follow the setup vizard to setup the software. 

Note: 

You will be required to input the serial number during the setup. 

You can find the number in the Disk bearing the name of sn.txt. You can 

double click it to read the content. 

4. When the installation finished, please run Setup file in your 

computer at first to driver the Dongle Key for Windows 2000/NT/XP, 

then you could use RDP2000 successfully in Windows 2000/NT/XP. 

 

 

 

Chapter 2 Interface  

2.1 Usage of Mouse, Keyboard, Dialog Box and Menu 

2.1.1 Usage of Mouse 

A standard mouse has three buttons, left button, middle button and 

right button. In RDP series, left and right buttons are the common buttons. 

The left button is the basic button, accomplishing nearly all the tasks, 

while the right one is mostly for some Shortcuts, like fast selection of the 
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menus and the operations of some special effects achieving. 

Apart from the text inputting of the dialog boxes, mouse can fulfill 

all the other tasks, Operations of mouse in RDP2000: 

Click: click left (or right) mouse button once. 

Double click: click left (or right) mouse button twice continuously. 

Drag mouse : press the left ( or right ) mouse button and drag the 

mouse to some other place in the interface at the same time. 

Release mouse: release the left (or right)mouse button. 

2.1.2 Usage of Cursor 

In RDP2000 you can choose large cursor or small cursor. The shift 

between the two cursors is quite convenient:F3 key on the keyboard or 

Large Cursor\ Small cursor in Setup menu. 

Large Cursor is an arrow with horizontal and vertical direction 

lines while Small Cursor is only the Arrow itself. 

2.1.3 Usage of Keyboard 

In RDP2000, keyboard is used to input text in the design or 

numerals in the dialog boxes. And there are quite a few Shortcuts in 

RDP2000. 

2.1.4 Usage of Dialog Boxes 

When select some items in the menu of click some right mouse 

button, a dialog box will pop out. In it, you can adjust parameter setup, 

add information, select options, select text of accomplish some other jobs. 
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Label Box: label dialog box is actually a series of dialog boxes. 

You can open any of the dialog boxes by clicking the labels at the top. 

Text Box: you can input texts in the text box. Click at the blanks of 

the box, input the desired text and click OK or press Enter on keyboard. 

List Box: it will show all the options, from which you can choose 

an item by double clicking it. Pulldown Box: it is a rectangle box with an 

arrow in the right. A click of the arrow will bring a dialog box and you 

can adjust the setups in it. 

Check Box: it is a switch box. A click at it can set it on or off. 

When there is the mark (v), it is on, and without is, it is off. 

Option Box: it is a series of round boxes providing different 

options. In one group of options, only one option can be chosen. When 

you select one and click it, there will be a black dot in the box. 

Combo Box: it is a combination of a numeral input box and two 

arrows, providing the input of numerals. You can input the numeral in the 

box directly from the keyboard or click the arrows to increase of decrease 

the number in it. 

Command Button: it is a button representing some certain orders. 

When clicking a Command button, there will be usually another dialog 

box pop-up or the execution of the command. 

There is a Scroll Bar in many of the list boxes and pulldow boxes. 

They are used to show the information that exceeds the box. You can 
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click it to see the information out of present area. 

When options in the boxes are grayed, they are not available now. 

When opening dialog boxes, there will be some default settings. You can 

choose to accept them by clicking OK or choose to adjust them. 

The key of OK is used to confirm the operations and get them 

started. In case some adjustment has been carried out in mistake, you can 

click Cancel. Click Help and you can get the information about the dialog 

box. 

2.1.5 Usage of Commands in the Menu 

RDP2000 has a similar interface and menu with that of Windows: 

To Choose Commands with Mouse: 

Commands: Click the name in the menu to open it and then click 

the command in the menu. 

Switch Commands: Those with the marks (v) are switch 

commands. When there is the mark in front of the command, it is on. 

Otherwise, it is off. Click it with mouse to open or close it. 

Close Menu: Click at any position outside the menu. 

To Choose Commands with Keyboard 

1. Press the key of Alt, at the same time press the underlined letter 

to activate the menu. For an example: For File menu, press Alt and F at 

the same time and you will open it. 

2. Press the underlined letter to activate the command. For 
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example pres the letter of O to activate the command of Open. 

3. Press the key of Esc to close the menu. 

4. The Shortcut in the commands is usually a combination of two 

keys. When using the Shortcut, you should press Shortcut and an assistant 

key at the same time. 

2.2 Starting RDP2000 

You can start the program in the same way as you start other 

Windows programs. 

To Start RDP2000 

You can start program in the following steps: 

Double click the program shortcut in the Windows Desktop. 

Or Click the Start Button on Windows Desktop, and the click the 

program icon in Program Files. 

The interface of Richpeace Design Pro 2000 will show as 

follow(2-2-1):  

 

                        2-2-1 
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2.3 Using Toolbars 

2.3.1 Toolbars in RDP 2000 

The Interface of RD2000 is mainly series of Toolbars. 

Standard Toolbar: a collection of commonly used orders(2-3-1-1). 

 

                      2-3-1-1 

Property Bar: the reference to the objects or text. It shows the 

properties in buttons and combo boxes of the objects or orders chosen. 

You can setup of adjust the parameter of an object directly on the 

Property Bar. 

Note: 

When you setup or adjust the parameter in the property Toolbar by 

filling in numerals, you must press Enter key. 

Draw Toolbar: consists of different Tool Buttons. You can click 

these buttons to activate the drawing tools with which you can draw the 

basic geometry graphics(2-3-1-2). 

 

                 2-3-1-2 

Edit Toolbar:(2-3-1-3) 

 

                   2-3-1-3 
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Punch Toolbar 1&2: consists of series of stitch tools(2-3-1-4). 

  

               2-3-1-4 

Browse Toolbar: consists of different buttons for ways of browsing 

the stitches(2-3-1-5). 

 

              2-3-1-5 

Color Toolbar: there are 100 colors available and each button 

represents a color of them. You can add different colors to different 

graphics of objects for easy distinguish in your design and representation 

of the embroidery threads(2-3-1-6). 

 

                  2-3-1-6 

Status Bar: the information on Status Bar shows the present 

operation. It can be set in one column or different columns. 

The program has set these Toolbars in their set places in the 

interface. But they are adjustable. You can drag them into the shape you 

like or to the place you want them to be. You can also set them to be 
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hidden so that you can have a large design window. 

2.3.2 To Display or Hide Toolbars 

To enlarge design window, you can hide the Toolbars that are not 

necessary at the moment. 

You can hide Toolbars in the following steps: 

1.Open View menu and choose Toolbar. 

2.Click the Toolbars to be hidden of displayed in the list. 

Note:  

Toolbars are switches in the list, the mark (v) in front of the 

Toolbar refers that it is now in display. 

2.3.3 To Change the Shapes and Positions of Toolbars 

The positions of Toolbars are changeable; you can get them into 

drifting windows and drag them along in the interface for your 

convenience. 

To drag Toolbars in the interface, you can follow the following steps 

Point the mouse to the edge of the Toolbar and press the mouse, drag 

the Toolbar to any place in the interface and release the mouse, the 

Toolbar will become a drifting window. You can move it to the desired 

place in the interface. At the same time, the name of the Toolbar will be 

displayed at top of the drifting window. 

To change the shapes of Toolbars, you can adopt the following steps: 

Point the mouse to the edge of the drifting window of the Toolbar, 
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the cursor will show as a Double Arrow, you can drag the Double Arrow 

and change the Toolbar into the desired shape. 

Note:  

A double click of the mouse on any point of the edge of the Toolbar 

will get it back to the original place and shape. 

The above operations could only be realized when you choose 

Auto Size for the toolbar from Setting/ Options/ Initialization, Otherwise, 

if you choose to set the Row of Column number for the toolbar in Setting 

/ Options / Initialization, you cannot change its shape thus freely. 

Please note the setup works only after restarting RDP2000. 

2.3.4 To Define Status Bar 

   You can get information on the commands you are carrying out 

on Status Bar. The Status Bar can be divided into several columns and 

show different information in different columns. The size of columns is 

adjustable so that more information can be displayed. 

Usually, Stitch Details, Color Information, Spacing and Stitches are 

set in the Status Bar. Sometimes the status of mouse and keyboard, date 

and running time can also be set in the columns. Snap information to Grid, 

Guidelines and Objects and Text Information are also often set in 

according to your need. 

To set Columns 

Status Bar can be set into2, 3, 4,5or 6 columns according to your 
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need. 

Click right mouse button at any point of the Status Bar. 

Point the mouse at Column Number in the pop-up menu and choose the 

number of columns. 

Note: 

To change the size of the columns, point the mouse to the edge of 

column and the cursor will show as Double Arrow. Draw the Double 

Arrow along to set the column to the desired size. 

To Shift Between Large and Small Status Bars 

Click right mouse button at any point of the Status Bar and click at 

Large Status Bars of Small Status Bars. 

You can also drag the top and bottom of the Status Bar to change 

the size of them. When in Large Status Bar, the information will be show 

in two lines if it can’t be display in one line. 

To Change the Position of Status Bar 

Status Bar can be positioned at the bottom as well as the top in the 

interface. 

Click right mouse button at any point in the Status Bar, then click 

Place at Top or Place at Bottom in the pop-up menu. 

Information Display Setup for a Column 

Each column of the Status Bar can be set to show different 

information 
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Click right mouse button at any of the columns of the Status Bar 

and select Show in the pop-up menu. 

Click the item to show in the column selected. 

Information Setup  

Double click any column and corresponding a dialog box will 

show the possible information that can be shown in the column. 

Following is an example of Object Details: 

1. Double click any point in the column of Object Details and a 

dialog box will show and follows: 

2. Select the items for the information in the switches. 

3. Click OK. 

In this example, the information of active and total stitches, color 

number and needle number, snap and print status will show about the 

object. You can setup each column in the same way. 

 

 

 

Chapter3 Create, Open or Close a File 

3.1 Creating and Opening a File 

When entering the interface of RDP2000, the program will open 

your last edited file, in this situation you can open another exiting file or 

create a new file. 
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3.1.1 Creating a New File 

You can create a new file in the following steps: 

Open File menu and choose New. 

Or double click new button on Standard Toolbar. 

And a new file is created and in the design window the page of the 

new file appears. The file bears the name of Design1, Design 2 etc 

according to the creating order of the files. 

SHORTCUT: Ctrl+N 

3.1.2 To Open an Existing File 

You can open and existing file in the following steps: 

1. Open File menu and choose Open 

Or double click the Open button on Standard Toolbar. 

The standard Windows dialog box of Open will appear on the 

screen. 

2. Select the file name in the list of flies and click it , then click 

Open. Double clicking the file name can also open the file. 

 If the file to open is not in the list, you can change the file holder 

or the file format. 

3. Enable the check box of Preview and/or Document Information 

to show the thumbnail and/or information of the file to be selected to 

ensure the file to be opened is the right file. 

Note: 
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To open a recent file, click the file name to be opened in recent file 

list in File menu. 

If the file to be opened is a paper tape file, the outline of its will 

appear on the screen first and the coordinates of its starting point will also 

be shown on the screen, which will help you position the design. 

To preview the content of the file, check the box of Preview and 

also check the box of Document Information if you want to examine the 

details of the file at the same time. 

SHORTCUT: Ctrl +O 

3.2 Saving a File 

During the process of creating a design, it is necessary to save your 

work from time to time so as to avoid losing data accidentally. Before you 

close a file or exit RDP2000, you should save your work, or your present 

operation will be lost. 

3.2.1 To Save a file in RDP2000 format 

You can save a file in RDP2000 format: 

1. Open File menu and choose Save 

Or click Save button on Standard Toolbar 

If this is the first time for you to save the file, the standard 

Windows dialog box of Save As… will appear: 

2. Click the Drive Name in the Save In box to select the drive and 

file holder. 
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3. Input the name for the file in the text box of File Name. 

4. Click Save 

Note: 

If the file has been saved before, you can click Save button or 

choose Save in File menu to save the modifications to the file. 

The input for the file name can be as long as 255 characters and the 

input cannot be any of the following: (/), (\), (<),(>), (*), (.), (?), 

(“),(:)or(;). 

SHORTCUT: Ctrl + S 

3.2.2 To Change Name, Location or Format when Saving 

For an existing file, you may need to save it in another format, 

place it in another file holder or save the change but not cover the original 

file. In these cases, you can use the command of Save As… 

1. Open File menu and choose Save As… 

The dialog box of Save As… will appear. 

2. In case you need to save it to another folder, select the folder for 

it in the list of Save In… 

3. In case you want to save it in another name, input the name for 

it in the text box of File Name. 

4. In case you want to save it in another format, select the format 

for it in the list of Type. 

5. Click Save. 



 24

The program will save the file according to the changes thus made. 

3.2.3 To Save All Files 

Using the command of Save All you can save all opened files 

together at the same time. 

From File menu choose Save All. 

Or Click the Save All button. 

3.2.4 To Setup Auto Save 

You can choose the program to auto-save your work for you and 

setup the time intervals for the auto save, so that even if you should meet 

accident turn-off of your computer or illegal operation, your operation 

will still be saved in the set time intervals. 

1. Open Setup menu and then choose Options. 

2. Click the label of Auto Save(show here as in 3-2-3 ) 

 

                         3-2-3 

3. In the dialog box, check the box of Auto Save. 

4. Set the Auto Save Interval for Auto Save. You can input the 

time interval in the text box or click the arrows to get to the number. 

5. Decide whether you need the program to remind you when 

auto-saving your digitizing based on the save intervals. If you need , 

check the box of Prompt when auto-saving, if not , uncheck it. If you 
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want the program to run foreground when auto saving, check the Check 

box of Run foreground when auto saving. 

6. Click OK. 

3.3 Closing a File and Exiting RDP2000 

When you have finished creating and modifying a file, and have 

saved it to the hard disk or a floppy disk, you can choose to close to file. 

And when you have finished all the tasks in the program, you can choose 

to exit the program. 

If there is still some unsaved work when you close the file or exit 

RDP2000, the program will remind you to save the modification of the 

file. 

3.3.1 To Close a File 

You can close a file in the following steps: 

Click Close button   in upper-right corner of the design window. 

Or open File menu and choose Close. 

the file to close has not been saved, the program will remind you to 

save it(shown here as in 3-3-1) 

 

               3-3-1 

Click Yes and program will save the file before closing it. 

Click No if you don’t want to save the modification to the file 
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before closing it. 

Click Cancel to cancel this operation and go back to the file. 

3.3.2 To Exit RDP 2000 

You can exit the program in the following steps: 

Open File menu and choose Exit. 

Or click Exit button  in the upper-right corner of the interface. 

If the file has not been saved, the program will remind you to save 

it before exiting. 

 

 

 

Chapter 4 Basic Operations 

Once you start working with RDP2000, you use commands and 

dialog boxes to complete your task. You can choose commands in 

RDP2000 in the same way as in other Windows 95/98 

applications----from pop-up menus or toolbars. You can also use 

keyboard shortcuts for most frequently used commands. 

To most of the commands, you can select Undo or Redo for the 

cancellation and repeat of them. If you need help on a command, you can 

select the command from the Help menu, click a Help button or start 

context sensitive help. 

In this chapter, we will discuss the most frequently used 
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commands. 

4.1 Selecting an Object 

In RDP2000, you need to select the object with a select tool before 

modifying or editing it. There are three select tools in RDP 2000. 

Pick Tool:  you need to select the object with Pick Tool before 

you use any of the following commands: Move, Mirror, Copy, Rotate, 

Change Size, Modify Attributes, etc. You can also select multi objects for 

the editing or modification. 

Shape Tool:  you can use Shape Tool to modify the outline of 

an object or adjust edit nodes. You can select and edit one object once 

only. 

Edit Stitch:  you can use Edit Stitch to select the stitch for 

editing or modification. 

When you need to select an object or stitches, click the tool button 

first and then click at the object or stitches. 

The following illustrates the operation: 

To select an Object with Pick Tool 

1. Click Pick Tool button on View Toolbar. 

2. Click at any point of the object or the outline of the object. 

The object is shown in the selected state with 8 handles showing 

the size of the object. You can change the size and shape of the object by 

dragging the handles ( shown here as in 4-1). 
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                    4-1 

4.2  Undoing and Redoing Commands 

If you are not satisfied with the effect of the last few commands, 

you can undo them. You can also redo them if you later decide you didn’t 

want to undo them. 

4.2.1 To Undo Last Command 

Open Edit menu and choose Undo 

Or click the Undo button on Standard Toolbar. 

Or click right mouse button and choose Undo. 

You can undo several commands in sequence , but please be noted 

that not every command can be undone. 

You should not use Undo more than 3 or 4 times. In need to do so, 

it is more different to modify the design. 

SHORTCUT: Ctrl +z. 

4.2.2 To Redo Last Operation 

Open Edit menu and choose Redo. 

Or click the Redo button on the Standard Toolbar. 

Or click right mouse button and choose Redo. 

You can redo several commands, but please be noted that not every 
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operation can be redone. 

SHORTCUT: Ctrl +Y 

4.3 Zooming and Panning Objects 

Click Zoom Tool button and the Property Bar of zoom will 

appear(show here as in 4-3-1 ). 

 

                   4-3-1 

It is a series of buttons to zoom in and out of the design and pan it 

around in the design windows, so that you can observe the details or the 

whole of the design. And when part of the design is out of the design 

window, you can pan it around to focus on the part out. When Zooming in 

and out of the design, you will not bring any change to the size of it, it 

only effects the display scale of the design in the design window. 

And, a Zoom Toolbar is available in the program ( shown here as in 

4-3-2): 

 

            4-3-2 

The buttons on Zoom Toolbar represent exactly the same 

commands as those on the Properties Bar, but they are valid only for one 

operation each time you click it. 

4.3.1 To Zoom Objects 
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1. To make stitches or objects in the design appear twice larger, 

click the button of Double Current Size.  Shortcut: Ctrl +Z 

2. To make stitches of objects in the design appear twice smaller, 

click the button of Half Current Size button.  

Shortcut: Shift + Z 

3. To display the design in the final embroidery size, click the 

button of Zoom to Actual Size.  

4. To zoom in and out of the design in real time, click Zoom in 

Real time Button.  

Dragging of the mouse upwards zooms in the objects, and dragging 

of the mouse downwards zooms out the objects. 

5. To Zoom in the selected area, click Zoom in Selected Area 

button. Then drag the mouse to circle the objects in the spring box and 

click right mouse button, the selected area is zoomed in. 

6. To fit selected object in the window, click Zoom to Selected 

button.  

7. To fit in all objects in the window, click Zoom to All button  

8. To fit in the whole page, click Zoom to Page button.  

9. To fit in the width of page in the window, click Zoom to Page 

width button.  

10.  To fit in the height of page in the window, click Zoom to Page    

Height button.  
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11. To zoom according to ratio, click the arrow of combo box of 

Zoom Ratio (shown here as in 4-3-3)and select a ratio of input the ratio in 

the text box and press Enter key on the keyboard. 

 

      4-3-3 

Note: 

When you have selected Zoom Button, a click of right mouse 

button will bring a Zoom List. You can also choose commands from the 

pup-up menu (shown here as in 4-3-4) 

                
                 4-3-4 

4.3.2 To Pan Objects 

When you zoom in objects, sometimes parts of the objects may be 

out of the window. In this case, you can pan the objects around in the 

design window with Pan in Real-time. 

Click Pan in Real-time button  in Zoom Toolbar and the cursor 

becomes the shape of a hand. Drag it and the objects or pattern will move 

around in the window.  

4.4 Full Screen Displaying the Design 
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Full Screen Display only shows the whole pattern without the 

menus or Toolbars. In the mode of full screen, you can use the Shortcuts 

on keyboard. You can get back to the normal state by press Esc key on the 

keyboard or click Full Screen button.  

4.4.1 To display the design in Full Screen Mode 

Open View menu and click Full Screen Display. 

Or click right mouse button and choose Full Screen Display in the 

pop-up menu. 

Or press F9 on the keyboard. 

In the Design Window only the design is shown. 

In the Full Screen Display mode, you can carry out the following 

operations:  

Select hide or display Ruler: Click Ruler button. 

Examine objects with Zoom in Real time: click Zoom in Real time 

button.  

Pan objects around in the window: click Pan in Real time 

button.  

Note: 

In the mode of Full Screen Display, Shortcuts are all available. 

4.4.2 Exit Full Screen 

Click the button  in the Full Screen Floating Bar. 

Or press Esc key on keyboard. 
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Or press F9 on keyboard. 

4.5 Measuring Distance on Screen 

You can use Ruler to measure the distance and angle between any 

two points directly on the screen. 

To Measure distance and angle with Ruler on the screen 

1. Click Ruler Button  on Punch Toolbar. 

2. Point cursor to one of the two points and click it , then point the 

cursor to the other one of the two points. 

Now, in the left of the Status Bar, the distance and angle between 

the two points will appear. 

3. Click the mouse to end the operation on these two points. 

4.6 Usage of Ruler, Grid and Guidelines 

Ruler, Grid and Guidelines are used to help you protract exactly or 

arrange objects, when in need, you choose to display Ruler, Grid and 

Guidelines, so that you can get an exact alignment on the objects. 

You can also adjust them. And Snap to Grid or Guidelines can 

bring ‘magnetic’ to the Grid and Guidelines, so guiding the object to align 

to grid or Guidelines accurately. 

4.6.1 To Hide or Display Ruler, Grid and Guidelines 

Open View menu, click Ruler, Grid or Guidelines. 

When no object is selected, click right mouse button and select 

Ruler, Gird of Guidelines if the pop-up menu. 
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Note: 

Ruler, Grid and Guidelines are switch commands. When they are 

selected, there will be a mark(√)in front of them in the menu, or , they 

are not selected and will not be displayed. 

You can also display or hide them in Layer Manager. Please refer 

to Layer Manager for details. 

When choosing Snap to Grid or Snap to Guidelines, you can align 

the object accurately to the Gird or Guide. Please refer to Snap to Grid 

and Snap to Guidelines for details. 

4.6.2 Parameter Setup of  Ruler 

1. Open Layout menu and choose Grid/Ruler Setup. 

2. Click the Label of Ruler. The Dialog box of Ruler(shown here as 

in 4-6-2-1) appears: 

         

               4-6-2-1 

3. Set the unit for Ruler: select the unit in the box of Horizontal. 

If you have checked the box of Same Unit, the unit for Vertical will 

be set the same as Horizontal. You can also set the unit for them 
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separately. 

4. Set Origin Point of Ruler: before using the Ruler, you need to set 

the Origin Point of it: input values in the boxes of Horizontal and Vertical. 

The value is the distance from the Origin to the Upper Left Point of the 

page. 

5.You can also set the Origin with mouse: point mouse to the cross 

point of the horizontal and vertical rulers, drag the mouse into the 

window and release the mouse when you have got to the desired point 

(process shown hers as in 4-6-2-2) 

4.6.3 Parameter Setup of Grid 

1. Open Layout menu and select Grid/Ruler Setup. 

2. Click the Label of Grid. The dialog box of Grid (show here as in 

4-6-3-1) appears: 

 
       4-6-3-1 

3. Check the option box of Frequency or Spacing. 

Frequency: the distance is decided by the dots in an inch. 

Spacing: the distance between the lines of grid Vertically or 

Horizontally. 
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4. Set the values for Horizontal and Vertical of Frequency or 

Spacing. 

5. Set Reference Point of Grid: it is for the exact position of the 

Grid, Input value in the boxes of Horizontal and Vertical. The values 

indicate the distance between the Reference Point of Grid and the Origin 

of Ruler. 

6. You can also set the Reference Points with mouse: 

a. Point mouse to the cross point of the rulers and drag the mouse 

into the Window while press the key of Ctrl. 

b. Release the mouse when you get to the desired point (process 

shown here as in 4-6-3-2) 

Note: 

*Grid can be represented by lattice or lines. 

*Check the box of Draw Grid and the grid is shown in horizontal 

and vertical lines. 

Uncheck the box of Drew Grid and the grid is shown in dots. 

*You can check or uncheck the box of Show Grid to show or hide 

grid. 

You can check or uncheck the box of Snap to Grid to set the 

digitizing to be snapped grid or not. 

4.6.4 Parameter Setup of Guidelines 

1. Open Layout menu and choose Guidelines Setup. 
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2. Click the Label of Horizontal. The dialog box of Horizontal 

(shown here as in 4-6-4-1) appears: 

      

               4-6-4-1 

3. Set the positions for horizontal Guidelines(the Zero Point of the 

horizontal and vertical Rulers). 

If you want to place it under the Zero Point or left of the Zero Point, 

you should input a negative number. 

4. Select unit from the list. 

5. Click Add. 

6. Click the Label of Vertical Line. The dialog box Vertical 

(shown here as in 4-6-4-2)appears: 

           

                     4-6-4-2 

7. Set the Vertical Guidelines in the same steps. 
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8. Click the Label of Slanted. The dialog box of Slanted appears: 

9. Select a way to setup parameters of Slanted Guidelines. You can 

set Slanted Guidelines in two different ways:2 PointS(shown here as 

4-6-4-3) of Angle and 1 Point(shown here as in 4-6-4-4) 

   
4-6-4-3                        4-6-4-3 

When selecting Two Points, you need to set the coordinates of the 

two points. 

When selecting Angle and 1 Point, you need to set the 

Coordinates of the corner and input the value for the angle. 

The Slanted Guidelines will pass the coordinates with the set angle. 

10. Click Add. 

Note:  

Click the Guidelines when with Pick Tool and you can get to the 

Dialog Box of Guidelines. 

4.6.5 Snapping to Grid or Guidelines 

The commands of Snap to Grid and Snap to Guidelines will add 

‘magnet’ to them and thus the objects will be snapped to the Gird of 

Guidelines. 
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4.6.5.1 To Snap to Grid 

You can get alignment of objects if you select Snap to Grid. The 

object will be forced to align to the nearest point on Grid. 

To Snap to Grid and to Cancel Snap to Grid 

When an object is selected, click the button of Snap to Grid on 

Property Bar to select of cancel it. 

4.6.5.2 To Snap to Guidelines 

Like Snap to Grid, the command of Snap to Guidelines can also get 

the alignment on the nearest Guideline. 

To Snap to Guidelines and To Cancel Snap to Guidelines 

When no object is selected, click the button of Snap to Guidelines 

on Property Bar to select or cancel it. 

Or open Layout menu and choose or cancel the command. 

Or double click Guidelines of on Status Bar, when it is grayed, the 

command is canceled. 

4.6.6 Snapping to Objects 

Snap to Object is a very useful command when digitizing, because 

the reference points will be snapped to the object so that your digitizing is 

faster and more exact. 

4.6.6.1 To Snap to Objects 

When no object is selected, click the button of Snap to Objects on 

Property Bar to choose or cancel it. 
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Or open Layout menu and choose or cancel it. 

Or double click Objects on Status Bar, when it is grayed, it is 

canceled. 

Hotkey:F12 

4.6.6.2 To Snap to a Certain Object 

1. Choose the command on in the above steps. 

2. Select the object with Pick Tool. 

3. Click right key of mouse and select Snap to of Object Operation 

Properties in the pop-up menu. 

You can also select Lock and Stop to, so that you are snapping it as 

well as forbidding editing it. 

Note: 

You can choose to snap to several objects or a group of objects. 

4.6.7 Max Distance for Snap to Grid, Guidelines and Object 

The default value of the max distance for the snapping is infinity. 

You can set the value. 

To Setup Distance for Snap to Grid, Guidelines and Object  

1.Open Setting menu and choose Options. 

2.Click the Label of Snap. The dialog box of Snap(shown here as in 

4-6-7) appears: 

3.Check the box of Grid. 

4.Set the Max Distance for the snap to the Grid in the unit of 
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Pixels. 

 

           4-6-7 

5.Setup the Max Distance for Guidelines and Objects in the Above 

steps. 

6.Click OK. 

4.7 Examining Designs 

To examine a design more conveniently, you can choose to hide or 

display some properties of the design, like stitches, needle penetration, 

outline, connection line, some or all of machine codes of the objects. For 

an example, when you examine outline of object, you can hide stitches 

and needle penetration. And when you examine stitches, you can hide the 

outline of the objects. 

To Display of Hide Stitches, Needle Penetration, Jump, Outline, 

Connection Line, Machine Codes, and Starting Point 

Open View menu, and then choose to display or hide them. 

Please be noted that all these are switch orders, and the marks(√)in 

front of them show that they have been selected and will be displayed. 

Otherwise, they will be hidden. 

Pressing of the Space Bar on keyboard displays of hides Needle 
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Penetr-ations. 

4.8 Usage of Multi Windows 

You can open several windows at the same time in the program, 

and you can arrange them in tiles or cascades so that all the windows will 

be shown in the screen. You can also shift among the windows at any 

time. 

4.8.1 Cascades 

The command of Cascade is used to arrange the window in vertical 

cascades. 

1. Open several windows. 

2. Open Window menu and choose Cascade. 

3. All the open windows will be arranged in vertical cascades. 

Note: 

To shift among the windows , simply click the window to shift to. 

4.8.2 Tiles 

The command of Tile is used to arrange the windows in horizontal 

tiles. 

1. Open several windows. 

2. Open Window menu and choose Tile. 

3. All the open windows will be arranged in horizontal tiles. 

Note: 

To shift among the windows, simply click the window to shift to. 
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4.8.3 Arrange Icon 

When all the windows are minimized, Arrange Icon can arrange 

all the icons of the windows in the alphabetic order. 

1. Minimize all the windows. 

2. Open Window menu and choose Arrange Icon. 

3. All the icons will be arrange in the alphabetic order. 

4.8.4 Shift among Windows 

Open Window menu and you can shift to the window by clicking 

the window name in the List. 

4.9 Page Setup 

Before staring a new file, you may want to know what size the 

page should be. The default page setup is A3. You can adjust the size, the 

direction or the color of the page, you can also create your own page size 

and save it. 

You can set the size, the direction and the color of the page in Page 

Setup. You can also set them in the Properties Bar. 

You can get the Page Setup in Properties Bar whenever you click and of 

the buttons of Pick Tool or Shape Tool (shown here as in 4-9) 

 

                     4-9 

4.9.1 Page Size Setup 

There are a few preset sizes and directions of pages. You can select 
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one from them or create a new size and direction on your own. 

1. Open Layout in the Program Menu and select Page Setup. 

The dialog box of Page Setup will shown in the screen (shown here 

as in 4-9-1): 

 

                  4-9-1 

2. Select one in the list of Type or select User-define. 

3. Input the width and height in the text box of through the arrows. 

4.9.2 Page Direction Setup 

You can choose to place the page horizontally or vertically. 

1. Open Layout menu and choose Page Setup. 

2. Choose Landscape for Horizontal or Portrait for Vertical. 

Or click the Portrait Button  or Landscape Button on 

Properly Bar. 

4.9.3 Display or Hide Page Border and Shade 

Page border is a rectangle in the window, showing the size and 

direction of the page. Page Shade is the shade around the page border. 
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You can choose to display them or hide them. Please be noted that before 

printing, you should choose to display them so as to make sure the objects 

are within the border of the page. 

1. Open Layout menu and choose Page Setup. 

2. Choose to display or hide border and shade. 

Or click Border  and Shade  buttons to display or hide 

them. 

Note: 

Double click the shade in the interface and the dialog box of Page 

Setup will appear. You can set the shade only after you have selected the 

page border. 

4.9.4 Page Background Setup 

Page Background Color Setup 

You can select different colors as the background of the page. 

1. Open Layout menu and choose Page Setup. 

2. Click the arrow in the button of Page Color and the Dialog. 

Box of Color Mixing will appear. You can select the color or mix the 

color in the dialog box of Color. 

3. Click Ok. 

Note: 

You can also set the color for background through the Background 

button.  
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And there are three kind of default colors: 

Ctrl +Alt +W White Grounding 

Ctrl + Alt + B Black Grounding  

Ctrl + Alt +G Grey Grounding  

You can select one of them of Background Color of Setup menu. 

Set Page background with a fabric picture. 

You can set the page background filled with a bitmap picture, in 

this way, you can insert some fabric picture into the program as the 

design background. 

You can choose to insert the bitmap picture temporarily by Link 

way or save it together with the design through Embed way; there are 

three kinds of different display modes for the fabric background. 

Centered, Tiled and Extended; to choose Zoom Enable, the 

picture will be zoomed in or out together with the window; to set the 

position of Top Left Corner could change the relative position of the 

picture in the page. 

4.10 Get Help On-Line 

Help On-Line is the details and instructions to the commands and 

functions of the program, You can get Help On-Line at any time or stage 

of your designing through Help menu. 

4.10.1 Get Help Information 

Open Help menu and select Help Topics and the dialog box of 
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Help Topics: Help on-line (shown here as in 4-10-1) will appear. 

       
               4-10-1 

There are three label boxes. Contents Index and Find, Under Index 

are the topics of help; you can select a topic and double click it to get the 

help information in the information window. 

You can preview, copy, print or even annotate the information or 

the help topics.  

You can also click the label of Index to open the text box of Index 

and input the key words to get to the topic of help. 

Double click help topic or click Display button can both open the 

information window. 

SHORTCUT: F1 

Note: 

There is a Help button in some of the dialog boxes. Click it and 

you can get the help information on them. 

4.10.2 To Get Clue on Window 
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Window Clue gives you the simple information about the 

commands in Menu or button in Toolbars. 

Get Screen Clue 

1. Click the help button on Standard Toolbar. 

2. Point the mouse to the command or button on the screen, and 

there will be the information about it near it. 

4.10.3 About Richpeace Design Pro2000 

There is another item in Help menu: About Richpeace Design Pro 

2000. It is the information about the present version of the program. 

Open Help menu and choose About Richpeace Design Pro 2000. 

Or click About Richpeace EmbDesign 2000 button on Standard 

Toolbar. 

The dialog box of About Richpeace Design Pro 2000(shown here 

as in 4-10-3)will appear in the design window: 

      

                    4-10-3 

 

 

 



 49

Chapter 5 Input Method 

The digitizing procedure in embroidery designing is in fact a series 

of inputting of lines and curves, describing the outline of the embroidery 

stitch objects. When carrying on the digitizing in your designing, an input 

method should be selected. 

The input methods RDP2000 Series offered includes: Richpeace 

Design Pro 2000 Input Method, Richpeace Punch II Input Method (Arc), 

Richpeace Punch II Input Method (Spline) and Ricpeace Punch Input 

Method. You can apply Side by Side input, Side to Side input, Midline 

input and Close Curve input method to these four types of input method. 

Richpeace Punch II Input Method (Arc)  

It is a combination of Line and Arc inputting, and involves three 

mouse buttons: the Left Button inputs Lines while the Right Button 

inputs Arc, to end the input, click Middle Button. For the mouse with nly 

two button, you can use the Enter key to replace the Middle mouse 

button. 

Richpeace Punch Input Method (Spline)  

It is a combination of Line and Spline inputting, and involves three 

Mouse button: the Left Button inputs Lines while the Right Button inputs 

Splines, to end the input, click Middle Button. For the mouse only have 

two buttons, you can use the Enter key to replace the Middle mouse 

button. 
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Richpeace Punch Input Method  

It is an Arc Input Method, and involves two mouse buttons: the 

Left Button inputs arcs and the Right Button Ends the input. Pressing on 

the Ctrl key while inputting with Left Button will input Lines. 

Richpeace Design Pro 2000 Input Method  

It is the basic input method of RDP2000 Series. It is based on the 

Compound Curve input and it can input five types of curve: Line, Spline, 

Arc, Cubic Bezier and Quadric Bezier. And it involves two buttons: the 

left mouse button input lines and the right mouse button finish the input. 

5.1 Regulation of Inputting Method 

1. In the environment of RDP2000, a click of left mouse button 

refers to INPUT and the right button refers to FINISH. 

2. If you have marked some wrong Reference Points when 

digitizing, you can press Backspace key to cancel them one by one. 

3. During the digitizing process, you can press Esc key at any time 

to cancel last input. It can be an outline, a Direction Line, Entry or Exit. 

Continuous pressing of the Esc key can cancel all the previous operation. 

4. When digitizing an object, you can modify and reference point 

or outline before stitches generate. Pressing of Space Bar will shift to the 

mode of Temporary Edit. You can add, delete, and move the Reference 

Points. Another pressing of Space Bar will shift the program back to 

Digitizing Mode. 
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5. When digitizing with vector graphics as Background, Snap to 

Object will greatly increase the precision of the Reference Points, and 

thus speeds up the digitizing. Please refer to Snap to Object for detailed 

information on usage. 

6. When finishing inputting Reference Points, continuous clicking 

of right mouse button bypasses the steps of manual input of Direction 

Lines, Entry and Exit. The program will set them and auto-generate the 

stitches. Please refer to Auto Generation of Stitches for detailed 

information. 

7. When inputting Reference Points, you can input horizontal, 

vertical or 45 lines by holding Ctrl key. 

8. Side to Side and Midline input objects can be transferred to Side 

by Side input objects at any time. Select object with pick tool or shape 

tool, click the right mouse button to choose Shift to Side to Side Input. 

9. When inputting the outline for Side by Side, Side to Side and 

Midline input objects, you can set different color for two borders of the 

outline. In Setting/Display Color Setup dialog box set the color (Outline 

refers to the first border color, Satin Second Border refers to the second 

border color.) 

10. Side to Side and Midline input objects can be transferred to 

Side by Side input objects at any time. Select object with pick tool or 

shape tool, click the right mouse button to choose Shift to Side to Side 
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Input. 

11.When inputting the outline for Side by Side, Side to Side and 

Midline input objects, you can set different color for two borders of the 

outline. In Setting/ Display Color Setup dialog box set the color(Outline 

refers to the first border color, Satin Second Border refers to the second 

border color.) 

5.2 Side by Side Input Method 

It is a suitable input method for digitizing embroidery objects with 

narrow sides or two irregular sides. It marks Reference Points on both 

sides of graphics and creates evenly spaced stitches all over the objects. It 

is applicable in Satin Stitch, Satin Stitch With Jump, Zig Zag Stitch, 

E-Stitch, 3D Stitch, Turn Fill Stitch and Classic Column Fill Stitch. 

To Digitize Designs with Side by Side Input 

We will take Satin Stitch for the example: 

1. Select a stitch for digitizing. 

For Satin Stitch, click Satin Stitch Button. 

2. Click Side by Side Input button on Input Toolbar. 

Or switch to Side by Side Input by pressing Shift key on the 

keyboard. 

3. Click left mouse button to input Reference Points on the first 

side. You can shift among different Lines and Curves according to the 

shape of the objects in the process of the digitizing. 
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If some Reference Points have been input out of desire, press 

Backspace key to cancel them. After inputting all the Reference Points, 

click the right mouse button(shown here as in 5-2-1) 

 
               5-2-1 

4. Now you can start inputting Reference Points on the second side 

in the same process. Up finishing , click the right mouse button(shown 

here as in 5-2-2) 

    
                     5-2-2 

5. If no Direction Line is needed, just simply click the right 

mouse button(shown here as in 5-2-3). 

  

                 5-2-3 
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Direction Lines are added to define the direction of stitches. Please 

reference to Direction Line to get detailed information for the usage. 

6. Input Entry and Exit of the object and click right mouse 

button(shown her as in 5-2-4). 

  

Please be noted that usually the Entry is at the opposite side of the 

Exit, and usually the first point marked. Generally, Entry is placed at the 

upper left corner of the pattern while Exit at the lower right corner of the 

pattern, In actual designing, the Exit of a pattern is mostly placed near the 

Entry of the pattern following it. 

Satin Stitch will be filled into the object automatically after these 

processes. 

5.3 Side to Side Input 

It is suitable for the digitizing of narrow objects. When using this 

method, the Reference Points of objects are input in pairs, thus enables a 

good control of the Direction Lines of the stitches of the object. When 

adding or deleting Reference Points, it is also in pairs. It is applicable in 

Satin Stitch, Satin Stitch With Jump, Zig Zag Stitch, E-Stitch, 3-D Stitch, 

Turn Fill Stitch and Classic Column Fill Stitch. 

To Digitize Designs with Side to Side Input 
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We’ll take Satin Stitch for the example: 

1. Click Satin Stitch button in Punch Toolbar, Click Side to Side 

Input button or press Shift key to switch to it. 

2. Use mouse to mark the Reference Points in pairs. First input the 

first Reference Point on the first side, then the first Reference Point on the 

second side, and the second Reference Point on the first side, then the 

second Reference Point on the second side, and so forth. In this way you 

can mark all the Reference Points on both sides of the pattern in pairs 

(shown here as in 5-3-1). 

            

                    5-3-1 

When inputting a wrong Reference Point, you can press 

Back-space key on the keyboard to delete it. You can press the key 

continuously to delete several wrong Reference Points. 

When finishing input, click right mouse button. 

3. Mark the Entry and click right mouse button. The Exit is added 

at the same time, and the object is filled with Satin Stitch (shown here as 

in 5-3-2) 
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                   5-3-2 

Note: 

The Reference Points are digitized in pairs. When modifying the 

Reference Points, you are not only modifying the shape of the object, but 

also modifying the Direction Line of the stitches. 

5.4 Midline Input Method 

It is an input method with only the Midline, which marks the shape 

of the object to digitize. It is suitable for patterns with same width. It is 

applicable to all the Stitches except Running Stitch, Manual Stitch, Fill 

Stitch and Motif Fill. There are three ways to input with Midline: 

generate stitches on the Left Side, Right Side and Both Sides. 

To Digitize Designs with Midline Input 

We’ll take Satin Stitch for the example: 

1. Click Satin Stitch button on the Punch Toolbar 1. 

2. Click Midline Input button or press Shift key on the keyboard 

to shift to Midline Input method. 

3. Digitize the Reference Points along the Midline of the 

pattern(shown here as in 5-4-1). 
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                    5-4-1 

4. If you need to add Direction Lines, you can mark them now and 

click right mouse button when finishing (show here as in 5-4-2) 

          

                    5-4-2 

Please refer to Direction Line for details. 

If you do not need the Direction Lines, please press N key of the 

keyboard and right mouse button at the same time. 

5. To mark Entry of the pattern, click right mouse button. 

The Exit is positioned at the opposite on the object and stitches 

generate(shown here as in 5-4-3) 

         
                      5-4-3 

To Setup Parameters for Midline Input 

There are three ways of Midline Input according to the position of 

stitches generated: 

1. Click the Midline button in the Property Toolbar. The dialog 

box of Midline will appear(shown here as in5-4-4): 
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             5-4-4 

2. Click the buttons of Left, Right or Middle to select the input 

method. 

a. When selecting Left, the stitches generate in the left side of 

the ,Midline, and Left Width is the same as Column Width(shown here as 

in 5-4-5) 

       

                       5-4-5 

b. When selecting Right, the stitches generate in the right side of 

the Midline, and the R ight Width is the same as Column width(shown 

here as in 5-4-6) 
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                        5-4-6 

c. When selecting Middle, stitches generate on both sides of the 

Midline, and the column Width is the sum of left Width and Right Width, 

and Left Width is the same as Right Width(shown here as in 5-4-7) 

        

                     5-4-7 

Note: 

Left Width, Right Width and Column Width refers to the widths of 

Left Column, Right Column and the Whole Column. 

The Left Side refers to left side of the digitizing direction of the 

Digitizing Line, and the right side of the digitizing direction of the 

Digitizing Line(shown here as in 5-4-8) 

6. Set the Value for Corner Fraction : the stitches are perpendicular 

to the digitized line throughout the column wherever it is possible. In 

tight curves and around corners, the stitches turn evenly. Corner Fraction 

decides how many stitches involve in the turning. The larger the value, 

the more stitches involved(show here as in 5-4-9)(N\A) 
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                      5-4-9 

To Shift Midline Input Object into Side to Side Input object 

You can shift a stitch object digitized with Midline Input into a stitch 

object digitized with Side be Side Input. 

1. Select the object for the modification with Pick Tool or Shape 

Tool. 

2. Click right mouse button and choose Shift to Side to Side Input. 

5.5 Close Curve Input Method 

Close Curve Input is suitable for the digitizing of large irregular 

patterns. The input outline must be a closed curve. When digitizing the 

pattern, you should input the outline first. If there are holes in the pattern, 

input the holes after inputting the outline. It is used in Fill Stitches and 

Motif Fill only. 

To Digitize Designs with Close Curve Input 

1. Click Fill Stitch button on Punch Toolbar1. 

2. Mark the Reference Points of the Outline of the pattern. You 

may leave some space between the first and last Reference Points and it 
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will be closed automatically. Click the right mouse button to close the 

pattern.(shown here as in 5-5-1) 

       
                       5-5-1 

3. Click right mouse once again to end the inputting of Reference 

Points. 

4. Mark the Direction Line, Entry and then Exit of the pattern. And 

the object will be filled with Fill Stitchs (shown here as in 5-5-2). 

 

                5-5-2 

5.6 Digitizing Design with Holes in Fill Stitch 

There can be some holes on an object if it is big and fill with Fill 

Stitich or Motif. 

When digitizing such objects, you can digitize the outline of the 

object and then the outline of the holes on the object. 

5.6.1 To Digitize designs with Holes in Fill Stitch 
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1.Click Fill Stitch button on Punch Toolbar1. 

2. Input outline of the object with the Closed Curve Input method 

(shown here as in 5-6-1-1). 

                   

                      5-6-1-1 

3.Click right mouse button. 

4. Digitize the outlines of the holes in the objects. Click right 

mouse button each time finishing the outline of a hole(shown here as in 

5-6-1-2) 

                      
                        5-6-1-2 

5. Input Direction Lines, Entry and Exit. Fill Stitch will be filled in 

the object with the holes blank.(5-6-1-3) 

         

                       5-6-1-3 
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Note: 

When embroidering designs with holes, the design will be divided 

into several sections, and stitches are filled in each of the sections, linking 

each section with Running Stitch. The Running Stitch cannot be seen in 

the products because it is covered by the filled stitches. It is divided into 

sections according to the Entry, Exit and the Direction Lines. Usually, the 

Entry, and the Direction Lines vertical to the Connection Line linking the 

Entry and Exit. In this way, the design will be divided into lesser sections 

and direct the machine to embroider in the same direction. If the 

embroidering directions are not the same in the different sections, there 

might be gaps or overlaps among sections. 

When the Holes in the design crossover or overlap each other , or 

there is another hole within a hole, they will be regarded as one hole 

according to the outline. 

5.6.2 To Add New Holes to an Object  

When you need to add holes to an object, there are two ways: Drag 

a Vector graphic to the object as the outline; or digitize the hole. 

Vector Graphic as Hole 

1. Select a vector graphic. 

2. Press right mouse button and drag the vector graphic to the 

object. 

3. Release right mouse button and select As Stitch Edge or other 
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commands in the List thus appears(shown here as in 5-6-2-1). The 

selected vector graphic will be added to the object as a hole(shown here 

as in 5-6-2-2).Please refer to As Stitch Edge for details. 

       

                      5-6-2-1 

             

                    5-6-2-2 

Note:  

You can add only one hole to object each time. 

5.6.3 To Digitize New Hole to Object 

1. Select the object to modify with Shape Tool. 

2.Click right mouse button and select Stitch Outline in Add 

Graphic Element.(5-6-3) 
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                    5-6-3 

3. Digitize the hole outline. You can digitize several hole outlines, 

click right mouse button each time finishing a hole outline. 

4. Click right mouse button when finishing digitizing all the hole 

outlines. 

5.7 Auto Generation of Stitches 

RDP2000 providers a shortcut in input method: continuous 

clicking of the right mouse button after inputting the Reference Points 

will generate Direction Lines, Entry and Exit and finally the Stitches. If 

you are not so satisfied with the effect of stitches, you can adjust them 

through Reference Points, Direction Lines, Entry and Exit. 

During this course, you can also choose to generate Direction Lines 

or not. 

To Select Whether to Generate Direction Lines 

1. Open Setting menu and choose Options. 

2. Click the Label of Embroidery. 

3. Click the box of Defaule Direction Lines when input, change 
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or fill in stitches. 

If it is forbidden, no default Direction Line will be generated 

(shown here as in 5-7). 

 

                       5-7 

Note: 

Press Y key on keyboard while digitizing and will get the default 

Direction Lines, Press N on keyboard while digitizing and you will not 

get default Direction Lines. (This does not change the setup in the Dialog 

Box). 

5.8 Marking Reference Points on Objects 

While digitizing a design, you should mark enough Reference 
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Points so that the program can recognize the outline and shape of the 

design. But too many Reference Points will cause the program to engage 

more time and so affect the precision of the design. Usually only the 

following positions need Reference Points: 

The positions where pattern widens; 

The positions where pattern changes direction; 

The positions where pattern change Bending; 

The positions where lines change into curves; 

The positions where curvatures change. 

Note:  

When marking Reference Points, you may need to input different 

types of lines: Line, Curve, Arc and Bezier. You can press Shift key on 

keyboard to shift among them in the order of Line, Curve, Arc, Quadric 

Bezier and Cubic Bezier(shown here as in 5-8).You can press the 

following letters to shift directly to the input method 

 

                     5-8 

L: Line 

S: Curve 

A: Arc 

Q: Quadric Bezier 
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C: Cubic Bezier 

5.9 Digitizing of Running Stitch and Manual Stitch 

The Above-introduced input methods are not applicable to Running 

Stitch or Manual Stitch, which have their own input methods. 

5.9.1 To Digitize Running Stitch and Manual Stitch 

We’ll take Running Stitch for the example: 

1. Click Running Stitch button on Punch Toolbar 1. 

2. Mark Reference Points with left mouse button. 

3. Click right mouse button when finishing inputting. 

Now, stitches will generate along the line digitized (shown here as 

in 5-9-1). The stitches are generated according to the parameters in the 

Attribute Bar of Running Stitch. You can modify the parameters at any 

time. 

    

                     5-9-1 

5.9.2 To Mark Reference Points for Running Stitch 

When digitizing Running Stitch, you should mark Reference Points 

at the following positions: 

The positions Where the curvatures changes; 

The positions Where the is a sharp change of the direction of line; 

And the points where the line changes into curve in the outline. 
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5.9.3 To Return to Running Stitch after Inputting a Stitch Object 

You can choose to transfer the stitch type to Running Stitch each 

time you have finished inputting a stitch object when you choose some 

type of stitch on your digitizing: 

1. Open Setting menu and choose Options. 

2. Click the Label of Embroidery. 

3. Check the box of Transfer to Running Stitch after inputting 

each stitch object(shown here as in 5-9-3) 

For the Running Stitch, you can also choose to have Line method: 

4. Check the box of Transfer to line after inputting the other 

stitch object(shown here as in 5-9-3) 

Further more , you can choose to have the curve type again when shifting 

back to the curve type for the stitch type: 

5. Check the box of Restore the curve type when inputting the 

other stitch object(shown here as in 5-9-3) 

6. Click OK. 

Note： 

You can shift between the selected input Stitch and Running Stitch 

with Spacebar on keyboard. 
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                         5-9-3 

5.10 Direction Lines 

Direction Lines is a group of information to decide the angles of 

stitches. They can be input during the process of digitizing , or added to 

the design after the stitches have generated. Direction lines can help 

arrange the stitches to be more even and fluent. You can also adjust them 

to improve the effect of arrangement. 

5.10.1 To Add Direction Lines to Object 

1. Select object to modify with Shape Tool. 

2. Click right mouse button and choose Add Graphic Element in 

the list thus appears. 

3. Select Direction Lines (5-10-1) 

4. Mark Direction Lines in the pattern 



 71

5. Click right mouse button when finishing marking . 

      
                  

The stitches of the object will be rearranged according to the 

Direction lines added. 

5.10.2 To Modify Direction Lines 

If there are already Direction Lines in the pattern but thy are not 

satisfying, you can adjust them to get a better effect of the arrangement of 

stitches. 

To Move Direction Lines 

1. Select the object to modify with Shape Tool. 

2. Click either of the Handles(shown as Nodes of Arrows) of 

Direction Line to be modified. 

3. Drag the Handle to the proper point and release mouse (shown 

here as in 5-10-2-1) 

      

The Direction Line has been move to a new position in the object 
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and the stitches will be regenerated according to the new Direction Lines. 

When you point the mouse to the Direction Line(not the two Handles of it) 

and drag the mouse, you will move the Line itself. You can also select 

both two Nodes of it to move the whole Direction Line. 

To Delete Extra Direction Line 

1. Select the object to modify with Shape Tool. 

2. Click either of the Handles (shown as Nodes or Arrows)of the 

Direction Line to be modified. 

3. Press Delete on keyboard, or choose Delete from Modify menu. 

The selected Direction Line will be deleted and the stitches will be 

regenerate. 

To Change the shape of the Direction Lines 

The Direction Line Handles are shown as a line connecting two 

Nodes or Arrows. The System Default the shape of Direction Lines as 

Lines linking two Handles(shown as Nodes)each. To change the default 

setting you can: 

1. Open Setting menu and choose Options. 

2. Click the label of Embroidery. The dialog box of Embroidery 

(shown here as in 5-10-2-2)appears: 

3. Check the box of Shown Direction Line Handle as Arrow. 

The Direction Line Handles will be displayed as Arrows. To show them 

in Nodes, uncheck the box. 
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                      5-10-2-2 

 

 

 

Chapter 6 stitch type 

6.1 Stitch type and parameter setup 

Richpeace Design Pro 2000 office rich stitch types to digitize the 

outline of a design, fill the design with stitch, and embroider on large 

areas as well as to create some artistic designs. It is an advanced 

embroidery designing system, which incorporates modeling, design 

creation and 3d simulation in one. 

Before you use a stitch type to digitize on your drawing, you 
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should first check the parameters of the stitch type on Property Bar. You 

can modify the parameters on Property Bar directly according to you 

requirements. 

If you modify the parameters on Property Bar without selecting 

and object, these parameter will be adopted to you’re the objects you will 

digitize later. 

6.1.1 Running Stitch 

Running stitch is often used to digitize thin lines, like underlay and 

borders. It can also be used to add decorations to patterns so as to 

penetrate special effects. Running stitch step is system-set. If there is 

sharp corner in the pattern you can set the step smaller. 

Parameters 

Step: step of running stitch is the distance between two adjacent 

needle penetration points, then considering the embroidery machine, it is 

defined as the distance of the taboret movement(show here as in 6-1-1-1).  

You may shorten the step when you meet sharp corner on the pattern so 

as to made your stitch penetrations coincide with the border of the 

pattern. 

               

                         6-1-1-1             
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Max step: the maximum distance of taboret movement. 

     Min step: the minimum distance of taboret movement. 

Repeat: repeat refers to the to-and-fro running times of each 

Two needle penetrations along stitch penetration direction. 

When repeat is an even number like 2, the stitches run to the end of 

the stitch penetration and then return back to the start to form the repeats 

(process shown as in 6-1-1-2). When it is an odd number like 3, the 

stitches form the repeats between each two penetrations (process shown 

here as in 6-1-1-3). 

   

  Repeat usually gets a bigger number when in need of a thicker 

Running Stitch penetration line. 

Divide: there are 3 divide types: >step;<step:＝step. 

a.> step: length of outline divides step, residue allots evenly to step. In 

this way, the step is a little larger than the original step(shown here 

as in 6-1-1-4) 

b.> step: length of outline divides step, if there is residue, it allots the 

out line evenly again. In this way, the step is a little smaller than the 

original step (shown here as in 6-1-1-5).   
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6-1-1-4                 6-1-1-5 

c.> step: length of out line divides step, ignore the residue. In this way 

the step id the same with the original step (shown here as in 

6-1-1-6).  

                     

6-1-1-6 

To select divide type: chick div pull-down box in Property Bar 

divide types appear in the box. Select divide type in box. 

     Control Point: if you check the box Keep CtrlPt on the Property 

Bar, the control Points (shown here as in 6-1-1-7). If not, stitch 

penetration points do not always coincide with control points (shown here 

as in 6-1-1-8)  

        

                    6-1-1-7 

 

         

                   6-1-1-8 

6.1.2 Manual Stitch 
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     There is no default step for Manual Stitch, you can set step with 

any length and angle. The difference between Running Stitch and Manual 

Stitch and Manual Points in Manual Stitch is commonly used to link two 

short distance, its function is the same with Satin Stitch with Jump. 

     Parameters 

     Jump: this is a switch option. When it is on, the needle 

penetrations of Manual Stitch is jump stitches. Otherwise, it is sunning 

stitches. Circles on the screen, the penetration points of running stitches 

are displayed as a cross (or a line, dot) (shown here as in 6-1-2) 

          

                    6-1-2 

Notes: 

     If the step of Manual Stitch is larger than the max step, it runs jump 

stitches according to the Jump Stitch. 

6.1.3 Satin Stitch 

     Satin Stitch is commonly used to fill narrow, long and curve 

patterns. The stitches run one side then the other side of the column, 

laying the the thread across in a tight pattern. Where the column is wide, 
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more stitches are required do not cover the fabric. Long stitches are loose, 

tend to move and thus do not cover the fabric properly. If the width of the 

column of Satin Stitch exceeds the Max Step of Satin Stitch, some 

penetrations will be added to the column, so creating a dotted line to the 

object created. This is the reason that Satin Stitch is not suitable for wide 

and large patterns. 

     Parameters 

     Repeat: repeats of Satin Stitch is the same as that of Running 

Stitch, lease refer to Running Stitch Section. 

     Spacing: spacing is the distance between two adjacent needle 

penetration points on the longer border (shown here as in 6-1-3-1).The 

bigger the value is, the thinner the Satin Stitch penetrations are. The 

smaller the value is, the thicker the Satin Stitch penetrations are. 

              
                       6-1-3-1 

There are three spacing types; Group Spacing, Auto Spacing and 

According Spacing. 

Click Spc button on Property Bar, the dialog box of spacing will 

appear (shown here as in 6-1-3-2) 

(a) Group Spacing 
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Group Spacing means using a same spacing in a whole pattern. 

a. Fixed Spacing: the spacing set here will be adopted the object to be 

created without any variation (shown here in 6-1-3-3). 

        
                      6-1-3-2 

Check option box of fixed Spacing and setup the spacing.  

Fine Tune: the Standard way to adjust spacing is according to the 

outer border of the design. If the Fine Tune option is checked, spacing 

will be adjusted both according to outer border and to inner border, so 

that a nicer and more evenly spread stitches can be achieved. 

b. Auto Spacing 

For some Satin Stitch objects, the widths of them vary quite much. 

In such occasions, Auto Spacing is usually chosen, so that the spacing 

changes automatically according to the width of the objects: thicker 
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where it is wider and thinner where it is narrower. In this way the 

E-Stitches can better cover the objects without effecting on thick or 

thinner stitch part on the objects (shown here as in 6-1-3-4) 

Check the option box of Auto Spacing to activate Spacing List. Step and 

Spacing are corresponding, you can modify them to meet your need. 

    

c. According Spacing 

Accordion Spacing changes the stitch spacing gradually, it helps to 

create color blends, perspective effects and other three dimensional 

shadings with a single color. There are ten default Accordion Spacing 

effects available, which you can apply to most fill stitch types. 

 

                    6-1-3-5 

 

                   6-1-3-6 
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                   6-1-3-7 

 

                  6-1-3-8 

     
                  6-1-3-9 

Check the option box of Accordion Spacing to activate Accordion 

Spacing. Click the responding Spacing button and set the maximum and 

minimum spacing values. 

 

                 6-1-3-10 
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                   6-1-3-11 

 

                   6-1-3-12 

 

                   6-1-3-13 

 

                   6-1-3-14 

Underlay: underlay types for Satin: One Side, Both Sides, Zig Zag, 

Cross, Zig Zag + Cross, Cross + Both Sides, Netting and so on. For 

details of underlay please refer to 6.1.12 Automatic Underlay section. 

Segment: segment is a parameter that is suitable to Satin Stitch and 
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Zig Zag Stitch. You can use Even Segment, Ratio Segment of Set length 

on both sides to divide the step of Satin Stitch of Zig Zag Stitch to 

achieve special stitch effects. 

Click Sgt button, and the dialog box of Segment appears (shown 

here as in 6-1-3-15): 

 

                   6-1-3-15 

 

Select the type of the segment in the pull-down box. 

a. Even Segment: evenly divides the step of Satin Stitch into several 

sections (shown here as in 6-1-3-16, with the number of segment 

is set to be three.) 

b. Ratio Segment: divides the step into several sections according to 

segment number and ratio(shown here as in 6-1-3-17, with the 

ratio of 1;2;1) 

c. Set length on both sides: divides the step according to the values 

of Set Length 1 and Set Length 2(shown here as in 6-1-3-18, with 

Set Length1=0.8mm, Set Length2=2.0mm) 
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After selecting the type of the segment, set its parameter value 

separately. 

Note: 

You can choose to have Penetration Interval (shown here as in 

6-1-3-19) when using Segment; check or uncheck the box of Penetration 

Interval. 

 

                 6-1-3-19 

Texture: twill or pattern can be applies to Satin Stitch or Zig Zag 

Stitch as the texture. However, since Satin Stitch step is relatively small, 

it is not good to add too much penetration points. Otherwise, it will 

damage the fabric. So twill or pattern is no often used in Satin Stitch, 

unless for some certain artistic stitch effect. 

6.1.4 Satin Stitch with Jump 

Satin Stitch with Jump is quite similar to Satin Stitch. When you 

choose Satin Stitch with Jump and the step exceeds the max step of Satin 

Stitch, some jump stitches will be added without trimming (displayed as 

empty circles) to cover the fabric properly. It will not form one or more 

lines on the pattern. In this way, it can keep the effect of Satin Stitch 

(difference between Satin Stitch and Satin Stitch with Jump show here as 

in 6-1-4-1) 
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                 6-1-4-1 

Parameters 

Step of Jump Stitch: when step of Satin Stitch is larger than step of 

Jump stitch, some Jump stitches will be added without trimming 

automatically (shown here as in 6-1-4-2). You can setup the parameter for 

Satin Stitch on Property Bar. 

 

                   6-1-4-2 

6.1.5 Zig Zag Stitch 

Zig Zag Stitch is similar to Satin Stitch. The difference between 

them is that two adjacent stitch penetration lines of Zig Zag Stitch form 

two sides of an isosceles triangle, but those of Satin Stitch form the two 

sides of a right-angled triangle( different between Zig Zag Stitch and 

Satin Stitch shown here as in 6-1-5). Zig Zag Stitch is often used in 

bordering. 

You can modify the parameters of Zig Zag Stitch on Property Bar. 

For parameters setting of Zig Zag Stitch, please refer to 6.3.1 Parameter 
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Setup for Satin Stitch. 

 

                    6-1-5        

6.1.6 E-Stitch 

E-stitch looks like a comb. It is commonly used in bordering or 

filling loose shapes. It is most after used in appliqués to hold the cutting 

edge of appliqués so that they so not pull away while the balance of 

stitching is made. In order to make the E-Stitch coincides with the edge of 

pattern you can add some Running stitches in E-Stitch. 

Parameters 

    Step: when the penetration length of E-Stitch exceeds the 

Max step, it is divided according to the Step value. Otherwise, it will not 

be divided (situation shown here as in 6-1-1-1) 

    Spacing: spacing is the distance between two adjacent 

penetration points of the first digitized border when the Running Stitch 

number is one (situation shown here as in 6-1-6-2). 

    Repeat: repeat in E-Stitch is the dame as Running Stitch and 

Satin Running Stitches in E-Stitch: in order to make the E-Stitches 

coincide with the edge of pattern, you can ass several Running Stitches in 

E-stitch. 
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                     6-1-6-1 

     
                     6-1-6-2 

The number of Running Stitch is determined by the spacing and 

min step of E-stitch. For instance, when spacing=1.5mm: min 

step=0.5mm, you can insert no more the (1.5/0.5=)3 Running stitches in 

E-Stitch (shown here as in 6-1-6-3). 

 
                6-1-6-3 

    Input value to the combo box of No. on property Bar. When 

you try to set Running Stitch number larger than the maximum number 

allowed, the maximum number will be used instead of the number input. 

    Running Stitch penetrations allot uniformly in the E-Stitch 

penetrations. The length of running stitch penetrations=Spacing of 

E-Stitch/Number of Running Stitch. So the Number of Running Stitch in 
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every pair of E-Stitch penetrations is the same except for some shape with 

sharp corners. 

If the numbers of Running Stitch is set to 1, there will be no 

running stitch penetration is E-Stitch penetrations. 

Direction: the direction of E-Stitch always points to the second 

digitized border (shown here as in 6-1-6-4). 

 

                  6-1-6-4 

Notes: 

When you choose Midline Input mode, the left side of the Mid-line 

is the first border, the right side is the second border(showh here as in 

6-1-6-5). 

      
                      6-1-6-5 

6.1.7 3-D Stitch 

3-D Stitch is also very similar to Stain Stitch, except that there are 

several Jump stitches without trimming. It is most used in designs that 

require nice three-dimensional effect. 

Parameters 

Spacing: the distance two adjacent penetration points on the longer 
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border (shown here as in 6-1-7). 

Segment: 3-D Stitch penetration can be divided to the number,  

you set in Sgt on Property Bar and generate Jump Stitch penetration 

where 3-D stitch penetrations are divided (shown here as in 6-1-7 with 

the segment being 3). 

 

              6-1-7 

6.1.8 Fill Stitch 

    Fill stitch is most after used to fill large areas or irregular 

shape. If provides filling with special arrangement of Running Stitches. 

Its features are even, close-grained and parallel. The object’s boundary is 

closed when input.  

Parameters 

Spacing: the distance between two adjacent penetration lines in 

same direction. 

Edgewalk Margin and step of Running Stitch: Edgewalk Margin 

is the distance between the edge of pattern and the Running Stitch 

penetrations which link different sections of Fill Stitch penetrations. The 

step of Running Stitches here means the step of the running stitch 
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penetrations mention above. 

Border type: there are 3 border types in Fill stitch. 

Click the Border Type button on Property Bar, select the border 

type you want in the pull-down list. 

Underlay Type: Netting, Single Side, Both Sides, Package, 

Package +both Sides, Netting + Both Sides, details of underlay please 

refer to 6.1.12 Automatic underlay. 

Texture: texture of Fill Stitch includes Twill and Pattern. 

a. Twill: 

When using Twill as the texture, there is an offset value in every 

penetration column of fill stitch, changing the offset value can create 

different embroidery effecters (effect shown here as in 6-1-8-1). 

 

             6-1-8-1 

    Usage of Twill: Select Twill in Texture pull-down list, then 

click the black arrow button behind, modify the parameters in the Twill 

dialog box. 
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                     6-1-8-2 

Step: the distance between two adjacent penetration points on the 

same penetration line. 

Repeat: different repeats will bring different effects on the stitches 

(shown here as in 6-1-8-3). 

   

                6-1-8-3 

Reference Point: the reference position to arrange Twill. 

b. Pattern 

Patterns can be used to fill designs. When you want to use pattern 

in Fill Stitch, select Pattern in Texture pull-down list, then select the 
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pattern on the pattern clipboard. About the usage of Pattern, please refer 

to 6.4 Filling Designs with Pattern. 

Stitch Elements: Stitch elements of Fill Stitch is the hole 

properties. The hole can be an empty hole (stitch edge) or filled with 

texture of Satin Stitch, Vector Texture, Twill Texture or Pattern Texture. 

For details refer to 6.1.13 Stitch elements of fill stitch. 

6.1.9 Turn Fill Stitch 

Turn Fill Stitch is the combination of Satin Stitch and Fill Stitch. 

Its stitch arrangement varies according to the angle modification of 

design. It is mainly used in rotating sector, ring shape designs. So it is 

also called Rotation Fill. 

Parameters 

Spacing: the distance between two adjacent penetration points on 

the longer border (shown here as in 6-1-9). 

For other parameters of Turn Fill Stitch, please refer to 6.1.3 Satin 

Stitch and 6.1.8 Fill Stitch. 

             
                       6-1-9 

6.1.10 Classic Column Fill Stitch 

Classic Column Fill Stitch is a fill stitch, in which stitches are 



 93

generated along the out line of the objects. The stitches follows the shape 

of the design, but the number of stitch lines does not change, so the 

stitches become denser in the narrower parts while thinner in wider part. 

In this way, it can create the effect of curve, flowing and sharp contrast on 

colors. It’s most suitable for narrow designs with motion effects. 

Parameters 

Spacing: the distance between two adjacent penetration points on 

the wider side of the pattern. So it changes along with the width changing 

of the pattern. Spacing will become smaller where the design becomes 

narrower, thus make the stitches denser (shown here as in 6-1-10) 

Step: it the distance between two adjacent penetration points on a 

same penetration line (shown here as in 6-1-10). 

About other parameters of Classic Column Fill Stitch, please refer 

to 6.1.8 Fill Stitch. 

          
                    6-1-10 

6.1.11 fagged Edge 

Jagged Edge applies to Satin Stitch, Satin Stitch with jump, Zig 

Zag Stitch, Turn Fill Stitch etc. it ensures smooth placement of stitches 

over corners and creates special effect on the edge of a design by 
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inserting long or shore stitches. There are several jagged Edge types: 

jagged on one side; Jagged on both sides and Auto-jagged. 

Usage of Jagged Edge 

     1. Select one stitch type that can apply to Jagged Edge. We will 

take Satin Stitch for the example. 

     2. Click Jag on Satin Stitch property Bar and the dialog box of 

jagged (shown here as in 6-1-11-1) appear: 

     3. Select jagged edge method in the Method pull-down list. 

     4. Set jagged number jagged ratio. 

     5. Click OK. 

     6. Digitizing on the pattern. 

     Parameters 

     Mode: Jagged Edge can be grouped as General and Tajima with 

regard to stitch type. The penetration points of General are between two 

adjacent stitch lines, while the penetration points of Tajima are all on the 

stitch lines (shown here as in 6-1-11-2). 

      

                   6-1-11-2 

     Number: Jagged number is the stitches inserted between any two 

adjacent stitch lines. 
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     Ratio: Jagged stitch length/Satin Stitch length. If it is positive, the 

jagged stitches are outside the stitch lines (difference shown here as in 

6-1-11-3). 

      

                         6-1-11-3 

     Jagged Edge Type 

     There are three Jagged Edge type: Short Stitches, Jagged Rough 

and Full Jagged. 

     Short Stitches: regular short stitches generated automatically. 

You can set the length and number (shown here as in 6-1-11-4). 

                 

                     6-1-11-4 

     Jagged Rough: Irregular short stitches generated automatically. 

You can set the number of stitches, however, the length is uncertain, it 

will vary randomly within the max jagged ratio and min ratio set by user 

(shown here as in 6-1-11-5). 

     Random: Means the extent of jagged, which decides the rough 

degree of jagged stitch, the value <0.3. 
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                    6-1-11-5 

     Full jagged: Random short or long stitches generated automatically. 

The length and number of jagged stitches are both random (shown here as 

in 6-1-11-6). 

               

                     6-1-11-6 

     Select Jagged Edge type in the Type pull-down list. 

     Jagged Edge Method 

     Group according to Jagged Method, it consists of Auto Jagged, 

Jagged on first side, Jagged on second side and Jagged on both sides. 

     Auto Jagged: When you digitize a curved object and two outlines 

contrast sharply in their radian, the program will automatically insert 

some short stitches to decrease stitch density over the sharp corner. 

     Jagged on first side: Insert short stitches on the first side (shown 

here as in 6-1-11-7). 

     Jagged on second side: Insert short stitches on the second side 

(shown here as in 6-1-11-8). 
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                       6-1-11-7 

                 

                       6-1-11-8 

     Jagged on both sides: Insert short stitches on both sides (shown 

here as in 6-1-11-9). 

                  

                         6-1-11-9 

Notes: 

     Generally, first and second is defined according to the input 

sequence, the side that is entered earlier is called first side, the side that is 

entered after is called second side. When you choose middle line input 

mode, the left side of digitized line is the first side, the right side is the 

second side. 

Valve Value: it is to control the time to add jagged stitches. When 
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the ratio of short border and long border is smaller than the valve Value, it 

begins to add jagged stitches (shown here as in 6-1-11-10). 

  
     Select Jagged Edge Method in the Method pull-down list. 

     To Choose to Use Jagged  

     1. First decide what type of stitch to apply to the jagged. Usually, it 

can be used on Satin Stitch, Satin Stitch, Satin Stitch with Jump, Zip Zag 

Stitch and Turn Fill Stitch. 

     2. Click the button of Jap on Properly Bar and the dialog box of 

Jagged (6-1-11-11) appears. 

          
                     6-1-11-11          

     3. Select jagged method in Method pull-down list. 

     4. Select japed type in Type pull-down list. 
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     5. Setup the necessary parameters in the dialog box. 

     When Selecting Auto Jagged, you need to set the parameters of 

Valve Value, Max Amount and Ratio. 

     Click OK when finishing the setup. 

     6. Digitize the design, and Jagged will be added to the design 

automatically. 

6.1.12 Underlay 

     Underlay is a kind of special stitch to fasten the fabric and support 

the surface thread. Usually, underlay is embroidered beneath the surface 

thread and when the design is finished on the embroidery machine, the 

underlay is not visible. 

     Underlay can be added to the design manually, but this is not 

always necessary, because it is a time bearing job. To solve the problem, 

RDP2000 provides kinds of underlay that can be added to your design 

automatically. 

     Single Side; 

     Both Sides; 

     Zigzag; 

     Cross; 

     Netting; 

     Package 

     Zigzag + Bothe Sides; 
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     Cross + Both Sides; 

     Netting + Both Sides; 

     Package + Both Sides; 

     To add underlay automatically 

     1. Select the Stitch type first. 

     2. Click the Udlay button on Property Bar and the dialog box of 

Underlay (shown here as in 6-1-12-1) appears: 

       

                    6-1-12-1 

     3. Select the underlay type in Type pull-down list. 

     4. Setup the parameters of Edgewalk Margin, Stop and Spacing, 

Click OK when finishing. 

     5. Digitize the design and the selected underlay will be added to the 

design automatically. 

     Parameter Setup  

     Edgewalk Margin:the distance between the border of the underlay 

and the outline of the design (stitch object). Usually, the value should be 
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0.2mm bigger than that of Pull Compensation. 

     Setup: The step of underlay 

     Spacing: the spacing of underlay. 

     To Select a Proper Underlay Type 

     Usually in practice, underlay type is decided by the fabric type, the 

design and type of the stitch. 

     For some large designs to be embroidered on loose fabric, more 

underlay will be needed.  

     For small design to be embroidered on tight fabric, less underlay 

will be needed.  

     For narrow designs, Single Side Underlay might be better, while 

for wider panel-shaped designs, Both Sides Underlay may serve better. 

     To support the surface thread better, you can choose to use Zigzag 

or Cross Underlay. 

     Netting, Package, Zigzag + Both Sides, Cross + Both sides, 

Nettings + Both Sides and Package + Both Sides can hold the surface 

thread strongly while tighten the fabric better. 

6.1.13 Stitch Elements of Fill Stitch 

Stitch elements of Fill Stitch is the hole properties. The hole can be 

empty or filled with Satin Texture, Twill Texture, Pattern Texture or 

Vector Texture(shown here as in 6-1-13-1) 
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Usage of Stitch Elements 

1. Click the arrow button on the right of Property Bar, the part of 

stitch elements (shown here as in 6-1-13-2) appears on Property Bar: 

 

2. Select the stitch element in Stitch pull-down list. 

3. Digitizing a design with a hole and the selected stitch element 

will be filled to the hole. 

To Modify Outline 

1. Select the object to modify with Pick Tool. 

2. Choose Modify Properties on Modify menu or chick right 

mouse button and select Object Properties. The dialog box of Fill Stitch 

(shown here as in 6-1-13-3) appears. Click the label of Outline and Hole 

Texture. 

3. Click Next Border to select the hole border you want to modify 
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(First border is the exterior outline of the pattern). 

 

Current selected border is shown in red on previewing window  

4. Click Graphic Parameter Step button, modify the parameters of 

the pattern in the relative graphic created so as to change the shape of 

object outline. 

5. If you want to convert object to curves, click Into Curve button. 

6. Click Delete to delete selected outline. 

Notes: 

     When you select an object with shape Tool, you can modify the 

outline of the object directly on the screen. 

     To Modify Hole Texture Properties 

     1. In the Change into pull-down list, click the border type you 

want to use. 
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     2. Click Modify button 

     If you want to use texture border, click Texture Parameter Setup 

button to set texture parameters. 

     3. Modify other properties of outline and hole texture. 

     4. After all modifications, click OK. 

6.2 Modifying Stitch Elements of an Existing Object 

     You can modify the stitch elements of an existing object at any 

time. You can add pattern, underlay or edgewalk margin to an object. You 

may also use another stitch type to replace current stitch type of the 

object. 

     You cannot only modify stitch properties of an object on Property 

Bar, you can also modify them in dialog boxes. There modifications are 

only applied to current selected object and have effect on other objects 

created or to create. 

     Before any modification, you should first select the object you 

want to modify. 

6.2.1 To Convert stitch Types 

     You may replace the present stitch type of an object with another 

stitch type: 

     1. Select the object to be modified with Pick Tool or Shape Tool. 

     2. Open Pattern menu and choose Stitch Type Conversion, or 

click right mouse button and choose Stitch Type Conversion (shown 
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here as in 6-2-1). 

 

     3. Select the stitch type to convert to in the list thus appears. 

     The selected object will be filled with selected stitch type. 

6.2.2 To Modify Properties of Stitch Element 

    If you want to modify the properties of stitch element of an existing 

object, you should first select the object on Property Bar. You may also 

modify the properties in relative dialog boxes. 

    To Modify Properties of Stitch Element in a Dialog Box 

    1. Select the object to be modified with Pick Tool or Shape Tool. 

    2. Click right mouse button and choose Object Properties or click 

Modify menu and select Modify Properties. The relative dialog box will 

appear. For example, if you select a Fill Stitch object, dialog box of Fill 

Stitch appears (shown here as in 6-2-2). 

    3. Modify the parameters of the object.  

    4. After all modifications, click OK. 
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6.3 Saving to Object Parameters Library 

    In RDP2000, you can save several different groups of parameters. 

When you need to use any group of parameters, you can just load it. 

6.3.1 To Save to Object Parameters Library 

    1. Click Library menu and choose Save to Object Parameter 

Library. The dialog box of Save to Object Parameter Library (shown here 

as in 6-3-1) appears; 

    2. Select a drive and a folder to save the file to. 

    3. Input a name for the file. 

    4. Click Save. 

    This group of parameters is saved in a file of this library. 
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     需要插图…… 

6.3.2 Load from Object Parameter Library 

    1. Click Library menu and select Load from Object Parameter 

Library. The dialog box of Load from Parameter Library (shown here as 

in 6-3-2) appears; 

    需要插图…… 

    2. Find the drive and the folder the library file in. 

    3. Click the name of the library file you want to open. 

    4. Click Open. 

    Or you may double click the file mane to open the file. 

Notes: 

    This group of parameters you load will replace the current 

parameters. 

6.4 Filling Design with Pattern 

    If you want to fill your designs with patterns, you can transfer 

patterns from Pattern Clipboard, or create your owe patterns, or drag a 

pattern on the screen to fill a design. 

6.4.1 Usage of Pattern 

    You can transfer patterns from Pattern Clipboard directly to fill 

design. 

    1. Select a stitch type. We will take Fill Stitch for the example. 

    2. Select Pattern from Texture pull-down list on Property Bar. 
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    3. Click the arrow button, and the dialog box of Pattern Clipboard 

(shown here as in 6-4-1-1) appears: 

       
    4. Click the pattern you want to use. 

    5. Modify the size and layout of the pattern. 

    6. Click OK. 

    7. Digitize the outline of the design. The design will be filled with 

selected pattern (shown here as in 6-4-1-2). 

              

Notes: 

    You can use patterns to fill and digitize objects of Satin Stitch, Zig 

Zag Stitch, Satin Stitch with Jump, Turn Fill Stitch, Contour Stitch and 
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Fill Stitch. 

    When you use patterns to fill designs, you should pay attention to 

the angle of the stitches. If the direction is parallel to the border of the 

pattern, the outline of the pattern may be invisible. Sometimes, you can 

adjust the direction to achieve nice effect. 

6.4.2 To Create Patterns 

     You can create your own patterns and save them to Pattern 

Clipboard. When you want to use them, you can transfer them from the 

Pattern Clipboard. 

    1. Use tools from Draw Toolbar to create a vector pattern and 

select it with Pick Tool, or select an existing vector pattern with Pick 

Tool. 

    2. Click library menu, select Copy to pattern Clipboard. 

    Or click right mouse button and select Copy to Pattern 

Clipboard. 

    The selected pattern is copied to Pattern Clipboard, you can 

transfer the pattern from pattern Clipboard at any time. 

6.4.3 To modify Name and Background Color of Pattern 

    The selected pattern is saved to Pattern Clipboard in a name that 

system defaults, you can rename the patterns and change the Background 

Color of Pattern Clipboard. 

    1. Open Library menu and choose Open Pattern Clipboard. 
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    2. Select the pattern you want to modify.  

    3. Click the name of the pattern to be modified again, input a new 

name on keyboard. 

    4. Click Background button, the Color dialog box appears, select 

the color from it. You may palette your owe color and click OK. 

Notes: 

    Use right mouse button to click a pattern on Pattern Clipboard, 

select Changing Background Color. In this way, you can also change 

the background color of Pattern Clipboard. 

6.4.4 To Delete Patterns 

    You can delete patterns you do not need on Pattern Clipboard. 

    1. Open Library menu and select Open Pattern Clipboard. 

    2. Click the pattern you want to delete. 

    3. Click Delete button or click right mouse button and choose 

Delete. 

    4. Click OK. 

6.4.5 To Copy Patterns from Pattern Clipboard to Windows 

Clipboard. 

    You can select a pattern on Pattern Clipboard and copy it to the 

standard Windows Clipboard, and paste it on the screen by carrying the 

Paste command. 

    1. Open Library menu and choose Open Pattern Clipboard. 
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    2. Click the pattern to be copied by right mouse button and choose 

Copy to Clipboard.  

    The selected pattern is copied to Windows Clipboard. 

    3. Click paste button. 

    The pattern is pasted directly on the screen. 

Notes: 

    The pasted pattern is put in the center of current window. 

6.4.6 To Save to pattern Library 

You can save the patterns on current Pattern Clipboard to the files 

in Pattern Library. When you want to use Pattern Library, just load the 

file. 

    1. Click Library menu and choose Save to Pattern Library. 

    The dialog box of save to Pattern Library (shown here as in 6-4-6) 

appears: 

      

    2. Select a drive and a folder to put the file in. 

    3. Input a name for the library. 
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    4. Click Save. 

    The content in current Pattern Clipboard is saved to that file, 

anytime you want to use them, just transfer them. 

6.4.7 Load from Pattern Library 

    When you need to use Pattern Library, you can just load it. The 

Pattern Library loaded will replace current on Pattern Clipboard. So 

before you load the Pattern Library, you should first save the content on 

Pattern Clipboard. 

    1. Open Library menu and choose Load Pattern Library. The 

dialog box of Load From Pattern Library (shown here as in 6-4-7) 

appears: 

     
2. Select the drive and folder you have put the Pattern Library file 

in.  

    3. Click the name of the library file to be loaded 

    4. Click Open or double click the name of the library file. 

6.4.8 To Modify Layout of Pattern 
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    You can modify the layout of pattern by modifying the size, 

direction and spacing of the pattern. 

    1. If you know the size and direction of the pattern, you can modify 

the layout of pattern on Pattern Clipboard. And the dialog box of Pattern 

Clipboard appears 

    2. Open Library menu and choose Open Pattern Clipboard. And 

the dialog box of Pattern Clipboard appears. 

    3. Click the pattern you want to use. 

    4. Set corresponding values in the dialog box. 

    And the effect of the modification is shown as follows (6-4-8-1): 

     

Notes: 

    In the preview window, you can see the layout of the pattern at any 

time. 

    5. After finishing the setting, click OK 

    Now, you can use the pattern to create new objects. 

    To Modify Pattern Layout of an Existing Object 



 114

    1. Select the object to modify with Pick Tool. We will take Fill 

Stitch as the example. 

    2. Open Modify menu and choose Modify Properties, or click 

right mouse button and choose Object Properties. The dialog box of Fill 

Stitch appears. 

    3. Click the label of Main Texture (shown here as in 6-4-8-2)  

      

    4. Click First Main Texture or Next Main Texture to select the 

pattern texture to modify. 

    5. Click Parameter Setup of Edit Main Texture box and the 

dialog box of Pattern (shown here as in 6-4-8-3) appears: 

    6. Modify Size, Line Space, Row Space, Offset and Reference 

Point in the dialog box.  
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7. You can also click the Pattern Ref button, and the dialog box of 

pattern parameter appears (shown here as in 6-4-8-4), in which you can 

modify the pattern itself too. For example, you can modify the size, 

coordinates of center point of the pattern, or rotate and mirror the pattern. 

       

6.4.9 To add Pattern Texture to an object 

    You can add pattern texture to an existing object. 
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    1. Select the object you modify with Pick Tool or Shape tool. We 

will take a Fill Stitch objects as the example. 

    2. Click right mouse button and choose Objects Properties or 

open Modify menu and choose Modify Properties. The dialog box of 

Fill Stitch appears. 

    3. Click the label of Main texture (shown here as in 6-4-9-1). 

     
    4. Select the pattern in Type pull-down list of the Add Main 

Texture box. 

    5. Click Parameter Setup button and the dialog box of Pattern 

Clipboard appear: 

    6. Select the pattern you want to use on Pattern Clipboard, adjust 

the layout of the pattern and then click OK. 

    7. Click Add. 
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    8. Click OK    

Notes: 

    You can also add twill to the pattern in the way mentioned above, 

just select Twill in the type pull-down list of Add Main Texture box. 

    To add Pattern Texture to an Object 

    You can drag a vector pattern (or a pattern composed by several 

vector graphics) to fill a design directly on the screen. 

    1. Select a vector pattern with Pick Tool.  

    2. Click the pattern by right mouse button and drag the pattern onto 

the design, release the button. A list appears (shown here as in 6-4-9-2) 

      

3. Choose AS main patterns on the lists. 

    The objects is filled with the selected pattern (shown here as in 

6-4-9-3). 
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Chapter7 Motif Run and Motif Fill 

Motifs are usually small and simple objects, or symbols that are 

used repeatedly in several designs. Motifs are stored on the motif 

Clipboard, you can transfer them at any time. You can also create your 

own motifs. 

You can repeat motifs regularly along a digitized line (Motif Run), 

and you can also fill close shapes with motifs (Motif Fill). Motifs are 

ordinary patterns, except that they have two reference points that allow 

you to position, scale, rotate them accurately. 

7.1 Usage of Motif 

7.1.1 To Transfer motif 

You can transfer motifs from the Motif Clipboard to create new 

objects directly. 

1. Open Library menu and choose Open Motif Clipboard. The 

dialog box of Motif Clipboard (shown here as in 7-1-1-1) appears. 

2. Select the motif to use. 

3. If you need, you can modify the size and layout of the motif.  

4. Click OK. 
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7.1.2 To Create Motifs 

You can create your own motifs, save them to Motif Clipboard 

and transfer them for use at any time. 

1. Create a stitch object, select it with Pick Tool. 

2. Open Library menu and choose Copy to Motif Clipboard. 

Or click right mouse button and choose Copy to Motif Clipboard. 

3. A reminding box (shown here as in 7-1-2-1) appears to remind 

you about the reference line; the program will add the default reference 

line if you select No. 

 
4. Click Yes, use the left mouse button to input two reference 

points. 

Click No, adopt the default positions of the two reference points 
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are at the first and last stitch. 

The motif is saved to Motif Clipboard. 

Note: 

These two reference points of motif will decide the arrange method 

of the motifs on the digitized line in Motif Run. 

If you put the reference points on the left side and right side of 

motif separately, motifs will be arranged parallel to the digitized line 

(shown here as is 7-1-2-2). 

   

If you put the reference points on the left side and right side of 

motif separately, motifs will be arranged vertically to the digitized line 

(shown here as is 7-1-2-3). 

      

7.1.3 To Change Name and Background Color of Motif 

The motif is saved with a default name in Motif Clipboard, you can 

rename the motif or change background color of Motif Clipboard. 

     To Rename Motif 

     1. Select the motif to modify with Pick Tool in the dialog box of 



 121

Motif Clipboard. 

     2. Click the name of the motif again. 

     3. Input a new name on the keyboard. 

Note: 

     After you have renamed the motif, the stitch information of the 

motif still remains. 

To Modify Background Color of Motif Clipboard 

Click Background button, and the dialog box of Color appears, 

select a new color from it , or palette your own color and click Ok. 

Note: 

You can also click the motif by right mouse button, choose Change 

Background Color and change the background color of Motif Clipboard. 

7.1.4 To modify reference line 

From Library menu choose Open Motif Clipboard. 

Click Input button in Motif Clipboard dialog box, the Input 

Reference Line dialog box appears on the screen. 

Choose the first reference points: P1(x,y), click and button in the 

dialog box or click in the Preview Window to change place of the first 

reference point. 

Choose the second reference points P2(x,y), click any button or 

click in the Preview window while holding down Ctrl key to change the 

place of the second reference point. 
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(In preview window, green box deputy the first reference point and 

white box deputy the second reference point.) 

7.1.5 To Delete Motifs 

You can delete the motifs you do not need from the Motif Clipboard. 

1.Open Library menu and choose Open Motif Clipboard. 

2.Click the motif to delete. 

3.Press Delete key on keyboard or click right mouse button and 

choose Delete. 

7.1.6 To Copy Motif to Windows Clipboard 

You can select a motif on the Motif Clipboard and copy it to the 

standard Windows Clipboard, and then use Paste command to paste it on 

the screen directly. 

1.Open Library menu and choose Open Motif Clipboard. 

2.Click the motif to be copied with right mouse button and choose 

Copy to Clipboard. 

The selected motif is put on the clipboard. 

3.Click Paste button, the motif is pasted on the screen. 

The motif will be kept in the clipboard till new content replaces it. 

Note: 

When you try to paste motif on the screen, you can select Copy 

object in Clipboard to current stitch position in the dialog box of 

Embroidery in Options. Otherwise, it is put in the center of current 
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window. 

7.1.7 To Save to Motif Library 

You can save the content in Motif Clipboard to Motif Library in a 

file. When you need them, you can just load it from Motif Library. 

1.Open Library menu and choose Save to Motif Library. The 

dialog box of Save to Motif Library appears. 

2.Select a drive and a folder to save the file. 

3.Input a name for the file you want to save. 

4.Click OK. 

The content in Motif Clipboard is saved to Motif Library. 

7.1.8 To Load from Motif Library 

You can load motifs from Motif Library, the motifs you load will 

replace the original content of the Motif Clipboard. 

1.Open Library menu and choose Load from Motif Library, and 

the dialog box of Load from Motif Library appears. 

2.Select the drive and the folder you have put in your motif library. 

3.Click the name of the motif library on the file list. 

4.Click Open or double click the name of the file to open it. 

Note: 

Before you load from the Motif Library, you should first save the 

content of current Motif Clipboard. 

7.2 Motif Run 
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Motif Run means motifs arranged repeatedly along a digitized line. 

Using the distortion control point, you can modify the size, spacing and 

rotation angle of the motif easily. 

7.2.1 Motif Run 

1. Create a new motif or transfer a motif from the Motif Clipboard. 

2. Click Motif Run button 

3. If you need, you can modify the step and spacing value of the 

motif. 

4. Use mouse to digitize the base line. 

5. Click right mouse button to finish the digitizing of base line. 

Motifs are arranged along the digitized line according to the set 

parameters(shown here as in 7-2-1). 

        
7.2.2 Parameters Setup 

The parameters of Motif Run are shown here as in 7-2-2 below: 

 

Step : the distance between each two adjacent Control Points of the 

motif. 
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Spacing: the distance between the same points of two consecutive 

motifs repeated along the baseline. The default value of Spacing is the 

same as that of Step. 

Baseline: the digitized line 

Fixation Point and Control Point when you use Motif Run, the 

first reference point of the baseline coincides with the first reference point 

of the motif, this point is the Fixation Point; the second reference point of 

the motif is the Control Point. If you drag the Control Point, the motifs 

will go around the Fixation Point. 

Notes: 

If the length of the baseline is not the integral multiples of Spacing 

the program will modify the spacing of the motif so as to make all motifs 

on the baseline evenly spaced. 

When there is are on the baseline, you can measure the spacing of 

motif in two ways: 

By Arc Length: the spacing of motif is the length of the arc that 

links these two points. 

By Chord Length: the spacing is the length of the chord that links 

these two points. 

If the length of the baseline is not the integral multiples of Space, 

there are three methods to arrange motif along the line: Automatic, 

Remains and Synchronously Adjust Space and Step. 
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Automatic: The program adjusts the space automatically to make 

the motif arranged along the line equably. 

Remains: Arrange the motif along the line with the fixed space. 

Synchronously Adjust Space and Step: The program adjusts the 

space and step of the motif automatically at the same time to make the 

motif arranged along the line equably. 

7.2.3 To Modify Size of Motif by Dragging Control Point 

You can drag the Control Point to rotate the motifs or modify the 

size of motifs. 

1.Select the object of Motif Run with Shape Tool. 

The outline, baseline and control point of the object(shown here as 

in 7-2-3)appears: 

 

2.Drag the Control Point, you can rotate and scale the object based 

on Fixation Point. Dragging the mouse towards the Fixation Point 

magnifies the motifs; dragging the mouse away from the Fixation Point 

reduces the motifs. Under these operations, the length of the baseline, the 

spacing of motif and the step of motif are not changed. 

7.2.4 To Modify Motif Run is Dialog Box  

You can modify the size, step and spacing of the Motif Run in 

dialog boxes. 



 127

1.Select the Motif Run object to be modified with Pick Tool or 

Shape Tool. 

2.Open Modify menu and choose Modify Properties or click right 

button and choose Object Properties. The dialog box of Motif Run(shown 

here as in 7-2-4-1)appears: 

 

3.Modify the Spacing and Step of Motif Run. 

4.Click the label of Motif, and the dialog box of Motif(shown here 

as in 7-2-4-2)appears: 
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In this dialog box, you can modify the size of the motif. 

In the Width and Height box, define the width value and the 

height value of the motif. 

When you modify the coordinate value, the arrange method and the 

size of the motif will be modified correspondingly.  

5.Click other label to modify other properties of the object. 

6.After all modification, click OK. 

Note: 

You can modify the Step and Spacing directly on Property Bar. 

To choose Keep Code option, all the machine codes, include color and 

color change information of the motif will be kept when running motif. 

To dispart Motif Run objects 

You can dispart a motif run object into individual objects at any 
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moment. 

Select the motif run object, then click the right mouse button, 

choose Dispart. 

7.3 Running Selected Object, Pattern and Motif  

7.3.1 To Run Selected Object 

Selected Object here refer to any objects created in RDP2000, 

including Graphic Objects, Stitch Objects and Letters. 

To Run Selected Object 

1.Select the object for the run with Pick Tool. 

2.Open Modify menu and choose Run Selected Object. The 

dialog box of Reference Points for Objects of Motif Run(shown here as 

in 7-3-1-1)appears: 

  

3.Choose object array method: Free, Rectangular and Polar. 

4.Select the Reference Point for the object. It is possible to define it 

to the 8 special points or define it through the Coordinate of the 
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Reference Point. The Reference Point defined will be taken as the Base 

Point to position the selected object. 

5.When using Rectangular and Polar method, you also need to set 

the reference angle. 

You can input an angle directly or through clicking a point in the 

preview window, the angle of this point and the reference point is the 

reference angle. 

6.When using Rectangular method, you can set the row and column 

number and spacing to change the run object shape. 

7.When using Polar method, you can set the run object number, the 

angle range and rotate direction. 

8.Click right mouse button when finishing the running. 

     9.Input the Base Point for the running of the selected object.It is 

aIso the position to place the object to be run. 

     10.Input Second Reference Point.The angle formed(clockwise)by 

the line connecting it with the Base Point and the horizontal line decides 

the rotation angle of the object to be run(shown here as in 7-3-1-2). 

      

11.Go on inputting the Base Point and Reference Point for the next 
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object to be run till finishing the running of the selected object. 

Note: 

When running the object with free mode, you can see the angle 

between the base point and the second point in the Status bar, which 

decides the rotate angle of the object.when you finish the whole process 

of free run object, click the right mouse button to finish. 

When using Rectangular mode,you can see the size of the rectangle 

at any time in the Status Bar before finishing the operation. 

When using Polar mode,you can see the center coordinate and 

radius in the Status Bar before finishing the operation. 

Click right mouse button when finishing the running. 

7.3.2 To Run Selected Pattern   

1.Open Library menu and choose Open Pattern Clipboard. 

Select the pattern to be run in the dialog box of Pattern Clipboard. 

2.Open Modify menu and choose Run Selected Pattern.The dialog 

box of Reference Points for Objects of Motif Run(shown here as in 

7-3-2-1)appears: 
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3.Select the Reference Point for the pattem.It is possible to define it 

to the 8 special or define it through the Coordinate of the Reference 

Point.The Reference Point defined will be taken as the Base Point to 

position the selected pattern. 

4.Click ok. 

5.Input the Base Point for the running of the sdelected pattern.It is 

also the position to place the pattern to be run. 

6.Input Second Reference Point.The angle formed (clock wise)by 

the line connecting it with the Base Point and the horizontal line decides 

the rotation angle of the pattern to be run(shown here in 7-3-2-2). 
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7.Go on inputting the Base Point and Reference Point for the next 

pattern to be run till finishing the running of the selected pattern. 

8.Click right mouse button when finishing the running. 

7.3.3 To Run Selected Motif 

1. Open Library menu and choose Open Motif Clipboard. Select 

the motif to be run in the dialog box of Motif Clipboard. 

2. Open Modify menu and choose Run Selected Motif. The dialog 

box of Reference Points for Objects of Motif Run (shown here as in 

7-3-3-1) appears: 
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3. Select the Reference Point for the motif. It is possible to define it 

to the 8 special points or define it through the Coordinate of the 

Reference Point. The Reference Point defined will be taken as the Base 

Point to position the selected motif. 

4.Click OK. 

5. Input the Base Point for the running of the selected motif. It is 

also the position to place the motif to be run. 

6. Input Second Reference Point. The angle formed(clockwise)by 

the line connecting it with the Base Point and the horizontal line decides 

the rotation angle of the motif to be run(shown here as in 7-3-3-2). 

 
7.Go on inputting the Base Point and Reference Point for the next 

motif to be run till finishing the running of the selected motif. 

8. Click right mouse button when finishing the running. 

7.4 Motif Fill 

You can fill a close pattern with motifs, under this operation, the two 

reference points of motif will be invalid-they do not work wherever these 

reference point locate. At this time, we call the motifs as the Motif Fill. 

7.4.1 Usage of Motif Fill 
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1. Create you’re the motif or transfer a motif from Motif Clipboard. 

2. Click Motif Fill button. 

3. Digitize the outline of the pattern using close curve input mode 

then click right mouse button when finish. 

4. Input Entry and Exit. 

The pattern is filled with selected Motif(shown here as in 7-4-1-1) 

 
Note: 

You can also use Motif Fill to fill the pattern object with several 

holes. 

There are two Motif Fill types: Motif Clipping and Motif Filling 

Scale and Direction. 

When you select Motif Clipping, the program will cut the motifs that 

are not fit to the pattern so as to keep a clear outline of the pattern(shown 

here as in 7-4-1-2). 

     When you do not select Motif Clipping , the motifs will not be cut, 

If half of a motif is outside the object, it will remain and the outline of the 

object will be enlarged. In this case, the outline of the object is not quite 

clean as it was digitized, but no cut motif will appear in the object(shown 
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here as in 7-4-1-2). 

       

7.4.2 To Modify the Layout of Motif Fill 

The default setting of the layout of Motif Fill is that the distances 

between rows and columns are decided by the height and width of the 

motif. In this way, there will be no gap between lines and rows. To 

change to layout of Motif Fill, you can preset the layout before filling in 

the objects with motif. 

To Preset Layout of Motif Fill 

1.Open Library menu and choose Open Motif Clipboard. 

Or click the button of Motif Fill in Punch Toolbar 1. 

Or click the button of Motif on Property Bar. The dialog box of 

Motif Clipboard(shown here as in 7-4-2-1)will appear. 
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2.Select the Motif to use. 

3.Modify the layout of Motif Fill by changing the row spacing, 

column spacing and value of offset. 

The effect of these parameters are shown here as in 7-4-2-2 and 

7-4-2-3. 

  

   

4.After you have modified the layout, click OK. Now, you can use 

this motif to fill in a new object. 

To Modify Layout of Motif Fill of an Existing Object. 

If you have created and generated stitches of an object with Motif Fill, 

you can still modify the layout of the object. 

1. Select the object filled with motif with Pick Tool or Shape Tool . 

2. Open Modify menu and choose Modify Properties or click right 
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mouse button and choose Object Properties. 

3. Click the label of Motif. The dialog box of Motif Fill(shown here as in 

7-4-2-4)appears: 

        

4. Modify the layout of motif fill by adjusting the size, row spacing, 

column spacing and offset values. 

5. Click other labels to modify other object properties in other 

corresponding dialog boxes. 

6. After all modifications, click OK. 

 

 

Chapter 8 Thread Color 

The method to assign colors in RDP2000 is quite similar to other 

drawing software. You can select a color for an object on Color Toolbar 

directly, or create your own color for it. When you select a color for the 
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new object you are creating, the color will be saved as part of the 

properties of the object, so it is more convenient and much easier for you 

to control the color of the object. 

As part of the properties of the objects, thread colors can 

differentiate each part of the object, but they do not stand of the real color 

of embroidery thread. 

When creating a new design, you just need to consider what kinds of 

color to use for each part. You do not need to consider how embroidery 

machines should change these colors. You can insert some Color Change 

Code in the design manually. However, this method is not a usual practice 

because the program will insert required machine codes automatically. 

8.1 Working with Colors 

If you want to apply a color, you just need to click the corresponding 

color button on Color Toolbar. You can also double click a color button to 

open the standard Windows Color dialog box, so that you can palette a 

new color. 

8.1.1 To Select Colors for New Objects 

When no object is chosen, you can click a color button on Color 

Toolbar, and a black pane appears around the button indicating this color 

selected. This color will be assigned to the objects to be created later till 

some new color is assigned. 

8.1.2 To Modify Colors for an Existing Object 
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1.Choose the object to modify with Pick Tool or Shape Tool. 

2.Choose a new color in Color Toolbar for the object chosen. And 

the object will appear in the new color. 

8.2 Displaying Colors of Multi Objects 

To view objects more conveniently, you can set different colors for 

different objects in a design. For and example, you can set different 

colors for penetration points, outline, Connector and selected objects. 

8.2.1 To set Display Color for Objects 

1. Click Setting menu and choose Display color, and the dialog box 

of Display Color Setup(shown here as in 8-2-1)appears: 

 

2. Click the color setup button behind the object to modify, and the 

standard Windows dialog box of Color appears. Select the color you want 

to use. 

3. Modify the color for other objects in the same way. 

Note: 

If you want to resume the program default color setting, you just 
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need to click the Default button. 

8.2.2 To set Display Color for Connector 

There are two ways to display the color of Connector: by the color 

of the object it connects to or by the color set for it. 

To apply the set color for it, you need to check the box before 

Connector,and the color button of Connector is lightened. Click the color 

button and you can now set color for Connector in the Windows standard 

dialog box of Color. 

To apply the color of the object it connects to , uncheck the box 

before Connector. 

8.3 Creating Thread List 

Before you begin to digitize on a design, you can first set the Thread 

Sheet. In this way, you can decide the sequence of the colors for the 

design. You can choose colors from the Color Toolbar or palette your own 

colors. 

8.3.1 To Choose Thread List 

1.Click Setting menu and select Thread List, and the dialog box of 

Thread List(shown here as in 8-3-1)appears: 

2.Define thread number in Thread Number combo box. It decides 

the number of colors in listed in Thread List. The maximum number is 

100. 

3.Select thread colors to use from Thread List. 
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When you open a new pattern, the Thread List that the program 

defaults will assign to this pattern. The program offers you Stock Thread 

List, you can select thread colors from Stock Thread List. You can also 

modify the colors in the thread color list so as to palette your own colors. 

 

8.3.2 To Modify Thread Color 

1.Click the number of the color to modify in Thread List.  

2.Click the number of the color to use in Stock Thread List.  

3.Click Modify button. 

The selected color in Thread List will be replaced by the color 

selected in Stock Thread List. 

4.Repeat above steps till you finish modifying all colors. 

5.Click Ok. 

8.3.3 To Edit Thread 

1.Click the number of the color to edit in Thread List. 
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2.Click the Edit button, and the dialog box of Edit Thread(show 

here as in 8-3-3)appears: 

   
3. Choose the option box of color model for the way to edit the color 

of the thread. RPD2000 provides 2 color models: RGB and HLS. 

4. Move the sliders or click the arrows to set the color for the thread. 

5.Input the necessary information for Code, Label , Density and 

Information separately in the corresponding boxes. 

Code: used for the embroidery factories to identify threads. So it is 

defined by the factory. 

Density of thread: 

A refers to genera; thread density; 

B refers to thick thread density; 

C refers to thin thread density; 

D refers to thinner thread density; 

6. Click OK. 

Note: 
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You can double click a color button on Color Toolbar to visit the 

Thread Sheet dialog box. 

8.3.4 TO Modify Color for Background, Outline and Selected 

Stitiches 

1. Click the buttons of Background Color, or Outline Color, or 

Color of Selected Stitches at the button of the dialog box, the dialog box 

of Color Setup(shown here as in 8-3-4)will appear: 

  
2. Choose option box of color model for the way to edit the color of 

the thread. RPD2000 provides 2 color models: RGB and HLS elect a hue 

program , RGB or HLS. 

3. Move the sliders or click the arrows to set the color. 

4. Click OK. 

Note: 

a.If you want to save current Thread List as the default color setting 

of the program, Click Save as Default button. 

b.If you want to resume the color setting the program defaults, click 
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Resume System Default button. 

8.4 Inserting Color Change Code 

The program can deal with color change automatically, it can insert 

required Color Chang Codes or delete them. But you can also insert Color 

Change Code manually, especially when you want to use two colors to 

embroider one object while the object is very difficult to divide into two 

objects to embroider. 

8.4.1 To Insert Color Change Codes Manually 

1. First run current stitch to the position to insert Color Change 

Code. 

Or click Edit Stitch on Punch Toolbar 1 and then click at the position 

to insert Color Change Code. 

2. Open Pattern menu and choose Insert Machine Code, and the 

dialog box of Insert Machine Code(shown here as in 8-4-1-1)appears: 

  

3. Select Change Color. 

4. Click OK, and the dialog box of Color Change(shown here as in 

8-4-1-2)appears: 
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Note: 

You can get the dialog box of Color Change by clicking Color 

Change button on Machine Code Toolbar. 

5. Click the number of the color to use in the color list. 

6. Click OK. 

A Color Change Code is inserted at the current stitch position, the 

stitches after the position are showed in the new color(process shown 

here as in 8-4-1-3). 

     

8.4.2 To Delete Color Change Codes 

Run stitches to where the Color Change Code to be deleted appear 

and press Delete key. The Color Change Code is deleted from the design. 
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Note: 

You can run stitches by Color Change Code and get to the Color 

Change Code to be deleted. 

 

 

 

Chapter 9 Machine Code and Connector  

9.1 Machine Codes 

Machine Codes are usually inserted automatically by the program 

according to the properties of the embroidery object during the process of 

creating a design. If you modify the design, the program will adjust them 

automatically, like inserting or deleting some Machine Codes. You can 

also insert or delete Machine Codes manually. When you regenerate 

stitches , you can select to save the Machine Codes or not. 

You can insert manually the following Machine Codes: Change 

Color Code, Trim Code, Stop Needle Code, Slow Stitch Code, Fast Stitch 

Code, Borer On Code, Borer Off Code, Spangle On Code, Spangle Off 

Code, Trim Cover Thread Code, Pause Code and so on . 

9.1.1 To Insert Machine Code Manually 

You can insert required Machine Codes in a pattern manually. 

1.Run current stitch to where you want to insert the Machine Code. 

2.Click a corresponding button(shown here as in 9-1-1-1)on the 
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Machine Code toolbar. 

 

   

Or open Pattern menu and choose Insert Machine Code, and the 

dialog box of Insert Machine Code(shown here as in 9-1-1-2)appears: 

 

3. Click the name of the Machine Code you to insert. 

4. Click OK. 

The selected Machine Code is inserted at the current needle position. 

For details about Color Change Code, please refer to Color Change 

Code. 

9.1.2 To Delete Machine Code 

You can delete Machine Codes manually. 

1.Run current needle position to where the Machine Code to delete 
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appears. 

2.Press Delete key. 

The current Mchine Code is deleted from the design. 

Note: 

You can only delete the Machine Codes that are inserted manually. 

9.1.3 To Adjust Size and Color of Machine Code 

9.1.3.1 To Adjust Size of Machine Code 

1. Open Setting menu and choose Options. 

2.Click the label of General, and the dialog box of General(shown 

here as in 9-1-3-1)appears: 

  

3. Input a value in the Machine Code combo box(1.00mm in 

9-1-3-1). 
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4. Click OK. 

9.1.3.2 To Modify Color of Machine Code 

Please refer to Display Color for details. 

9.1.4 Saving Machine Code 

After you have made some modifications to your design, you can 

select to save the Machine Codes. 

To Save Machine Codes 

1.Open Setting menu and select Options. 

2.Click the label of Embroidery, and the dialog box of 

Embroidery(shown here as in 9-1-4)appears: 

 

3.Check the box of Reserve Machine Code when create stitches. 

The manual-inserted Machine Codes will be reserved when 
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regenerating stitches after modification. 

Otherwise, they will be lost when regenerating stitches after 

modification. 

9.2 Connector 

Connector is a special stitch penetration, which is used to link 

objects. The program will add connectors among objects. You can insert 

trim code, tie in code or tie off code for connectors 

You can set the parameter of Connector before you create a design; 

you can also modify the parameter during the process of creating a 

design. 

9.2.1 Parameter Setup for Connector 

1. Click the Connector button on Property Toolbar. The dialog box 

of Connector(shown hers as in 9-2-1)appears: 
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2. Set insert condition for Trim Code, Tie In Code and Tie Off Code 

A. First decide whether to insert Trim Code or not 

Less trim codes are better for a design, because cutting threads 

operations will slow down the work of embroidery machine. 

Check the option box of Trim if Next Connector Longer Than, 

input the value for the max length of Connector. 

Click the button of Connector on View Toolbar, you can see the 

Connector on the screen when digitizing. 

A. cut Connector is showed as a dot line with a Trim Code at each 

side of the Connector. 

B. Set parameters for Tie In and Tie Off 

You can add tie in stitches or tie off stitches when trimming threads 

or when the Connector or longer than a defined value, so as to avoid 
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loose thread. Tie in stitches are usually added after trimming thread and 

tie off stitches are usually added before trimming thread. 

There are two methods to tie in and three methods to tie off. 

a. Two Tie In methods: 

   

Add two tie in stitches at the second penetration line. 

 

Add tie in stitches at the first and the second penetration lines. 

b. There methods To Tie Off: 

   

Add tie off stitches at the last stitch. 

 

Add tie off stitches at the last penetration line. This method is 

suitable for Fill Stitch. 

 

Add tie off stitches at the last two stitches. This method is suitable 

for Satin Stitch. 

c. Set the length and the number for Tie In/Tie Off Stitch: 

Define the length and number of tie in stitches in Stitch Length and 

Stitch Number separately. 

Stitch Length: the stitch penetration length of Tie In Stitch and Tie 

Off Stitch: 
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Stitch Number: the repeat of Tie In Stitch and Tie Off Stitch. 

9.2.2 Setting Color for Connector 

The color of Connector can be set to display in two ways, one is the 

color set for itself, the other is the color of the needle of the object the 

Connector links. 

9.2.2.1 With Connector Color 

1. Open Setting menu and choose Options. 

2. Click the label of Connector. The dialog box of Connector(shown 

here as in 9-2-2-1)appears: 

 
3. Check the option box of With Connector Color. 

The color you set of Connector in Color Display box will be assigned to 

the current Connector. 

9.2.2.2 With Current Stitch Color 

Check the option box of With Current Stitch Color. 

Check the option box of Starting Point or End Point.(Now of End 

Point Available) 

The color of Selected needle is assigned to the Connector. 

9.2.3 Same Parameters for Connector 

1. Click Setting menu and choose Options. 

2. Click the label of Connector. 



 155

3. Select the check box of Same Parameter and then click the 

button of Parameter Setup, the dialog box of Connector appears. 

4. Set parameters for Connector in the dialog box. 

5. Click Ok. 

The Connectors will be of the same parameters.  

 

 

 

Chapter 10 Digitizing Based on Background Image 

Two types of graphic files can be digitized on screen: Vector 

Graphic Files and Bitmap Image Files. 

Vector Graphic is better for digitizing, because they have cleaner 

outline, after magnifying for several times, the outline is still clear, and 

further more, they can be locked in RDP2000 and thus making the 

digitizing more accurate. 

You can also use Drawing Tools in the program to create your own 

Vector Graphics. It is possible for the program to read several formats of 

Vector Graphic Files. 

Bitmap images can also be use for digitizing , but when 

magnifying them several times, the outlines of bitmap images become 

quite wide and not fit for digitizing. It cannot be locked either. 

You can scan Artwork to get a bitmap image, or import a bitmap 
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image from a saved bitmap file. 

OLE Object can also be digitized on screen. The program provides 

the method of OLE, thus expanding the functions to treat background 

images. 

Before digitizing, you need to adjust the vector graphic or bitmap 

image to the proper size and position. 

Please refer to Graphics for more details on treatment to vector 

graphics. 

Please refer to Insert OLE Object for more details on OLE objects. 

In this chapter, we will mainly discuss the treatment to Bitmap 

images. 

10.1 Reading in a Bitmap Image 

You cannot directly open a bitmap image file, but you can read in 

different formats of bitmap image files, or paste a bitmap image into a file 

of RDP2000 through clipboard. 

To Read in a Bitmap Image 

1. Open Image menu and choose Read. The dialog box of Read in 

Image(shown here as in 10-1)appears: 
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2. Click the file name to read in . Click Open to read it in. 

Or double click the name to read it in . 

The bitmap image will appear on the screen in the selected mode. 

Note: 

RDP2000 reads files of the following formats: BMP, GIF, PCX, 

TGA and TIP. 

10.2 Scanning Artwork 

The command of Scan in File menu can bring a bitmap image in 

lattice. You can scan any kind of artwork, such as photos, magazines, 

drawings, newspapers, or even a piece of embroidery. You can adopt any 

kind of scanner supported by Windows 98/95. 

To Scan Artwork 

1. Open File menu and choose Scan. The dialog box of Scanner 

(shown here as in 10-2)will appear. 
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2. Click Choose Scanner to select the scanning program. 

3. According to the program selected, different dialog box will 

appear for you to select the parameters. 

Scanning Resolution: 

Scanning Resolution is the dots per square inch. The bigger the 

number is, the clearer the bitmap image is. But bigger ratio will engage 

more storage space and thus longer time to scan in the objects. And when 

punching , you would only need the bitmap image clear enough for you to 

distinguish it, so you should select the necessary ratio. 

Recommended Scanning Resolution: 

Types of Artwork      Scanning Resolution 

Business Cards, Letter Heads     300dpi 

Hand-Draw Sketches            150dpi 

Large Photos and Pictures   100dpi 

Commercial Design, Line Image   50dpi 

Color Mode: 

You can select Black, White, Grey Scale or Color Mode according 
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to your scanner and the color of the original picture. 

4. Click Start Scanning to scan the artwork 

The artwork scanned will show on screen , it will be a bitmap 

image of lattice. 

Note: 

*Check the box of Read From File, then click Start Scanning , you 

will be able to read in a bitmap image from a file. It is the same as the 

command of Read in Image menu. 

*Before scanning, make sure the scanner is on before starting 

RDP2000. 

10.3 Adjusting the Size and Position of Bitmap Image 

Before digitizing the image, you need to adjust the size and 

positions of it. You can adjust it through the commands of Rotate, Move, 

Zoom Out, Zoom In and Mirror. But the bitmap image is still a picture 

in RDP2000 and you cannot modify the picture itself. 

10.3.1 To Rotate a Bitmap Image 

The command Rotate is applicable to both general objects and 

bitmap images. Please refer to Rotate Object for details. You can also 

rotate bitmap images in the following steps: 

1. Select bitmap image to rotate with Pick Tool.’ 

2. Open Image menu and choose Rotate, select the rotation angle. 

The command of Rotate is to rotate the bitmap images in the set 
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angles of 90, 180,270. 

It is applicable only to bitmap images. 

The often used edit way to edit a picture is to change the picture 

rotate angle and size. RDP2000 offers two special methods to rotate the 

picture and set its size, that’s Horizontal Position and Set Size. 

Horizontal Position: choose the picture object at first, input two 

reference points, the picture will rotate to the horizontal direction decided 

by the two reference points. 

Set Size: choose the object at first, input two points, the Set Size 

dialog box appears on the screen, you can set the rotate angle, and 

through setting the length between the two points, to change the size of 

the picture. 

10.3.2 To Adjust Brightness of a Bitmap Image 

You can adjust the brightness of a bitmap image. 

1. Select the bitmap image with Pick Tool. 

2. Open Image menu and choose Adjust Brightness. 

Or click Adjust Brightness button  on Property Bar of Bitmap 

Image. 

In the dialog box of Adjust Brightness (shown here as in 10-3-2), 

the left window illustrates the original image and the right one is the 

preview window. 
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3. You can adjust the brightness through the slider or input the 

value in the Combo Box. 

4. Click OK when finishing . 

10.3.3 To Resume Original State 

After rotating or changing the size of bitmap image, you can adopt  

After rotating or changing the size of bitmap image, you can adopt the 

command of Resume Original State to get to the original state when the 

graphic was read in. 

1. Select the changed bitmap image with Pick Tool. 

2. Open Image menu and select Resume Original State.  

Or click Resume Original State button on Property Bar of Graphic. 

Note: 

This function only can resume the original angle and width/length 

scale of the picture, can not resume its original size. 

10.3.4 To Lock a Bitmap Image 

You can stop editing one or more bitmap images on the certain 
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positions of screen so that they will not move during the process of 

digitizing. When select Lock, you can not select the bitmap image with 

Pick Tool not adjust it. 

To Lock a Bitmap Image 

1. Select the image with Pick Tool. 

2. Open Image menu and choose Lock. 

To Unlock the Bitmap Image 

You can resume editing. When you select Unlock, the locked 

bitmap image resumes original state and you can select it and edit it 

again. 

Open Image menu and choose Unlock. 

10.4 Saving Bitmap Images 

You can save a bitmap image together with the design as well as 

save it alone. When saving with a design, save it with the commands of 

Save or Save AS…When saving alone, follow these steps: 

To Save a Bitmap Image Alone 

1. Select the bitmap image to save with Pick Tool. 

2. Open Image menu and choose Save or Save as… 

3. Input the name for the bitmap image in the dialog box thus 

appears. 

Note: 

The formats of BMP and PCX are allowed in RDP2000. 
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10.5 Displaying or Hiding Background Image 

When digitizing images, you can select to display or hide bitmap 

images on screen so as to examine stitches more clearly. 

To Display or Hide Background Graphic 

Open View menu and choose Background Image. 

Note: 

The command is applicable only to bitmap images and OLE 

objects. 

1. Open Setup menu and choose Options. 

2. Click the Label of Graphic. The dialog box of Graphic(shown 

here as in 10-5)appears: 

   
3. Check the boxes of Images as Background or/and OLE Object 

as Background. 
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Chapter 11 Insert OLE Objects 

11.1 Creating a New OLE Object 

You can start another program besides Richpeace Design Pro 2000, 

create an object and insert it in a design in RDP2000. 

11.1.1 To Create an OLE Object 

1. Open an existing design or create a design. 

2. Open Edit menu and select Insert New Object. And the dialog 

box of Insert Object(shown as 11-1-1-1)appears: 

3. Choose Create New. 

4. Select the type of application program in the list. 

5. Click OK. 

    

6. When the selected program started, you can create a new object 
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in it for RDP2000. 

11.1.2  To Exit to RDP2000 

Click at any point outside the Application Window or click Exit to 

get back to RDP2000, and you will exit back to RDP2000 with the new 

object created in the application program inserted. 

11.2 Linking an Object 

11.2.1  To Link an Object to RDP2000 

1. Open an existing design or create a design. 

2. Open Edit menu and choose Insert New Object. 

3. Select Create from File(shown here as in 11-2-1-1). 

   

4. Click the button of Browse to select the file for the link in the 

dialog box of Browse(shown as 11-2-1-2)thus appears; 

5. Select the file and then click the button of Insert and the dialog 

box of Insert Object appears again. 

6. Check the box if Link and then click OK. 

The chosen file has been inserted into your design. 
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11.2.2 To Edit a Linked OLE Object 

To edit a linked OLE object, you need to edit the original object in 

the application program. You can start the application program through 

RDP 2000.You need to save the operations so that they will be reflected 

in the linked OLE object in RDP 2000 

1.Select the linked OLE object with Pick Tool 

2.Open Edit and choose Object, then choose Edit in the menu thus 

appears. 

Or double click the OLE object 

The application program will start and the object will be opened 

And you can edit the object in the application program 

Note: 

The from of the command of Object in Edit menu will vary with 

the application: the OLE object from Corel DRAW will make it Corel 

DRAW Object ,for example. 

If you do not need the content of the file ,you can select Display as 

Icon in the dialog box of Insert Object 
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11.2.3 To Update a linked OLE Object 

When linked ,the object updates with the editing of the original 

object in the application program . If you do not need the linked object to 

vary with the original object ,you can update it manually 

To Update Linked OLE Object Manually 

1.Open Edit menu and choose Link. The dialog box of 

Link(shown as 11-2-3-1)appears: 

 

2.Select the file in the list.  

3.Check the box of Manual 

To Update a linked OLE Object Automatically 

Follow the above Step 1 and 2,and then select Automatic 

11.2.4 TO Change Source of an OLE Object 

When changing the content of linked OLE object ,you can change 

the source of the linked OLE object. Please be noted that when the 

contents of the new source and the old source are the same type you can 

only change the content , it is still in the same position of the design .If 

the contents are not of the same type ,there might be come severe changes 



 168

to the design 

1. Select the linked OLE object with Pick Tool. 

2. Open Edit menu and choose Link. And the dialog box of Link 

appears 

3. Click Change source, and the dialog box of Change Source  

appears 

4. Seek the file of new origin object  

5. Double click the name of the file . 

Or click the name of the file and click OK. 

In the above example ,the origin object to another Word document 

and the contents are changed. 

11.2.5  Break the Link to an OLE Object 

If you do not need to update an OLE object ,you can break the link. 

When you have selected to break the link ,it cannot be resumed and the 

object canot be edited 

1. Select the OLE object with Pick Tool 

2.Open Edit menu and choose Link. The dialog box of 

Link(shown here as 11-2-5-1)appears: 
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3. Click the button of break link. 

4. Before the program stops the Link, you will be reminded(as 

shown in11-2-5-2) 

  
5. To break it ,click YES.  To resume the link, click NO 

11.3  Inserting an OLE Object 

Insertion is another way to position an OLE object in RDP2000.An 

Inserted OLE object is a part of the design ,not linked. So when you deit 

the origin object ,the inserted OLE object will not vary with it. 

11.3.1 To Insert an OLE Object 

1. Open Edit menu and choose Insert New Object. 

2. Click the button of Create From File. 

3. Click Browse to select the object to insert. 

4. Check or uncheck the box of Link. 

5. Click OK. 

TO Insert an OLE Object 
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1. Start the application window containing the object to insert. 

Make sure that both the application window of the program are within the 

interface. 

2. Select the object to insert in the application program 

3. Drag the selected object into the design window of 

RDR2000.And it is now an inserted OLE object. 

Note: 

You can also insert the object by copying it to the Clipboard and 

then pasting it to the program .RDP 2000provides standard Windows 

Clipboard operation, you can use it for the exchange of date between 

applications. 

11.3.2 To Edit the Inserted OLE Object 

1. Select the inserted OLE object with Pick Tool 

2.Open Edit menu and point to Linked Object and choose Edit in 

the menu thus appears 

The application program will appear in design window ,and you 

can edit the inserted OLE sbject now. 

Note: 

* Double click the object will also start the application program 

within the program. 

* The item of Object menu varies with the type of the object ,For 

an example: when the object is a CorelDRAW object ,the item will show 
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as Coreldraw Linked Object. 

11.4 Editing an OLE Object as a Different Type of OLE Object 

11.4.1 To Edit an OLE Object as a Different Type of OLE Object 

1. Select the OLE object with Pick Tool. 

2. Open Edit menu and choose Convert…of Object 

3. In the dialog box of Convert , check the option box of Activate 

As (shown here as in 11-4-1) 

       
4. Select the type to convert into in the list 

5. Click OK. 

Note: 

When carrying out the command ,you are not changing the type of 

the object , but change the way to edit it  

11.4.2 Convert an OLE Object into Another Type 

1. Follow the above Step 1 and 2. 

2. Check the option box of Convert to  

3. Select the type to convert into in the list 
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Chapter 12 Usage of Digitizer Tablet 

Traditional digitizing operation was realized through the help of 

Digitizer Tablet .The puncher had to magnify the artwork several times 

and draw the outline of it by hand ,then the drawing was fixed to the 

Digitizer Table so that the puncher could digitize the artwork with the 

mouse and so the artwork was transferred to the punch design.  

Use of Digitizer Tablet can help achieve precision ,so it has been a 

popular method to most traditional punchers. 

To satisfy the different need , Richpeace Design Pro 2000 Series 

support operation of Digitizer Tablet. 

12.1 Using and Maintaining the Digitizer Tablet  

12.1.1 To Connect Digitizer Table 

Before using Digitizer Table, you need to Connect  it to your 

computer first. 

1.Install Digitizer Table :link Digitizer Table to the serial port and 

then power it on  

2.Connect Digitizer Tablet: Start RDP 2000, open Setting menu 

and choose Connect Tablet . And two beep sounds indicate connection 

success. 

12.1.2 Setup Digitizer Table 
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Before using Digitizer Table, you need to setup it. 

1.Open Setting menu and choose Table, The dialog box of 

Digitizer tablet setup (shown here as in 12-1-2-1). 

2.The text boxes of Table Name and Tablet Size tell those of the 

present Digitizer Table. 

      

Note: 

You need to set the page of RDP 2000 the same as that of the 

Digitizer Table. Please refer to Page Setup for more details. 

3.Setup Drawing Ratio  

Input value in the text boxes of Scale A and Scale B 

Scale A =width of magnified drawing along Reference Line/width 

of product along Reference Line 

Scale B=height of magnified drawing along Vertical Reference 

Line /height of product along Vertical Reference Line 

Most magnified drawing have the ratio as 3:0. 
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When you need to distort the pattern in ratio, you can set Scale A 

and B with different value. 

4.When using Digitizer Table for the first time, you need to register 

the Drawing Menu Chart and Screen Area. 

For Menu Chart and Screen Area, you only need to register once.  

Choose Register Menu Chart of Menu Chart Position and 

Register Drawing of Drawing Position and Setup Screen of Screen 

Position 

5.Click OK 

6.Register Drawing : input the Origin and Rotation Reference Point 

Point the cross cursor of mouse to the Origin of drawing and click No 2 

Key of the mouse ; point cross cursor to the Rotation Reference Point of 

drawing and click No 2 key of mouse. 

7.Register Menu Chart: input the three reference Points of Menu 

Chart .Mark the points with mouse in the following order : Reference 

Point 1, the upper left corner of Menu Chart ; Reference Point 2, Lower 

left corner of  Menu Chart ; Reference Point 3, lower right corner of 

Menu Chart  

8.Setup Screen : input the two Reference Points screen area ,Point 

cross cursor to the two points in the following order and click No 2 key : 

Reference Point 1,upper left corner of screen area ; Reference Point 2, 

lower right corner of screen area. 
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Register completed. 

When you move the cross cursor on Digitizer Table ,the cursor on 

screen will also move. You can digitize from the digitizer tablet now 

Note: 

* The input screen area cannot cover the drawing. 

* If you want to choose commands from screen , you need to move 

the mouse to the relative location on Digitizer Tablet. 

12.1.3 Reference Line Angle 

You can set the Reference line angle to any value .Choose Ref Line 

Angle and input the value in the Text Box. When it is 0, the Reference 

Line will be rotated horizontally; when it is set 90, the Reference Line 

will be rotated vertically. 

If you do not choose Ref Line Angle . no rotation will happen to 

the drawing . It will appear on screen as it is on the Digitizer Table. 

12.2 Usage of Mouse 

12.2.1 Mouse 

The mouse of Digitizer Table is different from that of computer 

Most Digitizer Tablet mouse has four keys and a cross cursor (shown here 

as in 12-2-1) 
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Cross cursor : when marking Reference points , you need to point 

the cross cursor to the point on the Tablet and click the relevant key of the 

mouse. 

No 1 key: Usually defined as Backspace key , like that on 

keyboard. 

No 2 key: Usually defined as Input key, like the left key of a 

computer mouse. 

No 3 key: Usually defined as Finish key ,like the right key of a 

computer mouse. 

No 4 key: May be defined as the Set Center key. 

12.2.2 To Define Mouse Keys 

1. Open Setting menu and choose Options. 

2. Click the Label of Digitizer Table and the dialog box of 

Digitizer Tablet (shown her as 12-2-2-1) appears. 
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3. Modify the function of the key in the list of Functions. 

4. Click the button of Press Button on Digitizer Tablet with the 

key to modify. 

5. Modify other keys in the same way. 

6. Click OK when finishing modifying all the keys. 

Warning: Do not modify the default setup of left key because the 

mouse would not be available if there were no setup of left key. In case it 

is changed , you can use computer mouse instead and resume the default 

setup of left key in the above steps. 

12.3 Moving and Registering Magnified Artwork 

There are two Reference Points in magnified drawing : Origin and 

Rotation Reference Point ,you can mark them on the drawing for later use 

of the drawing. 

You can change the size ratio at any time during the process of 

digitizing, and the program will change the size according to the changes 

and generate stitches. 

If the Drawing is bigger than Digitizer Tablet, you can move the 

drawing . 

To Move Artwork 

When moving drawing on the Tablet , you need to mark the two 

Reference points on it and make sure that they will not exceed the Tablet 

during the process of digitizing. 



 178

1. Mark the two Reference Points on the drawing. 

You can mark them at any point of the drawing , but you need to 

make sure that they will never exceed the Digitizer Table all the way 

through when you move and punch it on the Table. 

2. Open Setting menu and choose Digitizer Tablet (shown here as 

12-3-1) 

 
3. Click move Drawing of Drawing Placing and then click ok. 

4. In the status Bar on screen, you are reminded to Input Reference 

Point 1 on Drawing , point the cross cursor to the first Reference Point 

and click No 2 key. Then you are reminded to Input Reference Point 2 on 

Drawing point the cross cursor to the second Reference Point and 

click No2 key. 

5. Move the magnified drawing on the Tablet and mark sure that 

the area for punching is within the available area on the Tablet, the 

Reference Points just marked must be within the available area of the 
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Tablet , too. 

6.Input the two Reference Points after the drawing again is moved 

in the same step of Step 4. 

Now you can continue you designing on the moved part and the 

program will link the parts together. 

Note: 

 The Reference Points input in Step 6 must be exactly the same 

points . 

 When the drawing is really very large and you cannot finish it even 

when you have moved it once , you can move it time and time again. 

Just make sure the Reference Point input each time before and after 

the moving the same. 

12.4  Modifying Drawing Size Scale 

You can modify the size scale of drawing during the process of 

digitizing, and the program will alternate the size of pattern and generate 

stiches. 

To Modify Drawing Size Scale  

1. Open Setting menu and choose Digitizer Table(shown here as 

12-4-1). 

2. Modify the Scales in the combo boxes of Scale A and Scale B. 

3. If you choose Resize Design for Drawing , the digitized parts 

will change size for the new scales , or else ,they will not change 
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according to the scales. 

  
4. Click OK. 

12.5Moving and Registering Menu Chart 

Menu Chart is a series of blocks of orders in Tool Bars and menus. 

You can place them at any angle on the Digitizer Tablet, but they should 

not cover the drawing, Before using the Tablet , you need to register the 

Menu Chart by inputting the three Reference Points please refer to Setup 

Digitizer Tablet. 

During the process of digitizing , you may need to move the Menu 

Chart so as to avoid covering the drawing after it is moved . 

To Move Menu Chart 

1. Open Setting Menu and choose Digitizer Tablet. 

2. Choose Register Menu. 

3. Click OK. 

4. Input the three Reference Point of the Menu Chart and the Menu 
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Chart will be moved to the new location. 

12.6 Preparing Magnified Artwork for Digitizing  

1. Magnify: Magnify the drawing three of five times . 

2. Decide the Multiple: Calculate the multiple and mark it on the 

drawing. 

Multiple=size of magnified drawing/size of original drawing 

3. Trace: Analyze the characteristics of the drawing , such as the 

width of letters, the symmetry of the drawing ,etc. 

a. Draw the magnified drawing in lines . 

b. Make sure the lines are even, and flat at corners 

Note: 

You need to repair those irregular parts of the drawing and mark 

the Diredtion 

Lines. 

4. Mark the Reference Points of Origin and Rotation 

12.7 Connecting/Disconnecting Digitizer Tablet 

To Disconnect Digitizer or Connect Tablet 

You can connect and disconnect the Digitizer Tablet during the 

process of digitizing: 

1. Open Setting menu and choose Disconnect Tablet. 

2. When you need to reconnect Digitizer Tablet, open Setting 

menu and choose Connect Tablet. 
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Chapter 13 Draw Basic Graphics 

RDP 2000 offers you series of Draw Tools to create the basic 

graphics that compose a drawing file. Every drawing file is built up with 

several basic graphics. 

When you need to use a draw tool, click the corresponding button 

on the Draw Toolbar , then create the shape according to particular 

regulations. After you have selected a draw tool, the Property bar will 

change along with the change of the tool selected. 

13.1 Drawing Bezier Lines 

The Bezier Tool lets you draw lines and curves by placing each 

node with the mouse. As you place each node, it is connected to the 

previous placed node by a line or curve . This connect-the –nodes method 

lets you create complex , irregular shapes quickly and easily and gives 

you precise control over the position and number of nodes that form a 

curve. 

1. Click Bezier Tool Button  on Draw Toolbar click the mouse 

to input the staring node . 

2. Move the mouse and click the mouse to input the first control 

point of the curve . 
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3. Move the mouse to input the second control point. Now, a 

segment appears between the two nodes. As you input more nodes control 

points appear. The position and angle of the control points decides the 

shape of the segment created and the next segment to create. 

4. Repeat the steps till you finish the curve(process shown here as 

in 13-1) 

        
13.2 Drawing polylines 

The Polyline Tool lets you draw polylines with any directions. 

1. Click the polyline Tool button  ,then position the cursor 

where you want the first node of the polyline to appear and click the 

mouse. 

2. Move the mouse to the second node of the playline, and click the 

mouse. 

3. Repeat step 2 to input other nodes of the polyline till the end . 

4. Click the right mouse button to finish input, In this way, you can 

draw polylines with any shapes and lengths (process shown here as in 
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13-2) 

     

     

13.3 Drawing polygons or Stars  

The polygon Tool lets you draw polygons or stars. 

1. To draw a polygon , click the polygon tool button , input 

points number of the polygon in Number of Points of Polygon (3 to 500) 

on property Bar(shown here as in 13-3-1)Position the cursor where you 

want the polygon to appear and click the mouse. Drag diagonally to draw 

the shape , click the mouse to finish input (shown here as in 13-3-2). 

    
2. To draw an intercross star , first draw a polygon and then click 

the polygon/star button on property Bar (shown here as in 13-3-3) 

when it changes to the Star button, it will convert polygon to intercross 

star (shown here as in 13-3-4); when it change to the polygon button, it 

will convert intercross star to polygon again. 

    

Notes: 
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Hold down CTRL while you drag to create polygons with equal 

sides , release the mouse button and then release CTRL. 

13.4 Drawing Rectangles 

The Rectangle Tool lets you draw rectangles and squares. 

1. To draw a rectangle , click the Rectangle Tool button  

position the cursor where you want the rectangle to appear and click the 

mouse , drag diagonally to draw the shape ,click the mouse to finish 

drawing (shown here as in 13-4-1). 

                     

2. If you want to draw a rectangle with round corners ,select a 

rectangle shape , then adjust the roundness of rectangle’s corners in the 

Rectangle Corner Roundness on the Property Bar (shown here as in 

13-4-2)you can input a value or move the slider on the most left side of 

the sliding axle(shown here as in 13-4-3) 

          
3. To draw a square , hold down CTRL key while you drag the 

mouse . Release the mouse and then the CTRL key, and a square is drawn 

instead of a rectangle. 

13.5 Drawing Arcs 

The Arc Tool(Arc with three control points )lets you draw arcs with 

any shape . 
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1. Click the Arc Tool button  , position the cursor where you 

want the first control point of the arc to appear, click the mouse. 

2. Move the mouse to input the second control point of the arc 

3. Move the mouse to input the third control point and an arc is 

formed. 

4. If you want to draw a consecutive arc, begin at the last point of 

the previous arc, repeat step 2 and step 3 till the end, click the right 

mouse button to finish input (process shown here as in 13-5). 

The program offers 4 types arc shape , that’s Normal, S Shape , 

Wave Shape and Arch Shape . The input method for S and Wave shape 

arc are the same with Normal arc (three points) for Arch shape arc only 

needs to input two points for the start and end point of the arch . 

While holding down T key , you can input the tangent arc, which is 

more smooth at the joints of arcs . 

               

13.6 Drawing Circles 

The Circle Tool lets you draw circles with any sizes. 

1. Click the Circle tool button , position the cursor where you 

want the circle to appear , click the mouse.. 

2. Drag diagonally to draw the shape and click the mouse to finish 

the input(shown here as in 13-6) 
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Note: 

The circle has start point and direction; clockwise and 

anticlockwise. So you can fill a circle with Satin stitch objects. 

               
13.7 Drawing Splines 

The Spline Tool lets you draw splines with any shape. 

Click Spline Tool button . Position the cursor where you want 

the first node of the spline to appear and click the mouse, and move the 

mouse to next node of the spline and click the mouse , Repeat these 

operations till the last node of the spline, click right nouse button to finish 

the input and a spline is formed (process shown here as in 13-7). 

  

13.8 Drawing Ellipses 

The Ellipse Tool lets you draw ellipses , pies and arcs with any 

shape. 

1. Click the Ellipse Tool button  (shown here as in 

13-8-1)then position the cursor where you want the ellipse to appear and 

click the mouse . Drag diagonally to draw the shape , click the mouse and 

an ellipse is formed (shown her as in 13-8-2). 
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2. If you want to convert an ellipse to a pie , first draw n ellipse , 

then click the pie Tool button(shown here as in 13-8-3),the ellipse is 

concerted to a pie (shown here as in 13-8-4). if you click Pie Tool button 

before hand, you can draw a pie directly (shown here as in 13-8-4). 

         
3. Convert to arc First select a formed ellipse or a pie , then click 

Arc button on Property Bar(shown here as in 13-8-5),you can change an 

ellipse or a pie to an arc. If you click the button before hand , you can 

draw an arc directly (shown here as in 13-8-6). 

          

4. Convert to another half . Select a pie or an arc, click clockwise 

/Counterclockwise Arc or Pie button on Property Bar, and you can 

convert the shape to another half of the pie or the arc.(shown here as in  

13-8-7,13-8-8) 

              
Note: 

You can modify the wedge of a pie or an arc by changing the 
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starting Angle and the Ending Angle on the Property Bar. 

Hold down Ctrl while you drag to create a circle ,release the mouse 

button , and then release Ctrl. 

13.9 Drawing Spirals 

The Spiral Tool  lets you draw spiral shape . There are two 

types of spiral: Symmetrical and logarithmic spiral. 

1. To draw a symmetrical spiral (shown here as in 13-9-2)(1)Click 

Spiral Tool button . (2)Click Symmetrical Spiral button on Property 

Bar(shown here as in 13-9-1)(3)Input the value in Number of 

Revolutions box on Property Bar to indicate the number of revolutions 

you want for the spiral(4)Position the cursor where you the spiral to 

appear and click the mouse (5)Drag diagonally to draw the shape (6)Click 

the mouse to finish the input, a spiral is formed. 

       

2. To draw a logarithmic spiral (shown here as in 13-9-4):(1)Click 

Logarithmic Spiral button on property Bar(shown here as in 

13-9-3).(2)Move the slider on the sliding axle to change the Expansion 

Factor of the spiral.(3)Position the cursor where you want the spiral to 

appear and click the mouse.(4)Drag diagonally to draw the shape (5)Click 

the mouse to finish the input , a spiral is formed. 



 190

       
Note: 

Hold down CTRL while you drag to create a right-handed spiral, 

release the mouse button , and then release CTRL. 

Once a spiral object is created, it becomes Bezier Line, cannot be 

edited in the way for spiral. 

13.10 Drawing Compound Curves 

The Compound Curve Tool  lets you draw all kinds of curves. 

There are five curve types in the Compound Curve: line , spline, arc , 

quadric Bezier and cubic Bezier. User Can define his own Curve type in 

the Compound curve. 

To Define Compound Curve by youself 

1. Open Setting mene, and choose Options. 

2. Click the label of Graphic, The dialog box of Graphic (shown 

as in 13-10-1)appears: 
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3. Select the curve types in the compound Curve switch option. 

Select or forbid the types in the check boxes. 

4. Click OK. 

When you choose line and arc , the compound curve is composed 

of line and arc. 

To Draw Compound Curve 

Click the compound Curve Tool; click the mouse where you want 

to input the nodes of the curve , you can shift curve types according to the 

shape of the curve. 

Press Shift , you can shift line , spline , arc, quadric Bezier and 

cubic Bezier in turn. You may also use shortcuts to shit :L for line; S for 

spline ;A for Arc; Q for quadric Bezier and C for cubic Bezier. 

Note: 

In the shift operations mentioned above , the curve types can only 

shift among the curve types you defined. If you just select line and arc, it 
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will shift between line and arc. 

Click right mouse button to finish the input. 

13.11 Drawing EDcurves 

The EDcurve Tool lets you draw curves with equal distances. 

There are three types of EDcurves : On First Side, on second side and on 

both sides. On Second Side and on both sides . You can select EDcurve 

type on Property Bar. 

1. Click EDcurve Tool button.  

2. Select EDcurve type in the Type pull down list on Property 

bar and adjust the width of the EDcurve. 

3. Position the cursor where you want the EDcurve to appear and 

click the mouse .Move the mouse to input other nodes of the segment 

(you can shift the curve type at any moment, please refer to Compound 

curve )Click right mouse button to finish the input. 

Select Type of EDcurve 

There are three types of EDcurves: On First Side, On Second Side 

and On Both Side . 

(a) On First Side: 

 

(b) On Second side: 
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(c) On both Side: 

      

Note: 

The first side is the left side to the processing direction of the 

digitized line, the second side is the right side. 

13.12 Drawing Meshes 

The Mesh Tool lets you draw meshes with any row number and 

column number. 

1. Click the Mesh Tool button.  

2. Input row number and column number of the mesh in the row 

number and column number box on Property Bar(shown here as in 

13-12-1). 

       

3. Position the cursor where you want the mesh to appear and click 

the mouse. 

4. Drag diagonally to draw the shape. 

5. Click the mouse and a mesh is formed shown here as in 

13-12-2) . 
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Note: 

Hold down CTRL while you drag to create a mesh with equal units, 

release the mouse button, and the release CTRL.  

Mesh is some special group of objects , once it’s created,  it 

becomes a group of rectangle objects , cannot be edited in the way for a 

mesh. 

13.13 Drawing Close Curves 

The Close button  lets you convert any curves to close 

curves. 

1. Use Pick Tool to select a formed curve. It can be made with 

Curve Tool, Polyline Tool, Arc Tool , compound Curve Tool or Bezier 

Tool. 

2. Click Close button on Property Bar. 

3. The two nodes at the hatch of the curve will be linked 

automatically to form a close-curve (shown here as in 13-13). 

             
13.14 Parameter Setting  

You can set involved parameters of the graphic on Property Bar 

before hand, or you may modify the parameter value on Property Bar or 

in the dialog box of Object Attributes. You can even set parameter value 

for all graphics in a dialog box. 
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Set Parameters 

1. Open Setting menu and choose Options.  

2. Click the label of Graphic and the dialog box of Graphic 

(shown here as in 13-14-1)appears: 

       
3. Select the name of the graphic to be modified in the Graphic 

Parameters pull-down list  

4. Click Setup button, a corresponding attribute dialog box 

appears. 

For example , when you choose EDcurve, the EDcurve Attribute 

dialog box (shown here as in 13-14-2)appears: 
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5. Adjust these parameters in the dialog box , then click OK. 

6. Adjust parameters of all kinds graphics in the same way 

mentioned above. 

7. After finish setting click OK. 

Connect for graphic objects 

In this new version software, you can set the connect for some kind 

of graphic object , which is special used in Quilting design. 
 

 

 

Chapter 14 Edit Graphic Objects 

Each graphic is made up of paths and each path is constituted with 

nodes and segments (the part between any two nodes). You can change 

the shape of graphic by modifying nodes and segments. The tool most 
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ofter used to edit nodes is the Shape Tool . It lets you add, delete and 

move nodes, or to change the properties of nodes to change the shape of 

the graphic. 

To some graphics, like rectangle, ellipse and polygon, which are 

formed in particular methods, you will come up with limit when you try 

to use Shape Tool to edit them. To curve graphic, however, there is no 

limit, Graphics, it does not matter what kinds they are, can be finally 

converted to compound curves. Once they are converted to compound 

curves, the modification to them will bound limit and more. 

14.1 Editing Basic Graphics 

Such graphics as rectangle, circle, ellipse or polygon are formed in 

a particular method. Each node of them is related to its corresponding 

nodes, so when you change one node, all involved nodes will be changed 

too. For example, you can change all corners of a rectangle into round 

corners at one time. 

If you want to modify the shape of a graphic at will, you can 

convert it to compound curve. However, when it is changed to compound 

curve, it can not be formed in the original method. For example, when 

you convert a rectangle to a compound curve, you can not form a 

rectangle with round corners by only dragging the mouse. 

Warning: You can not delete any node of a rectangle, circle, 

ellipse or polygon. Once you delete a node, the whole graphic will be 
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deleted. 

14.1.1 To Edit Rectangle and Square 

You can use the Shape Tool to modify the roundness of the corners. 

There is a node at every corner of the rectangle, when you modify the 

roundness of corners, each of the nodes at the corners is divided into two 

nodes and an arc is formed between the two nodes. You can control the 

size of the are by moving any node at the corner. Whenever you try to 

modify a corner, the other three corners will also change along with the 

modification of the corner. 

To Modify Corner Roundness 

1. Click Shape Tool button. 

2. Click the object to modify, the outline and control points of the 

object(process shown here as in 14-1-1-1)appear. 

                
3. Click the node and drag along the outline of the graphic. Each 

of the nodes is divided into two nodes while you drag and round corner is 

formed between nodes(shown here as in 14-1-1-2). 

                  

Note: 
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You can modify the roundness of corner by moving the slider in the 

Rectangle Corner Roundness bar on Properties Bar(shown here as in 

14-1-1-3). 

             

14.1.2 To Edit Ellipse and Circle 

You can use Shape Tool to corvert an ellipse or a circle to a pie or 

an arc. There is only one node in an ellipse or a circle. When it is changed 

to pie or arc, this node is divided into two. You can control the 

appearance of the pie or arc by moving these two nodes. 

To Convert Ellipse to Arc or Pie 

1. Select the ellipse(shown here as in 14-1-2-1)with Shape Tool 

2. Click the node on the outline of the ellipse and drag it to form a 

pie(process shown here as in 14-1-2-2) 

        
Note: 

Select the object with Pick Tool or Shape Tool, click the Pie Tool 

button or the Arc Tool button on Properties Bar, you can convert ellipse 

to pie or arc quickly, and vice versa. 

Note: 

The circle here refers to the one drawn by the Ellipse Tool. The 
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circle drawn by Circle Tool has four nodes. These four nodes are 

correlative, move one of them, other three node will move too. So if you 

use Shape Tool, you can only change the radius of the circle(process 

shown here as in 14-1-2-3). 

   

14.1.3 To Edit Polygon 

Each node of polygon is correlative with all its corresponding 

nodes.All nodes at corner are correlative and all nodes on sides are 

correlative too. So when you try to change one node, all its correlative 

nodes will change too. 

For example, there are ten nodes in a pentagon. There is one node 

at each corner and each side. All corner nodes are correlative and all side 

nodes are correlative too. If you try to move one side node, all other side 

nodes will move too (process shown here as in 14-1-3-1). 

        

14.2 Editing Curve Object 
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Shape Tool lets you modify the shape of all curve objects by 

editing their nodes and segments. The curve objects can be any lines or 

curves made by Bezier Tool, Polyline Tool, Spline Tool, Arc Tool, 

Spiral Tool, EDcurve Tool and Compound Curve Tool. Moreover if 

you have converted rectangle, ellipse, polygon or text to compound 

curves, they are all curve objects. 

You can use Shape Tool to add, delete, or move the nodes of the 

curve object. You may also change the properties of the nodes and 

segment. 

14.2.1 To Select Nodes 

You should first select the node you want to edit before you do any 

operations to the node. 

To Select Single Node 

1. Click Shape Tool button 

2. Click the object to modify, the nodes(and the control 

points)appear on the screen. 

3. Click the node you want to modify. 

Select node is showed in solid color(Shown here as in 14-2-1-1) 
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To Select Multi Nodes 

1. Select the object with Shape Tool. 

2. Click the first node you want to select. 

3. Hold down Ctrl, and click next nodes one by one(shown here as 

in 14-2-1-2) 

                 

To Select Nodes with Spring Box 

You can also use the mouse to drag a bounding outline to select 

several nodes. 

1. Select the object to modify with Shape Tool. 

2. Click the mouse and drag out a bounding outline around the 

nodes to be selected. 

3. Release the mouse, all nodes within the bounding outline will 

be selected(process shown here as in 14-2-1-3). 

                

To Delete Selected Nodes 
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If you want to delete selected nodes, just press Delete key on 

keyboard. 

14.2.2 To Move Nodes 

You can change the shape of the object by moving the nodes, 

control points or segments of the curve. Usually we first move the nodes 

and the segments to modify the shape roughly, and then move the control 

points to adjust the object accurately. 

The node is shown in empty pane(the node of curve is shown in 

empty circle). The control point, however, is shown in a circle with +or- 

in it. 

To Move Nodes of an Graphic Object 

1. Select the node to modify with Shape Tool. 

2. Drag the node to where you want the node to appear and release 

the mouse(process shown here as in 14-2-2-1). 

                  

To Change Shape of Object by Moving Control Point 

1. Select the control point with Shape Tool. 

2. Drag the control point. 

You can control the shape of the curve accurately by moving the 

control points. 

Note:  
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If you position the cursor to the curve outline without nodes and 

drag the mouse, you will move the whole object. 

Minim Movement of Nodes 

Hold down Ctrl, Press four direction keys on the keyboard, you 

can give minim movement to the nodes in four directions separately. 

1. Select the nodes to move with Shape Tool. 

2. Hold down Ctrl, press any of the four direction keys , the 

selected node will move 0.1mm each time you press the four direction 

keys. 

Note: 

You can set the unit if minim movement by yourself. For details 

please refer to Object modification. 

14.2.3 To Add Nodes 

If the existing nodes can not result in satisfying effect, you can add 

some nodes properly to achieve the effect. 

To Add Nodes 

1. Select the object to modify with Shape Tool. 

2. Position the cursor where you want to add a node on the outline 

of the curve and click the mouse, a new node is added on the curve 

(process shown here as in 14-2-3-1). 

14.2.4 To Delete Nodes 

You can delete nodes from the curve. 
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1. Select the nodes to delete with Shape Tool. 

                
2. Press Delete key on keyboard. 

The node will be moved from the curve. 

14.2.5 Edit Node Dialog Box 

You can use a Edit Node dialog box to add or delete nodes, to 

divide and close curve , to modify properties of node, or to make the 

smoothness of node and generate symmetry node. 

Double click the node to modify with Shape Tool, and the Edit 

Node dialog box(shown here as in 14-2-5)will appear. 

          
Note: 

You can place the dialog box of Edit Node anywhere you like in 

the interface and it will not affect you to do other operations. When you 

want to use it, you just need to click a node to active the dialog box. 

1. Add: adds one to several nodes to the object. 

2. Delete: deletes one or several nodes of the object. 
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Note: 

If the Edit Node dialog box is on the screen, you can delete several 

nodes at one time by carrying it out. Otherwise, you can only delete one 

node at one time. 

3. Divide: divides the object into two objects from the selected 

node. 

4. Close: Links two nodes at the hatch of the curve so as to form a 

close curve. 

5. Smooth: makes the sharp-angled nodes smooth. 

6. Symmetry: generates two symmetry nodes. However it changes, 

the two nodes are always symmetry. 

Note: 

a. Smooth and Symmetry only fit to Bezier Curve. 

b. Unless the curve changes its direction clearly at the position 

where the node locates, it will not change the shape of the curve 

remarkable when you carry out Smooth or Symmetry. But it will affect 

the way to change the shape. 

7. Convert node to that of Line, Spline, Arc, Quadric Bezier or 

Cubic Bezier: converts node to that of spline or line of corresponding 

type. 

There are shortcuts for these commands: 

A + Shift, convert to that of arc; or cover arc point to line nodes. 
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S + Shift convert to that of spline; or conver spline point to line 

nodes. 

Q + Shift convert to that of quadric Bezier; or convert Quadric 

Bezier to line nodes. 

Shift convert to Line and then shift between line and spline. 

Note: 

Not all nodes can be edited. Only when the command buttons in 

black in current dialog box can you carry out these commands. Otherwise 

they are not available. 

14.3 Converting Graphic Object to Compound Curve 

All graphics can be converted to compound curves object. After 

you have converted a graphic to a compound curves object, you can edit 

it in the way to edit a curve object. 

Convert Graphic Object to Compound Curve 

1. Select the object with Pick Tool or Shape Tool. 

2. Click right mouse button, and choose Convert to Compound 

Curve(shown here as in 14-3)or click the Convert to Curve button on 

the Properties Bar. 

Note:After you have converted a graphic to compound curve, it does not 

change remarkably the appearance of the graphic but it changes the way 

to edit nodes. For the Satin Stitch objects auto filled based on polylines, 

circles, ellipses and polygons, only after converting their outlines to 
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compound curves, you can modify their width. 

          

14.4 Converting EDcurve 

You can convert any of graphic objects to EDcurve, the program 

will generate EDcurve with existing parameter values. 

14.4.1 Convert Graphic Object to EDcurve 

1. select the graphic object to modify with Pick Tool or Shape 

Tool. 

2. Click right mouse button and choose Convert to 

EDcurve(shown here as in 14-4-1). 

  

Note: 

You can only convert a single object to EDcurve. 

14.4.2 Dispart EDcurve 

You can use Dispart to dispart an EDcurve into parts. Each part is 
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an independent object, you can select to reserve one of them. 

1. Select an EDcurve with Pick Tool or Shape Tool. 

2. Click right mouse button and choose Dispar(shown here as in 

14-4-2-1). 

           
Note: 

The outer side of a close graphic(except for auto-close graphic)is 

the first side, and the inner side is the second side. 

1. If you do not want to show all parts, uncheck the box of All and 

check the boxes to select the parts you want to keep. 

2. Click Ok(shown here as in 14-4-2-2). 

       
The original EDcurve is disparted, only the selected parts are 

displayed on the screen(shown here as in 14-4-2-3). 
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Chapter 15 AutoFill 

RDP 2000 offers a convenient way to convert vector graphics to 

stitch objects. You just need to select a suitable to fill in the graphic. You 

can create your own vector graphic file with the drawing tools provided 

in the program. You can also open an existing vector file in other drawing 

software under RDP 2000 the following vector formats are applicable in 

RDP 2000: 

  (*.DXF) AutoCAD 

  (*.WMF) Windows Metafile 

  (*.EMF) enhanced Windows Metafile 

  The opened file is identified as RDP format. The parts of the 

graphic with clear ouline can be converted to stitch object directly. 

  The above method is not sufficient for the digitizing of the 

whole file, so you can also convert the graphic objects to ED curve 

objects first, and then fill the ED curve objects with and stitches. 

15.1 Converting Graphic Objects to stitch Objects  
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  1. Select the object to be converted to stitch object with Pick 

Tool or Shape Tool. 

  2. Open Pattern menu and choose AutoFill. 

Or Click right mouse button and choose AutoFill (process shown here as 

in 15-1-1): 

         
  3. Select the stitch type you want to use in AutoFill pop-up menu 

  The graphic is filled with stitch type chosen. 

Note:  

  For different graphic objects, there are different stitch type could 

be auto filled. In fact, there are in all 4 kinds of stitch types, they are 

single border, two borders, clove curved and circles. Only the graphics 

satisfactory the 4 types could be auto filled with some stitch types. 

15.2 Converting Stitch Objects to Graphic Objects 

  You can convert not only vector graphics to stitch objects but 
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also stitch objects to graphic objects. 

  1. Select the stitch object to convert to graphic with Pick Tool. 

  2. Open Pattern menu and choose Convert to Graphic. 

  Or click right mouse button and choose Convert to Graphic 

(process shown here as in 15-2-1).  

     
Note: 

  You can convert stitch objects to graphic (except for stitches 

from paper tape). 

 

 

 

Chapter 16 Select and Modify 

16.1 Selecting Objects 

  Before you can modify any object, you need to select it. 

  You can use Pick Tool to select object. 

16.1.1 To Select a Single Object  
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  1. Click Pick Tool button on Draw toolbar. 

  2. Click the object to select. 

  When it is selected, it will be covered with another color and 

eight handles will show around the object to indicate its size (as here as in 

16-1-1). 

                  

  To cancel select it, click at any point outside the outline of the 

object. 

16.1.2 To select objects with Polygon/Line Pick Tool 

  You can select an object or multi objects just through dragging 

out a polygon around the objects, which you want to select. 

  1. Click Polygon/Line Pick Tool button. 

  2. Drag out a polygon around the objects you want to select, 

show like Picture. 

  3. Click the right mouse button, the objects surrounded by the 

polygon will all the be selected.  

  You can also select the objects just through dragging out a line 

crossing the objects you want to select. Show here like Picture. Then the 

objects intersected with the line will all be selected. 
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  You can also choose from Setting/Options/Mouse Hit/Select 

Object Including objects intersected, you also choose the intersect 

method, Intersected by outline or Intersected by stitches, then when 

the object outline or the stitches of the object intersected by the polygon 

or line, the object will also be selected. 

16.1.3 To select objects by dragging a spring box from right to left 

Choose from Setting/Options/Mouse Hit/When selecting objects 

from right to left, including objects intersected. 

Dragging our a spring box from right to left, then the objects 

intersected by the spring box will all be selected. 

16.1.4 To Select Multi Objects 

1. Click Pick Tool button on Draw Toolbar. 

2. Click the first object to select. 

3. Press the key of Ctrl and click the other objects to select one by 

one (process shown here as in 16-1-4). 

Note:  

When the objects are overlapped, you can press Ctrl key and click 

at the object to select. 
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16.1.5 To select a Series of Objects 

1. Click Pick Tool button on Draw toolbar. 

2. Click at the first object to select. 

3. Press the key of Shift and at the same time click at the last 

object to select. 

You can also use the shortcut key to select a series of object: 

Select the first object for the series with Pick Tool. 

To select further on forward, press Shift key and ← key. 

To select further on backward, press Shift key and → key. 

To cancel the selection forward, press Shift key and ↓key. 

To cancel the selection backward, press Shift key and↑key. 

16.1.6 To Select Objects with Spring Box 

1. Click Pick Tool button in the Draw Toolbar. 

2. Draw the mouse along and a spring box will appear on screen 
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3. Cover the objects to select in the spring box and release the 

mouse. 

The selected objects will show in another color and surrounded 

with the eight handles (process shown here as in 16-1-6). 

   

16.1.7 To Select All Objects 

Open Modify menu and choose Select All. 

Or press the keys of Crtl + A to select all objects. 

16.1.8 To select the Next Object 

1. Select an object with Pick Tool. 

2. Press the key of Tab to select next object. 

3. Go on pressing the key till you have selected the desired object. 

When pressing Tab with no object selected, the program will select 

the last object. 

16.1.9 To Select the Previous Object 
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Select an object with Pick Tool. 

1. Press the keys of Shift + TAB and you will select the previous 

object of it. 

2. Go on pressing the keys till you have selected the desired object. 

When pressing the keys of Shift + TAB with no object selected, the 

program will select the first object. 

16.1.10 To Select Previous Objects 

1. Select any object apart from the last one with Pick Tool. 

2. Press the keys of Shift and at the same time press the leftward 

key of direction keys on keyboard to select next objects. 

16.1.11 To Select Next Objects 

1. Select any object apart from the last one with Pick Tool. 

2. Press the keys of Shift and at the same time press the Right ward 

key of direction keys on keyboard to select next objects. 

16.1.12 Invert Selection 

Use Invert Selection and you can select all objects except the 

selected ones: 
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1. Select one or several objects with Pick Tool. 

2. Open Modify menu and choose Invert Selection. 

The selection will be reverted, that is, the objects that were not 

selected will be now selected and those that were selected will not now 

selected. 

16.1.13 Object Hit Mode 

To Select Object Hit Mode 

1. Open Setup menu and choose Options. 

2. Click the Label of Mouse Hit. 

There are two modes available (shown here as in 16-1-13): 

 

Envelop: you will be able to select the object when you click 

anywhere within the envelop—the rectangle indicating the size of the 
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object. 

Outline: you will be able to select the object when you click at 

anywhere on the outline of the object. 

3. Click OK. 

16.1.14 To select objects with the help of needle mark 

Press F8 key, the object the current needle mark stays will be 

selected. Press Shift + F8, the object in which some parts stitches have 

been selected will be selected. 

16.1.15 To select objects using block 

Set Block Head 

This function is suitable for both objects and stitches. 

1. Select a stitch object. 

2. Choose Set block Head from modify menu. A box appears 

around the stitch object to show this object is the block head. To select 

stitches, select a stitch, then choose this function to set the black head. 

Set block Tail 

1. Select a object, then choose Set Block Tail from modify menu, 

then the series objects between the block head and tail will all be selected, 
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not including the forbid and hidden objects. 

2. To select stitches, select a stitch, then choose this function to set 

the black tail, the stitches between the black head and tail will all be 

selected. 

16.2 Modifying the size of an Object 

16.2.1 To Modify the Size of an Object by Dragging Handles 

1. Select the object with Pick Tool. It will show a different color 

and eight handles appear around it. 

2. It is possible to drag the four handles at the corners to modify the 

size diagonally. When the mouse is pointed to any of the handles, it will 

change into a set point. Drag it and the size of the object is changed 

diagonally. If you press the Ctrl key while dragging the mouse, the object 

will change size diagonally based on the Origin Point of it. 

While dragging the handle, you can press the key of Shift to shift 

among the modes of Ratio and Free. 

3. You can modify the width and height of the object with the four 

handles at the sides of the object. 

The two handles at top and bottom are for the modification of 

height of the object while the two at sides the width. Point mouse to any 
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of the handles and it will change into a set point. Now you can drag the 

mouse, and only the width or height of the object will be changed based 

on the set point. If you press the key of Ctrl while dragging mouse, the 

object will change width or height diagonally based on the Origin Point 

of it. 

16.2.2 To Modify Object Size through Dialog Box of General 

1. Select the object with Pick Tool or Shape Tool. 

2. Click the button of Gen on Property Toolbar. 

Or Click right mouse button and choose Object Properties. Click 

the label of General in the dialog box. 

3. Modify the value of Width and Height to change the size of 

object. 

16.3 Moving Objects 

16.3.1 To Drag Mouse to Move an Object 

1. Select the object with Pick Tool. 

2. Click and drag it, the outline of it appears. Drag the mouse to the 

desired position and release it And the object has been moved to the new 

position. 



 222

16.3.2 To Move Object With Command of Move 

1. Select the object with Pick Tool. 

2. Open Modify menu and choose Move. 

3. Click at any point of the object and move the mouse. 

4. While the mouse is moving along, the outline of the object 

appears, and a line connects the object with position the mouse moves to. 

The length and angle of the line decide the position to move the object to. 

5. Click the mouse when the mouse gets to the desired position.  

The object has been moved to the new place (process shown here 

as in 16-3-2-1). 

             

Note: 

a. When moving an object with any of the above mentioned steps, 

you can cancel the operation by pressing Esc key. 

b. Press the key of Shift while carrying out the command of Move, 

you can move the Starting Point to the desired place: 
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1. Select the object with Pick Tool. 

2. While pressing Shift, open Modify menu and choose Move. 

3. Click point on screen and the Starting Point will be moved there 

(process shown here as in 16-3-2-2). 

      

16.3.3 To Move an Object with Right Mouse Button 

1. Select the object with Pick Tool. 

2. Press right mouse button and drag the object to the desired 

position, release mouse. 

3. Choose Move Here in the pop-up menu. 

16.3.4 To Move an Object through Coordinates 

1. Select the object with Pick Tool.  

2. Input values in the Combo Box of Coordinates X and Y in 

Property Bar, or click the arrows to get the value. 

The object will be moved to the new position according to the 

coordinates. 
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Note: 

It is applicable only to graphic objects. 

16.3.5 To move an object precisely 

1. Select the object with Pick Tool. 

2. Press Ctrl key and at the same time, pres any of the direction 

keys, the object will move 0.1mm (default value) vertically or 

horizontally. 

To Setup the Unit for the Option. 

1. Open Setup menu and choose Options. 

2. Click the label of General. 

3. Input value in the Text Box of Ver and Hor of Precision 

Movement (shown here as in 16-3-5). 

4. Click Ok. 

16.4 Rotating and Distorting an Object 

16.4.1 To Drag Handle to Rotate and Distort an Object 

1. Select the object to modify with Pick Tool. 

2. Click the object again and the four rotation handles will appears 
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at the corners (shown here as in 16-4-1-1). 

    

             

3. Drag any of handles at the corners clockwise or counterclockwise, 

the object will rotate based on the Rotation Center (process shown 

here as in 16-4-1-2). 

Note: 

  You can drag the Rotation Center at any point on screen. 
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4. Now you can distort the object by dragging the four handles at 

sides (16-4-1-3). 

      

16.4.2 To Rotate an Object with the Command of Rotate 

1. Select the object to modify with Pick Tool. 

2. Open Modify menu and choose Rotate. 

3. Click at any point in the selected object and the point will be set 

the base point to rotate the object. 

4. Drag the mouse and the outline of the object appears on screen. 

A line also appears to show the angle of rotation. 

The value of the angle is now shown on Status Bar. 

Release the mouse when getting to the desired angle. 



 227

Note: 

While rotating the object, you can shift between free angle and set 

angle. The set angles are Horizontal, vertical and 45 degrees. 

16.4.3 To Position an Object Horizontally 

When using this command, you only need to input a horizontal 

reference line and the object will be rotated according to the reference 

line: 

1. Select the object with Pick Tool.  

2. Open Modify menu and choose Horizontal Position. 

3. Input a reference line on the object.  

And the object has been rotated according to the reference line. 

16.5 Deleting an object  

To Delete an object 

1. Select object to delete with Pick Tool. 

2. Open Modify in the Program Menu and select Delete. 

Or press the key of Delete on keyboard. 

The selected object has been deleted. 
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16.6 Copying Objects 

16.6.1 Cupboard 

Copy: The command of Copy in Edit menu copies an object to the 

clipboard: 

1. Select the object to copy with Pick Tool. 

2. Open Edit menu and choose Copy. 

Or click the Copy button on Standard Toolbar. 

Or click right mouse button and choose Copy in pop-up menu. A 

copy of the object has been put into the Clipboard. 

Cut: The command of Cut in Edit menu removes the object from 

the file to Clipboard: 

1. Select the object to cut with Pick Tool. 

2. Open Edit menu and choose Cut. 

Or click the Cut button on Standard Toolbar. 

Or click right mouse button and choose Cut in pop-up menu. 

The object has been removed from the file into the Clipboard. 

Paste: The command of paste can get the object in the Clipboard to 
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the screen: 

Open Edit menu and choose Paste. 

Or click the Paste button on standard Toolbar. 

Or click right mouse button and choose Paste in the pop-up menu. 

The object in Clipboard has been inserted into the file. 

If the object was copied or cut from the file, it will be inserted to 

where it was copied or cut. For stitch objects, you can also copy them 

behind the present stitches. Please refer to Chapter 19 Combine Stitch 

Objects and Designs. 

16.6.2 Usage of the Copy Command in Modify Menu 

Then command of Copy in Modify menu can position the copied 

object precisely in the design: 

1. Select the object to copy with Pick Tool. 

2. Open Modify menu and choose Copy. 

3. Click at any point of the selected object and drag it. The outline 

of the object and a line will appears. 

4. Release the object has been inserted to the position. 
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Note: 

When carrying out the command while pressing the key of Shift, 

the program will take the Starting Point as the reference point for 

position: 

1. Select the object to copy with Pick Tool. 

2. Press Shift key, at the same time open Modify and choose Copy. 

3. Click at the position for the object to be copied to. 

The copy of the object has been inserted to the position with the 

Starting Point as the reference point. 

16.6.3 To Copy an Object with Mouse 

You can get a copy of object directly. When doing so, the selected 

object will not be put to the clipboard: 

1. Select the object to copy with Pick Tool. 

2. Drag the object while pressing the Crtl key. 

3. When arriving at the desired position, release the mouse. 

The copy of the object has been inserted on screen. You can made 

several copies of an object in this way. 
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Note: 

Release mouse before releasing the key of Ctrl. 

16.6.4 Drag the Object with right mouse button to copy Object. 

1. Select the object to copy with Pick Tool. 

2. Click right mouse button and drag it to the desired position, then 

release the mouse. 

3. Select Copy Here in the pop-up menu. 

Tip: 

You can choose to place the stitch objects duplicated (except for the 

objects on the Clipboard) at the current penetration point. 

1. From Setting menu choose Options 

2. Click the label of Embroidery. 

3. Enable the check box of Insert the duplicated stitch objects after 

the current penetration. 

16.7 Mirroring Objects 

Mirror is a command to get the object turn over along 

horizontally,vertically or on any angle. 
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16.7.1 To mirror Object Horizontally 

1. Select the object to mirror with Pick Tool. 

2. Open Modify menu and choose Horizontal in Mirror. 

3. Input the base point for the mirroring. 

4. Move the mouse, the outline and a vertical line appears on the 

screen, this line is also called Mirror line, the Object will be mirrored as 

this line is the symmetric axis. Input the second point, the object will be 

mirrored horizontally. 

The object is mirrored horizontally. 

Note: 

Press the key of Ctrl while click the mouse will reserve the original 

object as mirroring, thus getting a mirrored copy of the selected object. 

16.7.2 To Mirror an Object Vertically 

1. Select the object to mirror with Pick Tool. 

2. Open Modify menu and select Vertical in Mirror. 

3. Input the base point. 

4. Move the mouse, the outline of the object and a horizontal line 
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appears on the screen, this line is also called Mirror line, the object will 

be mirrored as this line is the symmetric axis. Input the second point, the 

object will be mirrored vertically. 

The object is mirrored vertically. 

Note: 

Press the key of Ctrl while click the mouse will reserve the origina 

object as mirroring, thus getting a mirrored copy of the selected object. 

16.7.3 TO Mirror an object an any Angle 

1. Select the object to mirror with Pick Tool. 

2. Open Modify menu and select User-defined in Mirror. 

3. Click at any point on screen and drag the mouse from the point. 

A line appears (Mirror line) and the outline of object appears. The 

program will take the line as the axis to mirror the selected object. 

4. Drag the Mirror Line and click when arriving at the desired 

angle. 

The object is mirrored according to the angle you selected. 

Note: 

Press the key of Ctrl while the mouse will reserve the original 
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object as mirroring, thus getting a mirrored Copy of the selected object. 

16.7.4 To Mirror Object on Property Bar 

1. Select object with Pick Tool. 

2. Click the button of either Vertical Mirror or Horizontal Mirror. 

And the selected object is mirrored.  

It is applicable only to graphic object. 

Note: 

You can also get horizontal or vertical mirror of object in the 

following steps: 

1. Select the object to copy with Pick Tool. 

2. Click right mouse button and select Properties in the pop-up 

menu. 

3. Click the label of General. 

4. Select the Hor or Ver for the Angle. 

5. Click Ok. 

The selected object is mirrored horizontally or vertically. Please be 

noted that the object is mirrored in the same place. 
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Chapter17 Manage Objects 

17.1 Objects Alignment 

RDP2000 offers you command to align objects accurately. You can 

make selected objects align to the left, right, top, bottom, horizontal 

center, vertical center and the center. The objects will be aligned to the 

first created object among them. 

To Align Object 

1. Select at least two objects with Pick Tool. 

2. Choose A lignment from Modify menu. 

3. Choose an alignment mode form the pup-up list, or click the 

corresponding button on the Order Toolbar, and the objects will be 

aligned accordingly (process shown here as in 17-1-1): 
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Note: 

You can use several alignment modes together to achieve special 

effect. 

17.2 Making Objects Same Size 

Same Size command lets you to make objects the same size 

according to the width, height, or the width and height of the objects. It is 

subject to the first crested object among the objects selected for this 

command. The width, or height, or width and height of selected objects 

will be made the same size according to that of the first created object. 

To Make Objects Same Size 

1. Select the objects for the size adjustment with Pick Tool. 

2. Choose Same Size from Modify menu. 

3. Select the method from the pup-up menu, or click the 

corresponding button (shown here in 17-2-1) on Order Toolbar. The 

selected objects will be arranged same size accordingly (shown here in 

17-2-2): 
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17.3 Making Objects Even spacing 

Even Spacing command lets you arrange objects evenly in either 

horizontal or vertical direction. 

1. Select the objects to be modified with Pick Tool. 

2. Choose Even Spacing from Modify menu. 

3. Choose the method to arrange objects from the pop-up menu, or 

click the corresponding button (shown here as in 17-3-1) on the Order 

Toolbar. And the selected objects bear the even spacing accordingly. 

17.4 Grouping and Ungrouping 

When individual objects are ground, they behave live a single 

object. You will find grouped objects very useful when in need of making 

a series of objects in same format, same properties. 
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If you want to modify the properties of an object separately, you 

can use Ungroup or ungroup all command. 

17.4.1 To Group Objects 

1. Select the objects to group with Pick Tool. 

2. Click the right mouse button and choose Group command form 

the pop-up menu, or click Group button on Property Bar. And the 

selected objects are grouped as one object. 

17.4.2 To Create Nested Group 

Group command also lets you create nested groups—groups 

composed of groups. 

1. Select several grouped objects (or one object and several 

grouped objects, or one grouped objects and several objects) with Pick 

Tool. 
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2. Click right mouse button and choose Group command in the 

pop-up menu, or click Group button on Property Bar. 

17.4.3 To Ungroup Objects 

Grouped objects can be ungrouped at any time and the ungrouped 

objects will be once again a single object but bearing the same properties 

they got when grouped. 

1. Select a grouped object with Pick Tool. 

2. Click right mouse button and choose Ungroup or Ungroup all 

from the pop-up menu, or click the Ungroup or Ungroup All button on 

Property Bar. 

Note: 

For a nested group, if you choose Ungroup, the nested group will 

be only ungrouped to the state when it was grouped, the grouped objects 

in the nested group will not be ungrouped. If you choose Ungroup all, 

the nested group will be totally ungrouped and no group will remain. 

17.5 Locking Objects 

Lock command lets you fix an object on the page. When locking 

an object, you cannot move, scale, copy or modify the object, so that you 

can avoid modifying the object accidentally. You can lock a single object 
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as well as several objects or grouped objects. Moreover, you can unlock 

all them when you need to modify or edit them again. 

17.5.1 To Lock Objects 

1. Select an object with Pick Tool. 

2. Click right mouse button and choose Object Operation 

Properties, then click Lock in the pop-up menu (shown here as in 

17-5-1-1). 

   

Note: 

You can select several objects at one time and lock them. 

17.5.2 To Unlock All 

You can use Unlock All command to resume the state at which you 

can edit, modify the objects. 

Click right mouse button and select Object Operation Properties, 

then click Unlock All (shown here as in 17-5-2-1) from the pop-up menu. 

17.6 Hiding Objects 
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If there are overlaps or envelops among objects in a design, you 

can hide part of a design to conveniently edit the object. 

17.6.1 To Hide object 

1. Select the object to hide with Pick Tool. 

2. Click right mouse button and choose Object Operation 

Properties, then click Hide (shown here as in 17-6-1-1) from the pop-up 

menu. The selected object will disappear form the design window. 

  

Note: 

You can select several objects and hide them. 

17.6.2 To Cancel All Hide 

To display the hidden object(s), click right mouse button and 

choose Object Operation Properties. 

And then click Cancel All Hide (shown here as in 17-6-2-1) from 

the pop-up menu. And the hidden objects will be displayed in the design 
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window again. 

   

Note: 

The difference between Hide and Lock is that the hidden object is 

not displayed on the screen while the locked objects are still displayed in 

the word window. 

17.7 Ordering Objects 

You can use Order command to change the stitching sequence of 

objects. 

17.7.1 To Order objects 

1. Select the objects to modify with Pick Tool. 

2. Click right mouse button and choose Order. 

3. Choose the command you want to use or click the corresponding 

button (shown here as in 17-7-1-1) on the Order Toolbar. When you 

have selected Object in same order as embroidery (please refer to 

17.7.2 for details), the roles of the commands are shown as follows. 

To Front 
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Places the selected object in the first sequence number, so that it 

will be the first object to embroider. 

Shortcut key: Shift + PageUp 

To Back 

Places the selected object in the last sequence number, so that it is 

the last object to embroider. 

Shortcut key: Shift + PageDown 

Forward One 

Places the selected object in front of the previous one  

Shortcut key: Ctrl +PageUp 

Back One 

Places the selected object behind the next one.  

Shortcut key: Ctrl +PageDown 

In the front of … 

Places the selected object behind the defined object. 

Behind … 

Places the selected object behind the defined object. 
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Reverse 

Choose Reverse, and all selected objects will be rearranged in 

reverse sequence. 

17.7.2 To Choose Different Order Mode  

When using the above orders, you need to first set the order mode, 

otherwise, the order might be just the contrary. 

1. Open Setting menu and choose Options. 

2. Click the label of General. And the dialog box of Options 

(shown here as in 17-7-2-1) appears: 

  

To set the needle sequence the same as your design sequence, you 
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need to: 

3-1. Check the box of Object in same order as embroidery. 

To set the needle sequence the contrary as your design sequence, 

you need to: 

3-2. Uncheck the box of Object in same order as embroidery. 

17.7.3 To sort objects sequence by color 

You can sort the objects sequence for a design by color. To Sort 

objects by color 

1. Open the design you want to modify. 

2. Choose Sort Objects By Color from Layout menu, the Set 

Order by Color dialog box appears on the screen. 

3. All the objects in the design displays in the dialog box according 

to the color change sequence, you can change the object sequence just by 

moving the objects. Click the object you want to move, drag it where you 

want to place it. In this way, change the other object sequence. 

4. Click Merge Color button, put all the objects in the same color 

together to embroider. 

If need, you can adjust the background color by yourself. 
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17.7.4 To sort Order by objects 

You can also sort the objects sequence by objects completely in a 

dialog box. 

To sort the objects sequence by object list 

1. Open the design you want to modify. 

2. Choose Sort Order by Objects, the Sort Order by Objects by 

color dialog box appears on the screen. 

3. All the objects in the design display in the dialog box by their 

embroidering sequence. You can change their sequence just by moving 

the objects, click the object you want to move, drag it where you want to 

place it. In the way to change the other object sequence. 

Note: 

1. The grouped objects, show in the dialog box as one object. 

2. You can order all the objects hidden or forbidden edit in the 

dialog box. 

3. The selected objects,show in the dialog box in the selected color. 

4. You can order all the objects in different layers in this dialog 

box. 
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17.8 Finding and Replacing Object 

Find and Replace command lets you find and replace the general 

objects or the objects with defined properties. You can find and replace all 

kinds of graphics, images, text objects or stitch objects. 

17. 8.1 To Find Object 

You can use Find Object to search all kinds of graphics, images, or 

stitch objects. 

1. Open Edit menu and choose Find and Replace, then click Find 

object (shown here as in 17-8-1-1). 

  

2. Click the name of the object to find in the Find pull down list. 

3. Click Next button. 

The program will search for the object defined from very beginning 

of the design (or from the selected object). 

4. Continue to click Next button, the program will continue to 

search for the object defined.  
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If the program has searched objects to the end of the design and 

you continue to click Next button, or there is no defined object in the 

design, it will remind you (shown here as in 17-8-1-2): 

    

Click OK to return to the Find Object dialog box, 

17.8.2 To Replace Object 

Replace Object command lets you replace the found object with 

another object defined, you can also replace all objects with same 

properties in a design. 

1. Open Edit menu and select Find and Replace, then click 

Replace Object. 

2. Click the name of the object replace in the Find pull down list 

(process shown here as in 17-8-2-1) shown. 
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3. Select the new object you want to use to replace the original 

object in the Replace pull down list (process shown here as in 17-8-2-2). 

       

4. Click the Replace button. 

The program will search in the design the object defined and 

replace it. 

If you click Replace All button, all objects with defined property in 

the design will be replaced with the new object. 

17.8.3 To Find Text 

Find Text command lets you search for the text string defined 

properties in the design, whether it is a plain text or a text object as the 

stitch elements. You can define whether to match upper/lower case. 

1. Open Edit menu and select Find dialog Replace, then click 

Find Text. 

2. Type the string to find in the Find dialog box (shown here as 

17-8-3-1). 
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3. Click Next button. 

The program will search for the text object that contains the string 

from very beginning of the design or from the selected object. 

To match upper/lower case during searching, please select the 

check box of Match Case. 

4. Continue to click Next, and the program will continue to search 

the string. 

If the program has searched to the end of the design and you 

continue to click Next, or there is no string defined in the design, the 

program will remind you (shown as in 17-8-3-2): 

  

Click OK and return back to Find Text box. 

17.8.4 To Replace Text 
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You can use new string to replace the original string in a text object, 

no matter it is a plain text or a stitch text object. 

1. Open Edit menu and select Find and Replace, click the 

Replace Text. 

2. Input the original string to replace in the Find box. 

3. Input the string to replace the original one in the Replace box. 

To match Upper/Lower case, please select the check box of Vase 

Sensitive. 

4. Click Replace. 

And the program will search for the defined string and replace it 

with the new string. If you select Replace All, text objects contain 

defined string will be replaced. 

17.9 Copying Properties 

The command of Copy Properties is used to copy the properties of 

one object to another, so saving the time of creating another object. This 

command is applicable only among objects of the same type, from one 

object to another object of Satin and Fill Stitch of one object to another of 

Fill Stitch. 

17.9.1 To Copy Properties 
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1. Select the original object to copy properties from with Pick Tool. 

2. Open Modify menu and choose Copy Properties. 

3. The cursor becomes a big arrow. Click it at the target object to 

copy properties to. 

The Properties (spacing in the example) of the original object has 

been copied to the target object (Process shown as in 17-9-1-1) 

  

17.9.2  To Copy Properties with Mouse 

1. Select the original object to copy properties from with Pick Tool. 

2. Drag the original object to the target object to copy properties to 

with right mouse button and release it. 

3. Select Copy Properties in the pop-up menu thus appears. 

The properties of the original object have been copied to the target 

object (process shown here as in 17-9-2-1). 

And the properties (spacing in the example) of the original object 
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have been copied to the target object (shown here as in 17-9-2-2): 

         

                     

17.10 Object Display Filter 

Object Display Filter is an on-off switch, which arranges to display 

the objects in different types according to Graphic Objects. Image 

Objects, stitch Objects OLE Object and Group Objects. It is especially 

useful when you need to modify or edit part of a design: you can choose 

to display on screen only the part to modify or edit and hide all the other 

parts from the screen, so the complicated design new becomes a simple 

object. 

To View One Type of Objects  

1. Open Setting menu and choose Object Display Filter. And the 

dialog box of Object Display Filter (shown here as in 17-10-1) will 

appear: 

2. The default setting of this switch is Display All, so that all the 

design is displayed on the screen. To view a certain type of objects, 
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uncheck box of Display All at upper-left of the dialog box. 

Uncheck Display All at the bottom of Stitch Objects and Graphic 

Objects. Then click at the buttons of Hide All in both Stitch Objects and 

Graphic Objects. Now you can choose to display the designed type or 

types of object in the Dialog box (process shown here as in 17-10-1) 

 

You can choose to display different types by clicking at them while 

pressing the Ctrl key. 

3. Click Apply. And only the selected types of objects will be 

displayed on screen. 

4. For all Graphic Objects or Stitch Objects, you can also select to 

Hide All or Inversion. 

Hide All 

If you don’t want to display any of the graphic objects or stitch 
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objects in the design, you need first to uncheck Display All and then click 

the button of Hide All. 

Inversion 

Click the button on of Inversion, and you will invert the selection 

of the items. 

Note: 

If you don’t close the dialog box of Object Display Filter, it will 

float on the interface and will not interfere your other operations. 

17.11 Layer Manager 

Layer Manger is used to manage the objects in different layers. 

You can create, copy, delete, hide, lock and print layers so as to manage 

the overlays of the objects in the design. When there are many objects in 

the design, the Layer Manager is a very powerful tool to select and edit 

the objects. 

There are four default layers in a new file: Grid, Layer, Guideline 

Layer, Desk Layer and a Layer for the pattern (Layer1). 

You can visit the Dialog box of Layer Manager by opening 

Layout menu and then choosing Layer Manager. 

Or you can also press the keys of Ctrl + F3 to visit Layer 
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Manager. 

And the dialog box (17-11-1) appears: 

  

17.11.1 To Create a New Layer 

1. Open Layout menu and choose Layer Manager 

2. Click right mouse button at Current Layer and the choose Create 

a new layer in the pop-up menu (shown here as in 17-11-1-1)thus 

appears. 
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Or click the button of Arrow at he upper right corner of the dialog box to 

activate the menu (shown here as in 17-11-1-2) and then select Create a 

new layer. 

           

The newly created layer will get the name of Layer2, Layer3, etc. 

The last created layer will be the Current Layer. 

Note: 

You can create a new layer by pressing the keys of Ctrl +Alt +L at 

any time and make it the Current Layer. 

17.11.2 To Rename a Layer 

1. Open Layout menu and choose Layer Manager to get the 

dialog box of Layer Manager. 

2. Double click at name of the layer to rename and the name will be 

circled in a box. Now you can rename the selected layer. 
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You can also click right mouse button at the name of the layer to 

rename and choose Rename Layer. 

Or choose the layer or rename and click at the Arrow at the right 

upper corner, and then choose Rename Layer. 

17.11.3 To Delete a Layer 

You can delete a layer at any time: 

1. Click the layer to delete in the dialog box of Layer Manager. 

2. Click right mouse button at the layer to delete and choose Delete 

Layer. 

Or click the button of the arrow at the upper right corner of the box. 

Choose Delete Layer. 

The selected layer and the objects in it are deleted. 

17.11.4 To Setup a Layer 

You can set the attributes of the layer in the dialog box of Layer 

Manager: 

Open Layout menu and select Layer Setup. 

Click right mouse button at the layer and select Layer Setup. 
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Or choose the layer and click the button of the Arrow at the upper 

right corner of the Box and select Layer Setup. 

The dialog box of Layer Attribute (17-11-4-1) appear: 

     

Now you can setup the properties of the layer in the box  

Layer Name  

It is a text box listing the name of the layer you have chosen. You 

can change the name of the layer by inputting text in it. 

Visible 

It is a check box, allowing to display or hide the layer you have 

chosen. You can set the layer to be visible by checking it, otherwise, the 

layer will be hidden and invisible from the design window together with 

the objects in it. 
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You can also set a layer visible or not visible by choosing of 

forbidding the icon of the eye in front of the layer. When it is grayed, 

the layer with the objects in it are not displayed in the design window, 

thus you cannot select or edit them. 

The default setting of the program sets each layer visible. 

Printable 

A layer (with the objects in it) can be included or excluded from the 

printing of the Work Sheet. To include a layer in the Work Sheet, you can 

check the box if Printable. Otherwise, the layer will not be included. 

You can also choose or forbid the icon of printer in front of the 

layer, when it is grayed, the layer with the objects in it will not be 

included in the printout of the Work Sheet of the design. 

Editable 

The check box of Editable is quite useful as it helps to display the 

objects in the design window without being able to be edited. It is good 

when you edit or modify parts of a design. To set a layer editable, check 

the box besides it. Otherwise, the layer with the objects in it will not be 

able to be edited. 

It is also possible for you to set a layer editable or not by choosing 
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of forbidding the icon of pencil in front of the layer. When it is grayed, 

you cannot edit or modify the object in this layer. 

The default setting is editable for each layer. 

Note: 

Grid Layer cannot be edited or modified, the pencil of it is always 

gray. 

Unicolor Display 

It is an on-off command. When it is on, all the objects in the chosen 

layer are displayed in the color of the layer, no matter what color they 

were. At this time, if you change the setup of color, the colors of all the 

objects in the layer will also be changed. To resume the original colors of 

the objects in the layer, just uncheck the box. 

Layer Color 

The button of Layer Color helps to setup the color of the layer. A 

click on the button  and you will get the standard windows 

pop-up dialog box of color. You can setup the color of the layer in it. You 

can also setup the color of the layer in the dialog box of Layer Manager. 

Click the Button of Layer Color in the Dialog box of Layer Manager to 

select or palette the color in the box of Color. 
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17.11.5 To select Current Layer 

When creating, editing or modifying objects in a layer, you need to 

make it Current Layer first. Only when it is the activated current layer, 

can the layer be selected or edited. The Black arrow     indicates that 

the layer is the Current layer. When starting a new design, the Current 

Layer is the defaulted layer, that is, Layer 1. 

1. In the dialog box of Layer Manager, click the layer to be the 

Current Layer.  

2. Click right mouse button and select Shift to Current Layer in 

the pop-up menu. 

Or click the layer to be current Layer and then click the Arrow at 

the upper right corner of the box and select shift to /current Layer. 

Or you can select Current Layer by clicking at the icon and press 

the key of Ctrl. 

Or you can also click in the column of the Black Arrow at the layer 

to select it. 

And the Black Arrow moves to the selected layer, indicating that it 

is the Current Layer. 

Note: 
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You can select the current Layer with the keys of Ctrl + Alt ++ or 

Ctrl + Alt+- to move the Current Layer upwards or downwards. 

17.11.6 To Copy or Move Objects among Layers 

You can use the commands of Move to and Copy to move or copy 

objects among layers. 

To Move Objects to Another Layer 

1. Select the object to be moved with Pick Tool. 

2. Open Layout menu and select Layer Manager. 

3. Click the layer of the selected object. 

4. Click tight mouse button at the layer and select Move To in the 

pop-up menu. 

The cursor becomes a big arrow   , click it at the layer to move 

the object to, and the object is moved to the new layer. 

To Copy Object to Anther layer 

1. Select the object to cope with Pick tool. 

2. Open Layout menu and choose Layer Manager. Click the layer 

of the selected objects. 
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3. Click tight mouse button at the layer and select Copy to in the 

pop-up menu. 

4. The cursor becomes a big arrow   , click it at the layer to copy 

the object to, and a copy of the objects is placed to the new layer. It is 

covered by the original object and cannot be seen. You can move away 

the original object to examine the copy. 

Note: 

You can also visit the commands of move to and Copy to by 

clicking the button of the Black Arrow at the upper right corner of the 

dialog box of Layer manager. 

17.11.7 To Edit cross Layer 

This if a switch command to treat all the editable layers as a group 

layer, so that you can edit, modify, delete, copy or move objects in the 

editable different layers. When this switch is off, you can only carry our 

operation on the Current Layer or the Desktop layer. If you need to edit 

object in another layer, you have to shift Current Layer to that layer. 

You can also visit this command by clicking the button of Black 

Arrow at the upper tight corner of the dialog box, and the Edit Cross 

Layer command. 
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17.11.8 Move Layer Locations in the Dialog Box of Layer Manager 

1. Open the dialog box of Layer Manager. 

2. Click the layer to move. 

3. Drag the mouse and a dashed line will appear to indicate the 

location. When you get to the desired location in the dialog box, release 

the mouse. 

The selected layer has been moved to the new location in the dialog 

box. 

17.11.9 To set layer by color 

You can set layers for a design or tape file according to its color 

change sequence. 

To set layer for a design by color  

1. Open the design you want to modify.  

2. Choose Set Layer by color from Layout menu, the Layer 

Manager Dialog box appears on the screen, all the objects in the design 

will be shown in different layers according to the color change sequence. 

You can use all the operations in Layer Manager to edit the design. 

17.12 3-D Simulation 
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17.12.1 3-D Simulation 

3-D Simulation is an on-off switch, which shifts the design 

displayed on the screen between the states of the design and the end 

product. 

1. Open a design for the 3-D Simulation. 

2. Open View menu and choose 3-D Simulation. 

New the switch of 3-D Simulation is on and design is shown in the 

state of product (17-12-1-1). 

  

3. Choose the command of 3-D Simulation again and the switch is 

off. The pattern is shown in the state of the design. 
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Note: 

You can also visit the command of 3-D Simulation through the 

shortcut button on View Toolbar. 

Hotkey: f5. 

17.12.2 3-D Simulation Parameter Setup 

The parameters are: Angle of the light, Contrast and Brightness: 

1. Click Thick, Middle, Thin button to select the thread width. 

And the dialog box of 3-D Simulation Parameter Setup appears 

(17-12-2-1): 

           

2. Adjust angle, Contrast and Brightness through the slider till you 

have got the desired effect and you can also choose the thread width for 

the 3-D Simulation. 
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3. Click OK to finish the setup. 

Note: 

Click Simulation Punch button, you can do all the punching 

functions under the simulation status. 

17.13 Unicolor Display 

Unicolor Display is a color switch, which allows you to display, 

modify or edit objects in your design according to colors they bear. You 

can display, modify or edit objects in several colors. 

To Examine Pattern with Unicolor Display 

1. Open an existing design. 

2. Open view menu and choose Unicolor Display. 

The switch of Unicolor Display is now on and only the objects 

bearing the first color sequence on Color Toolbar will be displayed on 

screen. 

At the same time, dialog box of Unicolor Display switch (17-13-1) 

appears: 

3. Click the color to display the objects in the box. Only the object 

in the chosen color will be displayed. 
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You can also display objects bearing different colors at one time; 

A. Click the colors while holding the Ctrl key. 

B. Or click the first color and then click the last color while 

pressing Shift key to cover a series of colors. 

Note: 

You can close the dialog box, then press the Tab key and you can 

shift among the objects bearing different colors in the color sequence on 

Color Toolbar. 

4. Open View menu and choose Unicolor Display again, and you 

will turn the switch off and exit the state of Unicolor Display.  

Note: 

You can turn the switch on and get the dialog box floating in the 

Window. 
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It is also possible for you to visit the command through the shortcut 

button on View Toolbar. 

Hotkey: F4 

17.14 Slow Redraw 

Slow Redraw is on-off switch. To switch it on, the design is 

display in the process when it was designed. It is also the process that the 

design will be embroidered. 

17.14.1 Slow Redraw of a Design 

1. Open an existing design. 

2. Open View menu and choose Slow Redraw. 

The design is now being redraw in the set speed to show you how it 

will be embroidered when finished. 

You can press the Esc key to stop redrawing the design at any time 

during the process. But this does not turn the switch off. Any other 

operation will activate the command and the design is being redrawn 

again. 

3. Open View menu and choose Slow Redraw again, and you will 

exit the state of Slow Redraw. 
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Note: 

The parts that can apply to the command of Slow Redraw are those 

of the design within the window. 

17.14.2 Slow Redraw Speed Setup 

1. Open Setting menu and choose Slow Redraw Speed. 

And the dialog box of Slow Redraw Speed Setup (17-14-2-1) will 

appear: 

     

2. You can adjust the speed by the slider or inputting value in the 

text box. 

3. Click OK. 

 

 

Chapter 18 Modify Object Outline 

When you use Shape Tool to select a stitch object, it shows the 
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outline, edit nodes of the outline, entry, exit, direction line and other 

information of the object on the screen. You can add, delete, or move edit 

nodes for the object; you can modify the properties of the edit nodes; you 

can add or move direction lines. Please refer to Direction Lines for details 

about direction lines. For details of adding, deleting or moving edit nodes 

and modifying the properties of edit nodes, please refer to Modify 

Graphic Object. 

You can choose to generate stitches at once when you modify a 

stitch object. You can also choose not so generate stitches till you press 

the Enter key. 

As to stitch object converted from vector graphics, when you use 

Shape Tool to select the object, the outline showed on the screen is the 

outline of the original vector graphic. So, the way to modify accurately. 

If there are overlaps among edit node,entry,exit and direction 

lines,you can use the following keys to help you select the object you 

want to modify accurately. 

Hold down E key, you can only select edit nodes; Hold down D key, 

you can only select direction line; Hole down I key, you can only select 

entry; Hold down O key, you can only select exit. 

18.1 Selecting Mode to Generate Stitches 
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When you modify a stitch object, you can choose to generate 

stitches at once or not to generate stitches till you press the Enter key. 

1. Choose Options from Setting menu. 

2. Click the label of Punch. 

3. Check the box of Generate stitches when modify stitch object 

(process shown here as in 18-1-1). The program will regenerate stitches at 

once as you modify the outline of the object. 

  

If you uncheck the box, the program will only show the outline 

after modification. It will not. 
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Regenerate stitches until you press the Enter key  

Note: 

If you choose not to generate stitches at once, then after 

modification, you can press ESC to cancel the modification to outline 

before you press the Enter key. 

18.2 Entry and Exit 

The Entry and Exit are usually put at the top left corner and the 

bottom right corner separately. But when in practice, you should consider 

the principle of Minimum Distance, which is to make the Exit of the 

previous object as near to the Entry of next object as possible. So you can 

adjust the positions of entries and exits of the objects in the design to your 

need. 

To change the positions of Entry and Exit 

1. Select the object to modify with Shape Tool, and the object will 

shoe the outline edit nodes, Entry Exit, direction line and other 

information of it on the screen. 

2. Drag the Entry and Exit to where you want them to appear. 

3. Add Entry and Exit: select object at first,click the right mouse 

button to choose Add Graphic Element,Entry/Exit,then input the Entry 
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and Exit. 

4. Delete Entry and Exit: select the Entry or Exit with Shape tool, 

then click Delete to remove them. 

To keep default Entry &Exit of satin stitch objects 

The default position of Entry is usually at the start of the first 

border of a Satin Stitch object, while the Exit is at the end of the second 

border. When editing the Satin Stitch objects, if you want to keep the 

Entry and Exit at their default positions, you can set it from 

Setting/Options/Punch/Keep default Entry &Exit of Satin Stitch 

objects. 

18.3 Exchanging Entry and Exit 

Using Exchange Star/End command, you can exchange the 

positions of Entry and Exit of a stitch object. 

1. Select the object to modify with Pick Tool. 

2. Choose Exchange Star/End from Pattern menu. 

And the Entry and Exit of the selected object is exchanged. 
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Chapter 19 Combine Stitch Objects and Designs  

You can out or copy part or all of a design and paste it to another 

design, the object you cut or copy is put on the Windows chipboard, you 

can repeatedly use till it is replaced by new content. 

You can also use Merge command in File menu to insert a design 

to another one. 

When you use clipboard or Merge command to insert objects, 

current layer always has the precedence over current needle position. That 

is to say, when current needle position is not in current layer. The object 

will be inserted to the current layer. 

There are two ways to position inserted objects: a. Keep the 

position when the object was cut or copied: b. Paste the object to current 

needle position. 

19.1 Inserting an Object in a Design through Chipboard 

19.1.1 To Copy and Paste Stitch Object 

1. Select the object to be copied with Pick Tool. 

2. Open Edit menu and choose Copy, or click Copy button on 

Standard Toolbar. The selected object is copied in to the chipboard. 

3. Use command buttons on Browse Toolbar to travel current 



 277

needle position (shown as Needle Mark) to where you want to paste the 

object. (To paste the object to another design, first open it, and then travel 

current needle position to where you want to insert the object). 

Note: 

Choose from Setting/Options/Embroidery/Copy Object in 

Clipboard to Current Location or Insert the Duplicated Stitch 

Objects after the Current Penetration, the first option will insert the 

object at the current stitch location, while the second option will insert the 

object after the current penetration in the stitch sequence. 

4. Open Edit menu and choose Paste, or click Paste button on 

standard Toolbar. 

The selected stitch object is pasted behind the current needle 

position or where it was cut or copied. It is in the chosen state with the 

eight handles around it, and you can move it to some other position. 

Note: 

There are two ways to position the object according to you setting. 

One is to place the object at the same position where it was originally cut 

or copied, the other is to position the object coincides with current needle 

position point. Please refer To Select Insert Mode for details. 



 278

The current needle position must be on the current layer. Otherwise, 

the object will be pasted to the current layer rather than behind the current 

needle position. 

You can click right mouse button and select Copy or Paste 

command. 

19.1.2 To Cut and Paste Stitch Object 

1. Select the stitch object with Pick Tool. 

2. Open Edit menu and choose Cut, or click Cut button on 

Standard Toolbar. The selected object is removed from the design and 

put on the clipboard. 

3. Use command buttons on Browse Toolbar to travel current 

needle position (shown as Needle Mark) to where you want to paste the 

object. (To paste object to another design, you should first open it and run 

current needle position to where you want to insert the object.) 

4. Open Edit menu and choose Paste, or click Paste button on 

Standard Toolbar. The stitch object cut is pasted where you have 

selected. 

Note: 

You can also click right mouse button to choose Cut and Paste 
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commands. 

19.1.3 To Select Insert Mode 

When you insert a stitch object into a design, you have two choices 

to position it: to paste it at the current needle position of the design, or 

paste it when it was cut of copied. 

To Select Position for Inserted Object 

1. Open Setting menu and choose Options. 

2. Click the label of Embroidery. 

3. Check the box of Copy object on Clipboard to current needle 

position (shown as in 19-1-3-1).  

      

In this way, the object in Clipboard is copied to the current needle 
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position of the design, the Start Point of the object coincides with the 

current needle position (process shown here as in 19-1-3-2): 

     

If you uncheck the box, the object on the clipboard will be pasted 

where it was cut or copied, but the Start Point of the object still coincides 

with current needle position. 

4. To use the color of current stitch object for the stitch object to be 

inserted, check the box of Use same color when insert objects in 

current stitch object (shown here as in 19-1-3-1). 

Note: 

There is an option in Setting/Options/Embroidery Input/Insert 

stitch objects only at the current layer, if you don’t choose this option 

you can insert objects at any layer. 

19.2 Inserting an Object with Mouse 

If you want to insert an object in to some other part in the design, 

you can drag the mouse to create a copy of the object and insert the copy 

into another object in the design. 
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1. Select the stitch object to insert with Pick Tool. 

2. Use command buttons on Browse Toolbar to travel the needle 

position to where you want to insert the object. 

3. Pass Ctrl key and at the same time drag the object to where you 

want to insert it and release the mouse. The selected object has been 

copied and pasted at the position you have dragged it to. The pasted 

object is in the selected state and you can modify or edit it. 

19.3 Merging Designs 

You can insert an entire design into the current design with the 

command of Merge. There types of embroidery files apply to this 

command: DST format files, DSZ format files and DSB format files. The 

design is inserted at current needle position of the design. But when the 

current needle position is not on current layer, it will be inserted into the 

current layer. 

19.3.1 To Insert a Design into Current Design 

1. Use command buttons on Browse Toolbar to run the needle 

position to where you want to merge the design. 

2. Check whether current needle position is in current layer. If not, 

shift to current layer. 



 282

3. Choose Merge from File menu, and the dialog box of merge 

(shown here as in 19-3-1-1) appears: 

  

4. Click the name of the design you want to insert into the other 

design. 

5. Click Open. 

6. The outline of the design to be inserted appears on screen. Move 

outline to a proper position and click the mouse. An entire design if 

inserted into the current design at the position you have chosen. 

19.3.2 To Select Merge Mode 

When you merge designs to create a new design, you can choose to 

insert it on the current layer or in a new layer. 
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To Set Merge Mode 

1. Choose Options from Setting menu. 

2. Click the label of Input/Output. 

3. Check the box of Create New Layer in the box of Merge Designs 

(shown here as in 19-3-2-1), and the merged design will be inserted in a 

new layer. Uncheck it, and the merged design will be inserted in the 

current layer. 

  

19.4 Shifting Current Layer to Current Needle Layer 

In case you are now not in current needle layer, the design to merge 

will be inserted into current layer rather than current needle layer. To shift 
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to current needle layer, you should open Pattern menu and choose Shift 

Current…. You can also shift to current needle layer by pressing the 

keys of Ctrl + F8. 

19.5 Dividing Object 

You can use Divide command to divide a stitch object into two 

objects at the current needle position. 

1. Use command buttons on Browse Toolbar to travel to the needle 

position where you want to divide the object (shown here as in 19-5-1). 

           

2. Select the object to divide with Pick Tool. 

3. Click right mouse button and choose Divide or choose Divide 

from Pattern menu (shown here as in 19-5-2). 

     

The object is divided into two objects at the selected needle 
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position (19-5-3). 

          

19.6 Ordering Objects in design 

The embroidery objects in a design form a stitching sequence. 

Usually, the embroidery objects are stitched in the same order as they are 

created. But you can order the objects in a design to change the stitching 

sequence. 

You can use command buttons on Order Toolbar to rearrange the 

order of the objects. You can also change the position of a selected object 

by cutting it, then pasting it back somewhere else in the design. 

To Order Objects with Commands of Cut and paste 

1. Select the object or a series of objects with Pick tool. 

2. Choose Cut from Edit menu. Or click Cut button on Standard 

Toolbar. 

The selected object is removed from the design and placed on the 

Clipboard. 
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3. Click Edit Stitch button to travel to the needle position where 

you want to paste the object you have cut. 

4. Click Paste from Edit menu, or click Paste button on standard 

Toolbar. 

The object on the Clipboard if pasted behind the current needle 

position 

You can also click right mouse button to choose Cut or Paste 

command. 

Note: 

You can check the stitching sequence of a design with Slow 

redraw in View menu or the Slow Redraw button on Browes Toolbar. 

 

 

Chapter 20 Modify Properties of Multi Objects 

RDP2000 allows modifying the properties of selected objects in a 

design. You can modify the properties of Multi Objects at the same time, 

sush as the properties of Width and Height, Stitch Count, Spacing , 

Texture and Size. You can convert stitches for all the selected objects and 

identify tape objects. All the task are fulfilled within the same dialog box. 

Select the Objects to modify before getting into the dialog box. 

The program will automatically arrange the types of the objects in 
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Stitch, Graphic, Image and Text. 

20.1 Modifying Properties of Multi Objects 

Select the objects to modify with Pick Tool. 

Click right mouse button and choose Modify Multi Objects in the 

pop-up-menu. 

And the dialog box of Modify Multi Objects will appear (shown 

here as in 20-1): 

 

You can now select the objects to modify in the box of Objects to 

Modify. The program defaults two items: Whole Document and All 

selected objects, you can also select group objects for the 

modification-objects of the same stitch type or graphic type. Apart; from 

them, you can also choose single object for the modification(please refer 

to 20.2 Modifying Single Object.) 

For section, we take multi objects both as group objects and all 

selected objects. For them, some of the button in the dialog box might not 

be activated and are grayed, and they are not available for the selected 
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objects. In the Preview Window, all the selected objects are included in . 

When you choose them for the modification, they will be brightened and 

the others are grayed. 

20.1.1 To Modify Stitch Number 

Select Modify Stitch Num and click Execute Selected button, the 

dialog box of it will appear(shown here as in 20-1-1): 

  

There are two ways to adjust the Stitch Number: 

a) The Way of Absolute Value: set the total stitch number for the 

modification. Input the value of the total stitches in the text box of Adjust 

to.  

b) The way of Ratio: set the stitch number ratio for the 

modification, Adjust the slider or input the perecentage. 

The two ways are associated and if one of them changes, the other 

will vary too. 

Click OK. 

Note: 

The Box of Adjustable refers to those stitches that can be adjusted. 
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There might be some stitches that cannot be adjusted, like some from the 

tape files. 

20.1.2 To Modify Spacing  

You can adjust the spacing of Multi Objects at the same time. 

Select Modify Spacing and click Execute Selected button, the 

dialog box of it will appear(shown here as in 20-1-2): 

      

There are two ways to adjust Spacing: 

(a) The way f Absolute Value: set the value for the adjusted 

spacing. Check the option box first and input the value for the target 

spacing. 

(b) The way of Relative Value: set the percentage of the adjusted 

spacing. Check option box first and input the value for the target 

percentage. 

Click OK. 

Note: 

When modifying stitch numbers, the spacing of Satin Stitch objects 

and the step of Running Stitch objects will accordingly change. 
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20.1.3 To Modify Step 

If you have a Running Stitch object or objects containing Running 

Stitch, you can modify the Steps of them: 

Select Modify Step and click Execute Selected button, the dialog 

box of it will appear(shown here as in 20-1-3): 

  

There are two ways to modify step: 

(a) The way of Absolute Value: set the target step. Check the 

option box of Absolute Value in first and input the value for the target 

step. 

(b) The way of Relative Value: set the percentage for the modified 

step. Check the option box of Relative Value first and then input the value 

for the percentage of the target step. 

Click OK. 

20.1.4 To Modify Width  

Select Modify Width and click Execute Selected button. The 

dialog box of it will appear(shown here as in 20-1-4): 

Set the width for the Left Side and the Right Side. 



 291

         

Click Ok. 

Note: 

The positive value, widen the object. The negative value, 

narrowing the object. When the outline of the stitch object is Circles, 

Ellipses, Polygons and so on, only after converting the outline to 

Compound Curves, you can modify their width. 

20.1.5 To Modify Twill 

For the objects with Twill, you can modify them at the same time: 

Select Modify Twill and click Execute Selected button. The dialog 

box of it appears(shown here as in 20-1-5) 

       
Modify the parameters in the box. 

Click OK. 



 292

20.1.6 To Convert Stitch Type for Multi Objects 

Select Convert Stitch Type and click Execute Select button. The 

dialog box of it appears(shown here as in 20-1-6): 

       

Select the stitch to convert to in the list. 

Click OK. 

20.1.7 To Identify Tape Objects 

You can identify multi tapes at the same time. 

Select Identify Tape and click Execute Selected button. The tape 

objects are being identified. 

20.1.8 To Modify Connector 

Select Modify Connector and click Execute Selected button. The 

dialog box of Connector Setup appears. Please refer to Chapter 9 

Machine Code and Connector. 

20.2 Modifying Properties of Single Object 

Fist, select Single Object in the list of Objects to Modify. And now 

you have activated the orders for modifying single object, the four 

buttons in the box of Single Object for selecting the object is 
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available(shown here as in 20-2): 

The button of First: select the first single object. 

The button of Next: select the next single object. 

The button of Previous: select the previous object. 

The button of Last: Select the last object. 

Note: 

When you select objects with the four buttons, you can see the 

colors of objects in the Preview Window vary. When it is brightened, the 

object is selected. At the same time, in the top of the window, the status of 

the selected object will show, such as Stitch Type, Stitch Number and the 

position of the object among the selected one. 

When you have selected the object, click the button of Parameter to 

get the dialog box of it and modify the object in it. You can modify the 

parameters of the object, such as the Spacing, Jagged, Underlay, 

Segment, Connector, Hole Property, Texture, etc. 

To select the selected stitches object 

This function is very usable in selecting one or multi objects in a 

complicated design. The method is that you can select some stitches in 

the object(or multi objects), which you want to select, then press SHIFT 

+ F8, the object(or multi objects) will be all selected. 
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Chapter 21 Edit Stitches 

You can use Edit Stitch to edit the stitches of an object in a design. 

But we don’t. Because once the stitches of an object are re-generated, for 

example, after scaling, all the changes you made to the stitches will be 

lost. Whenever possible, you should modify the outline of the objects, or 

change their properties inserted of editing the stitches. 

If you really need to modify several particular stitches, you can 

select these stitches for editing. You can move or delete it, or add some 

stitches to the object. 

Browse Toolbar lets you browse stitches and check the stitching 

sequence of a design conveniently. 

You can delete small steps in a design to avoid damaging fabric or 

breaking needles before you output a design. 

12.1 Traveling Through Stitches 

RDP 2000 offers you different ways to travel through stitches, you 

can travel by 1, 10, or 100 stitches, you can also travel by object, color or 

machine code, and you can go directly to the Start Point or large Red 

Cross – Needle Position Mark, which shows where the stitch arrives. 

Click the up half part of a button to travel be one unit and hold 

down the down part of a button to travel backward or forward continually. 

Moreover, shortcut keys are provided for most tools. 

21.1.1 To Travel Through Stitches  
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To Travel Through Stitches and Their Shortcut Keys 

Go to the Starting Point of the design       Home 

 Go to the end of the design               Left 

 Travel backwards by 1 stitch              left 

 Travel forwards by 1 stitch                Right 

 Travel backwards by 10 stitches            Up 

 Travel forwards by 10 stitches             Down 

 Travel backwards by 100 stitches           = 

 Travel forwards by 100 stitches            - 

 Travel backwards to the Starting Point of previous object 

 Travel forwards to the Starting Point of next object 

 Travel backwards to previous color change point  Page UP 

 Travel forwards to next color change point      Page Down 

 Travel backwards to previous machine code   

 Track forwards to next machine code 

 Track 

Note: 

When browsing stitches, you can also choose to make the current 

needle position is always auto visible. 

1. From Setting menu choose Options. 

2. Click the label of General. 

3. Enable the Check box of Current Penetration Point Auto 
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Visible When Browsing. 

If you disable the check box, the current penetration point will be 

invisible when it is browsing to out of the design window. 

21.1.2 To Track 

There are four ways to track stitch: Go to defined stitch number; 

Go to previous or next jump stitch; Go to previous or next machine code; 

Go to previous or next color. 

To Track Stitch 

1. Click the button of Track , and the dialog box of Stitch 

Browse (shown here as in 21-1-2) appears: 

     

2. Click Stitch Number. 

3. Input the number of the stitch you want to check in the input 

box. 

4. Click Go. 

5. The needle position marker will move to the stitch point of 

defined number. 

6. Close the dialog box and continue to search other stitches. 
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To Travel by Jump Stitches 

1. Click the button of Track . 

2. Click Jump Stitch in Stitch Browse dialog box. 

3. Click the button of To previous one or To next one. 

After the needle position marker traveled to the position you want, 

close the dialog box. 

Note: 

If you click To Travel To previous one or to next one button 

continually, you can travel through jump stitches of the design backward 

of for ward continually. 

To Travel by Machine code 

You can use the tool to run current stitch to the machine code with 

defined type backward or forward. 

1. Click the button of Track . 

2. Click Machine Code. 

3. Select machine code to travel to in input pull down list. 

4. Click the button of To previous one of to next one. 

The program will run current stitch backward or forward to the 

defined machine code. 

Note: 

If you keep on clicking To previous one or To next one, the 

program will run stitch backward or forward continually. 
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To Travel by Color 

You can use this tool to search objects with defined color backward 

or for ward: 

1. Click Track button . 

2. Click Color. 

3. Click To previous one or To next one. 

The program will search for the object with defined color backward 

or forward. 

Note: 

You can run the stitch to last stitch of next object or to the first 

stitch of previous object: 

1. Open Setting menu and choose Options. Check the label of 

Embroidery. 

2. Check the boxes of When browsing to next color, run current 

needle mark to the end or When browsing to previous color, run 

current needle mark to the start (shown here as in 21-1-2-4). 

21.1.3 Run current needle mark to the start/end when browsing 

stitches with color. 

When browsing stitches with colors, you can choose to when 

browsing to previous object, run current needle mart to the end. 

1. From Setting menu choose Options. 
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2. Click the label of Embroidery. 

3. Enable the check box of when browsing to previous object,run 

current needle mark to the start or When browsing to next object, 

run current needle mark to the end. (Shown here as in 21-1-3). 

  
21.1.4 To select current Stitch Position Object 
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You can select directly the object in which the current stitch locates 

while you are using Browse Toolbar to browse stitch penetrations. 

To select the current stitch position object  

1. Use Browse Toolbar to run current stitch to the stitch you want 

to modify 

2. Open Pattern menu and choose Select Current or Press the 

shortcut key F8. 

The current object is selected. 

21.2 Editing stitches 

21.2.1 To Select Stitches 

You must first select the stitches before you modify them. You can 

select several stitches at one time. 

To Select Single Stitch 

1. Click Edit Stitch button. 

2. Click at the stitch you want to modify. 

The needle position mart travels to the stitch indicating the 

selection. All stitches behind the needle position mark are showed in 

another color. The program default color of the stitches behind the needle 

position mark is gray. 

Note: 

You can also use Browse Toolbar to run to the stitch you want to 

modify. 
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To Select Multi Stitches 

1. To Edit Stitch button  

2. Hold down Ctrl key and click the stitches you want to modify. 

In this way, you can select multi stitches. The selected stitches are 

shown in another color (as in 21-2-1-2), you can move and delete selected 

stitches. 

             
Select range of Stitches  

1. Click Edit Stitch button   

2. Click the first stitch you want to select, the needle position mark 

travel to the selected stitch. 

3. Hold down Shift and click the last stitch to be selected, the 

needle position mark travel to the selected stitch (shown here as in 

21-2-1-3). 

             
The stitches between the first selected stitch and the last selected 

stitch are all selected. The selected stitches are showed in another color. 
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You can move or delete a range of stitches 

To Select Stitches with Spring Box 

1. Click Edit Stitch button. 

2. Click mouse and drag it over the stitches to be selected. A spring 

box is format, cover the stitches to select in it. 

Note: 

When you use spring box to select stitches, before you release the 

mouse, you can press Esc to cancel the selected stitches. 

When you are modifying stitches, you must select Penetration in 

View menu. 

21.2.2 To select stitches using Edit Stitch by Polygon/Lone Pick tool 

You can select stitches through dragging out a polygon around the 

stitches, which you want to select. 

1. Click Edit Stitches by Polygon/Line Pick Tool button. 

2. Drag out a polygon around the stitches you want to select 

(shown here as in 21-2-2-1). 

        

3. Click the right mouse button, the stitches surrounded by the 
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polygon will all be selected. 

You can also select the stitches just through dragging out a line 

across the stitches you want to select, (show here as in 21-2-2-2), then the 

stitches intersected with the line will all be selected. 

       

You can also choose from Setting/Options/Mouse Hit/Select 

stitches Including Stitches Intersected, intersected by the polygon or 

line will also be selected. 

21.2.3 Hit Mode of stitch selection 

RDP 2000 offers you several hit modes to select stitches, you can 

choose different hit mode in different situation. 

1. Open Setting menu and choose Options. 

2. Click the label of Mouse Hit. 

The dialog box of Mouse Hit (shown here as in 21-2-3) appears: 

Modes: 

Envelope: Only when you click the mouse within the envelope 

rectangle which stands for the position of the stitches can you select these 

stitches. 

Appointed Precision: Only when you click the mouse within a 
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defined precision can you select stitches. The precision is measured by 

pixels and you can set the precision by yourself. 

  

Min Distance: When you click a point, the program will 

automatically measure the distance between this point and each stitch of 

the design and select the stitch with the shortest distance. 

Appointed Precision and Min Distance: This mode is the 

combination of Appointed Precision and Min Distance, the program will 

select the stitch with shortest distance within a defined precision. It is the 

program default hit mode. 

Select the mode in the option boxes 

3. Click OK 

21.2.4 To Move Stitches 

To Move stitches  

1. Click Edit Stitch button. 

2. Select the stitch or stitches to be moved. 
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3. Drag selected stitch or stitches to a new position and release the 

mouse and the stitches are moved to the new position. 

Note: 

When you are moving stitches, as long as you did not release the 

mouse, you can press ESC to cancel the move. 

Precise Movement of Stitches 

You can make very fine adjustment to stitch or stitches with 0.1mm 

as unit, you can also set the unit of precise movement by yourself. 

1. Click Edit Stitch button. 

2. Select the stitch or stitches you want to move. 

3. Hold down Ctrl and press Up or down, or Left, or Right arrow 

key repeatedly to move the selected stitch or stitches by small increments 

in the desired direction… 

You can set the unit of precise movement by yourself. Please refer 

to the Object Modification for deletes. 

21.2.5 To Delete Stitches 

1. Click Edit Stitch button 

2. Select the stitch or stitches you want to delete. 

3. Press Delete key. 

21.2.6 To Insert Stitches in Design 

You can insert additional stitches to fill in gaps between stitches in 

a design. The inserted stitches will be part of the design and will share the 
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same properties. If you change the size or shape of the design and 

regenerate stitches, the inserted stitches will be lost. You can also insert 

stitches using manual input method. The stitches inserted in this way will 

be an independent design. When you try to modify the original design, 

these stitches will be constant. 

To Insert Stitches in Design 

1. Click Edit Stitch button. 

2. Click the stitch before which you want to insert the stitches 

(shown here as in 21-2-6-1) 

                 

3. Move the mouse to the stitch you want to insert stitches and click 

right mouse button. 

A new stitch is inserted in the defined position (process shown here 

as in 21-2-6-2). 

          
4. Move the mouse to next stitch to insert stitches and click right 

mouse button (process shown as in 21-2-6-3) 

         
5. Repeat those operations till you fill all gaps. 
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21.3 Modifying Stitches  

The command of Remove Small Stitch lets you remove small 

stitches that are smaller than a defined value in a design. The small 

stitches in a design may damage fabric or break needles or threads, so 

they are usually deleted before the design is out for the production. 

To Delete Small Stitches 

1. Open an existing file or create a design. 

2. Open Design menu and choose Remove Small Stitches, and the 

dialog box of Tidy Stitch (shown here as in 21-3-1) appears: 

    
3. Check box of Remove Small stitches. 

4. Input length for Min Step. 

5. Click OK 

The small stitches that are smaller than the Min Step in the design 

will be all removed from the design. 

Note: 

For Schiffli designs or Boring designs, some small stitches are 

necessary for the boring, so the program provides two options for your 
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chose whether to delete these small stitches in Schiffli or Boring designs. 

 

 

Chapter 22 Identify Tape Files 

RDP 2000 can identify tope files in many formats, like Tajima, 

Barudan, Melco 

The program can identify a tape file automatically when it is 

opened. It is also possible for the program to identify single or multi 

objects after the file is opened. 

It is only possible to identify general stitch types. For some certain 

stitch type that cannot be identified, the program will treat it as tape 

stitch. 

22.1 Identify Tape Files Automatically 

1. Open Setting menu and select Options. 

2. Click the label of Input/output in the Options dialog box 

(shown here as in 22-1-1). 

3. Select the check box of Identify. 

4. Click OK 

5. Open one or several paper tape files. 

Objects in it will be identified when the file is opened. 

If you uncheck the box of Identify. The objects at the same time. 

22.2.1 To Identify Single Tape Stitch Object  
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First uncheck the box of Identify, choose Open in File menu or 

Choose Embroidery Disk to open a tape file. The file opened in this way 

will not be identified. 

1. Select the tape stitch objects you want to identify with Pick Tool. 

2. Click right mouse button and select Identify Tape. 

  And the selected stitch objects will bee identified. 

22.2.2 To Identify Multi Objects  

1. Select several tape stitch objects with Pick Tool. 

2. Click right mouse button and select Modify Multi Objects. 

3. Choose Identify Tape from the list and click Execute Selected in 

the Modify Multi Objects dialog box. Please refer to Modify Multi 

Objects for details. 

And the tape stitch objects selected are being identified. 
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Note: 

RDP 2000 defaults identified objects as a group object. If you want 

to edit single objects, select Ungroup or Ungroup all to cancel the group. 

22.3 Setting a Layer for Each Needle   

You can place different objects in a tape file in different layers 

according to their needle number when you open the file. It is convenient 

for you to check and modify a design with needle as unit. You can edit 

needle layers and adjust sequence of needle layers in the Layer manager. 

To Set a Layer for Each Needle 

1. Open Setting menu and choose Options. 

2. Click the label of Input/output. 

3. Select the check box of Set Needle Layer. 

4. Open one or several tape files. 

5. Open Layout menu and choose Layer manager. You can see 

different objects in different needle layer in the Layer manager (shown 

here as in 22-3-1). 
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Note: 

You can edit needle layer in the way you edit general layers, like 

adjust the sequence of layers. Please refer to Layer Manager for details. 

To put all the different needles in one layer, you can uncheck the 

box of Set Needle/Layer in Input/Output of Options dialog box before 

you open the file. 
 
 
 

Chapter 23 Create Letter Objects 

You can create letters easily in RDP2000. The letter created can be 

standard fonts or user-defined. It is possible for you to create your own 

Satin Font Library or adopt the Font Library provided with the program. 

You can modify the outline of letters and create art fonts. 

You can input letters directly on screen or edit letters in the dialog 

box of Edit Font. And you can fill in different stitches in the letters 

created. 

23.1 Inputting Letters  

To Inputting letters on screen  

1.Click the button of Font List  on Draw Toolbar. 

2.Click at the position where you will input the letters, and an I 

cursor appears for the input. 

3.You can choose the Font and Size of the letters, whether Bold or 

Italic, on Property Bar. Input the letters through keyboard. 
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If you have input a wrong letter, you can press the key of 

Backspace to delete it. Continuous pressing of the key will delete the last 

input letters. 

Note:  

You can input several each time, press Esc key to end the input of 

them. Press Enter key to shift to next line. 

23.2 Editing Letters  

You can edit letters through the dialog box of Edit Text. You can 

change the font, size, or whether broad or italic of the letters, and you can 

also set the Letter Spacing and Line Spacing, or delete or add letters. It is 

quite like that of Microsoft Word. 

To Edit Letters  

1.Select the letters to edit with Pick Tool. 

2.Click right mouse button and select Object Property in the 

pop-up menu. 

Or click the button of Others on Property Bar. 

And the dialog box of Art Text (shown here as in 23-2)appears: 

You can choose the Font, Size, whether Broad or Italic, or add or 

delete letters. 

To Delete Letters  

Position the I cursor before or behind the letters to delete. Press the 

key of Backspace and you can delete the letter before the I cursor. Press 
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the Key of Delete and you will delete the letter behind the I cursor. 

  

To Select Letters  

To select letters, drag mouse over the letters and they will be 

selected and show in another color. 

You can delete the selected letters or input from keyboard to 

replace them. 

To Add Letters 

To add letters, point the I cursor to the position and input the letters 

from keyboard. 

To Adjust Word Spacing and Line Spacing 

The spacing between letters and lines are represented by the 

percentage of Font Width and Font Height. 

Input the values in the text boxes of Word Spacing and Line 
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Spacing.  

Note: 

The above ways are applicable only to graphic letters. For stitch 

letters, you can modify them in the same way as modifying stitch objects, 

or use the command of Convert to Graphic and modify them in the 

above ways. 

23.3 Creating Art Letters  

1. Click the button of Font List  on Draw Toolbar and an I 

cursor appears on screen. 

2. Click at the position for the letters and the I cursor is moved to 

the position. 

And the Property Bar becomes that of Font. 

3. Select Font and Size, decide whether Broad or Italic in the 

Property Bar of Font. 

4. Click the button of Art Font  on Property Bar of Fond and 

click the arrow of Others. The dialog box of Art Font(shown here as in 

23-3-1)appears: 

5. Select the art font in the dialog box by clicking the 

corresponding button. 

6. Click OK. 

7. Input the letters from keyboard. 

23.4 Editing Art Font  
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1. Select the art letter to edit with Pick Tool. 

2. Click the arrow button of Others  on Property Bar. 

And the dialog box of Art Font(shown here as in 23-4)appears: 

  

3. Click the Label of Edit Font and you can add, delete letters, 

change the Word Spacing or Line Spacing. 
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Please refer to Edit Font for more details. 

4. To change the art font: click the Label of Art Font. You can 

choose another type of art font. 

5.Click OK when finishing editing. 

Note:  

You can only use the above ways to edit graphic letters. For stitch 

letters, you can edit them in the same way as modifying stitch objects, or 

choose the command of Convert into Graphic and edit them in the 

above ways. 

23.5 Distorting Letters  

You can modify the letters in different ways---to modify them in 

the same ways as modifying other objects: select them with Pick Tool, 

adjust the size, rotate, mirror, copy, move, deflect, align, snap and lock, 

etc(shown here as in 23-5-1): 

      
When selecting art font with Pick Tool, you can change the shape 

and curve of them by dragging the control points(process shown here as 

in 23-5-2): 

You can modify the shape of letters with Shape Tool: select the 

letters and they will show in outlines and Edit Node. You can modify 
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them in the same ways as you modify other graphic objects. Please refer 

to Modify Shape of Graphic Objects for more details. 

        

And at the lower left corner of each letter, there is a triangle mark. 

Drag it to move the letter(process shown here as in 23-5-3): 

             

Dispart letters  

Using Dispart function, you can dispart the letters into single 

objects, each curver segment becomes one single object. 

Choose the letters you want to dispart, then click the right mouse 

button, select Dispart. 

23.6 Converting Letters into Stitch Objects  

When having created letters, you can select a stitch for them and 

convert them into stitch objects. 

To Select Stitch for Letters  

1.Select the letters with Pick Tool. 

2. Click right mouse button and select AutoFill. 
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Or open Pattern menu and select AutoFill. 

3. Select the stitch to fill in the letter in the pop-up menu. 

And the letters will be filled with the selected stitch. 

Note: 

If there is no such Font Library, the program will remind 

you(shown here as in 23-6): Click Yes to create the Satin Stitch Letter to 

the Font Library, click No to cancel AutoFill. 

 

Note:  

Once the letters filled with stitches, they becomes normal stitch 

objects, you can modify their properties in the same way modifying the 

normal stitch objects. 

 

 

 

Chapter 24 Create User’s Font Library 

It is possible for you to create user-defined letters. They can be any 

kind of characters, numbers and symbols. You can group them together 

and save a font library. 

You can safe a stitches letter of a group of stitches letters into a font 
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library, or add them to a font library. It is also possible to create a new 

font library with them. 

24.1 Creating Satin Font Library  

You can create your own Satin Font Library. 

To Digitize Letters for Font Library 

1. Click Font List button  on Punch Toolbar. 

2. Input the letters for the Font Library.  

3. Select the letters created with Pick Tool. 

4. Open Library menu and choose Create Font Library. 

Click at the (first) letter for the digitizing and the program shift to 

Satin Stitch. To shift to other Input method, press Shift on keyboard. Your 

digitizing will be snapped to the letter selected automatically. 

5. Digitize the letter(shown here as in 24-1-1). 

      
To Save to Satin Library  

6. Click right mouse button when finishing digitizing the letter. You 

can also press Enter key on keyboard. The dialog box of Save Satin 
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Font Library(shown here as in 24-1-2)appears: 

 
7. Input a name for the letter created. 

8. Select or create the name for the library to save the letter to. 

9. Setup the parameters for the letter. 

Each letter has three Reference Points: Reference Point 1 is the 

Base Point, it decides the width of the letter with Reference Point 2 and 

decides the height of the letter with Reference Point 3. Before saving the 

letter to the Library, you need first to define the three Reference Points. 

Reference Point 1(the Base Point): the default setting is that it is at the 

left lower corner of the letter. You can set it elsewhere by clicking at the 

desired position in the Preview Window with mouse or define it through 

the boxes of X and Y Coordinate. 

Reference Point 2: to decide the width of the letter. 

Hold Ctrl key and click at the desired position in the Preview 

Window with mouse or define it through the box of Ref Width. Reference 

Point 3 to decide the height of the letter. 
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Hold Ctrl key and click at the desired position in the Preview 

Window with mouse or define it through the box of Ref Height. 

10. To Define Letter Spacing 

The Letter Spacing is defined with the percentage of the letter 

height. You can define the letter spacing for each letter so that the spacing 

for all the letters in the library is defined. Input the value in the box of 

Default Spacing. 

11.Click OK. 

You will be reminded that the letter has been saved to the relative 

library(shown here as in 24-1-3). 

       
24.2 Loading from User-defined Font Library  

You can load from a font library at any time during your digitizing 

on a design. 

To Load from a Font Library  

1. Open Pattern menu and choose Insert Text. The dialog box of 

Insert Text(shown here as in 24-2)appears: 

2. Select the Font Library. 

3. Input the letter in the box of Input Text(shown here as in 24-2). 

4. Select the Size for the letter. 
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5. Check or uncheck the boxes of Bold and Italic. 

 

6. To load art letters, check the box of Art Font and click the button 

of it. The dialog box of Art Font appears. Select the art font type in the 

dialog box. 

You can see the effect of the letters input in the Preview Window. 

7. Click OK. 

8. Click right mouse button and choose the stitch type in Auto Fill 

in the pop-up menu. 

24.3 Modify User-defined Font Library  

You can modify the font libraries or the letters in them. You can 

rename the library or the letters in it, modify the letter spacing of a letter 

or other parameters. You can modify or shape a letter with Pick Tool or 

Shape Tool and save it to the library. The original letter will be replaced 

with the modified one if they bear the same name. 



 323

To Modify User-defined Font Library  

1. Select the object to modify with Pick Tool or Shape Tool. 

2. Modify of shape it in the same way as modifying or shaping 

other objects. 

3. Open Library menu and choose Save to Font Library to save 

the modification to the letter. 

4. Follow the steps to save a letter to a font library. 

For details, please refer to To Save to Satin Library. 

 

 

Chapter 25 Save and Export Designs 

25.1 Information of a Design 

You can export your designs directly to any disk or the special 

embroidery disk. You can also export the design directly to the 

embroidery machines. Before exporting, you may need to examine the 

information about them or print them or print them out to be a guide to 

the workers at the machines. To examine the design, you can select 

Information. 

To Examine Information of an Design 

1. Open the design. 

2. Open File menu and choose Document Info…. 

And the dialog box (shown here as 25-1-1) of Document 
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Information will appear: 

3. You can choose to show the information by selecting the items 

in the dialog box. 

4. Click Close to exit Document Information. 

 

Note:  

The information shown in the dialog box cannot be modified. 

The information of thread length shown in the Document 

Information box is counted by the color, while if you want to check the 

thread information for a DST file by the needle, you should set the needle 

numbers by yourself at first. 

25.2 Generating Outline of a Design 

When finishing a design, you can generate the outline of it to 

examine the size and bounding of it. 

The outline generated is actually a closed circle, you can modify it 

to get a better effect of the design. 

To Generate the Outline of Design 

1. Open the design. 

2. Open Patten menu and choose Create Pattern Outline. And the 

outline of it(shown here in 25-2-1will generate around it: 

If you are not satisfied with it, you can modify it with Pick Tool or 

Shape Tool. 
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25.3 Pull Compensation 

When embroidering the design, the stitches will pull the grounding 

fabric inwards along the stitches, and at the same time push the extra 

grounding fabric outwards vertically against the stitches. And due to this, 

the design might appear more slender when embroidered than on the 

screen, sometimes even cause unnecessary spaces between the objects in 

the design. 

This can be solved if you use some strong material for the 

interfacing or add underlay to strengthen the grounding fabric. Besides, 

you can also use the method of Pull Compensation. 

To Adopt Pull Compensation 

1. Open Setup Menu and choose Options. 

2. Click the label of Embroidery. 

3. Check the box of Pull Compensation in the dialog box. 

4. Input the length in the text box of length. 

5. Click OK. 

25.4 Start Point Setup 

You can set up the Starting Point anywhere in the design you like. 

When you select the command of Setup Start Point, the whole 



 326

design and the nine points will show on screen. When you drag mouse 

along, the design will move on screen showing the movement of the 

taboret of the machine. When you click the mouse at the proper point at 

the design, the Start Point has been set there. You can set the Start Point at 

one of the nine points. The nine points are the special points on the design: 

4 points at the four corners, four at the center of the four sides, and one at 

the center of the design. 

25.4.1 To Setup Start Point 

1. Open the design. 

2. Open Pattern menu and choose Setup Start Point. The whole 

design and the nine points will show on screen. 

3. Move mouse to the proper point and click it. The point is set the 

Start Point of design( shown here as in 25-4-1-1). 

          
25.4.2 To Set Start Point at One of the Nine Points 

1. Follow the above 3 steps. 

2. Point mouse at any of the nine points and it will turn from the 

shape of a square to a diamond, Click mouse and the Start Point is set at 
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the special location of the design. 

Note : 

While holding down D key, click at any point, a Input Cursor’s 

Coordinate box appears on the screen, in this way, you can position the 

Start point accurately. 

25.4.3 Cancel Start Point 

To cancel Start Point, open Pattern menu and choose Cancel Start 

Point. The Start Point will go back to the default position on the design: 

the very beginning of the designing. 

25.5 Tape Coding Parameter 

To setup tape Coding Parameter 

1. Open the design. 

2. Open Setup menu and choose Tape Coding Parameter. 

3. Setup the parameter in the dialog box(shown here as 25-5-1) 

thus appears. 

a. Step: 

Max Step: the maximum space between two close stitches. It is 

also the maximum movement of the taboret on the embroidery machine. 

Min Step: the minimum space between two close stitched. It is also 

the minimum movement of the taboret on the embroidery machine. 

Jump Step: the embroidery machine carries out jumps according to 

the value of Jump Step. You can setup the value to your need. 
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b: Trim When Jump: when jump stitches are over the number, the 

embroidery machine will carry out the operation of trimming thread. 

C: Use Auto Start/End: there are two different methods to get the 

Needle of the embroidery machine back: Auto Center and Return to 

Start Point. 

Choose the methods in the option boxes of Auto Center and 

Return to Start Point. 

Start Point: after finishing previous design embroidering, the 

needle of embroidery machine goes back to the Start Point ( process 

shown here as in 25-5-2). 

When embroidering large quantities of the same design, you can set 

the needle of the machine to go back to the Start Point each time finishing 
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an embroidery, and in the way, you can guarantee each embroidery is the 

same. 

     

Center: after finishing previous design embroidering, the needle of 

embroidery machine goes back to the center. There are three ways to set 

the needle center: Horizontal Center (25-5-3), Vertical(25-5-4) or 

Center(25-5-5). 

            

d: Tie in/ off: there are three ways to tie in or off  the stitches: Tie 

in before Jump, Tie Off After Jump and Tie In before Trim. 

25.6 Setting Needle /Color List. 

You can setup the Needle/Color List when outputting the tape file 

of your design, so as to reflect the response between the colors and the 

needles correctly. 
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To set needle/color list 

1. Open Setting menu and choose Options. 

2. Click the label of Input/Output, and the dialog box of it 

appears. 

3. Don’t choose Forbid Change Color when Stop, Click the button 

of Set Needle/Color List, and the dialog box of Corresponding List of 

Color and Needle appears. 

4. Click the color to modify and then click at the needle number. 

5. Input the needle number for the color. 

6. Modify all the other colors in the same way and click OK when 

finished. 

Note: 

* Check the option box of Hide unused colors and the unused 

colors will not be displayed. 

* Check the option box of Shield unused colors, the unused color 

will be displayed on the grayed background and they will not be able to 

be selected or modified. 

* Unchecked either of them, all the colors will be displayed in the 

order of the Thread List. 

* If you don’t want to change the parameter setup of the active file 

when saving it to the tape file, choose Not Changing Current 

Document When Save As Tape File. 
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Tip:  

If the check box of Change Color When Stop is enabled, you need 

not to set needle----- color list any longer, it will change at every Stop 

function. 

25.7  Embroidery Disk 

25.7.1 To Format Embroidery Disk 

1. Insert a disk into the driver 

Some embroidery machines require disks of double density(DD), 

while others require disks of high density(HD), Make sure you use the 

correct type of disk for disk for your embroidery machine.To forma a 

Embroidery disk of BARUDAN-FDR,BARUDAN-FMC,ZSK-EMB, 

ZSK-SHUTILE, you must insert a disk of DD to the driver. 

2. From File menu choose Embroidery Disk, Format. The dialog 

box of Formatting Disk appears(25-7-1-1). 

         
3. Choose the format from the list of Disk Format. RDP2000 can 
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format the following types of Embroidery disks:BARUDAN-FDR, 

BARUDAN-FMC, ZSK-EMB, ZSK-SHUTILE and MS-DOS diskette. 

4. Choose the format type. To format vacant disk or to change the 

format of a disk, you’d better choose Completely type, while if you only 

need to clear the date but not need to reformat the disk, you can choose 

Quickly type. 

5. Click Start to start formatting the disk. 

When you are formatting a special format Embroidery disk, the 

dialog box of formatting disk of MS-DOS will appear.(25-7-1-2) 

    
While formatting a MS-DOS disk, the dialog box of formatting 

disk of Windows will appear. 

6. When finishing formatting the software will remind you 

“Formatting disk completed”, Click OK. 

7.  You can format another disk 

Or click Stop to finish the formatting. 

25.7.2  To Save Design to an Embroidery Disk  
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You can save the design to a formatted embroidery disk: 

1. Insert the formatted disk into the drive. 

2. Open the design. 

3. Open File menu and choose Save As from the Embroidery 

Disk And the dialog box of Save in Emb Disk will appear. 

4. Input the file name in the text box of Name. 

5. Click Ok. 

The design will be save in the format of the disk. 

25.7.3  To Read in Designs from Embroidery Disk  

To Read in from Embroidery Disk 

You can directly open a design in a floppy disk with the command 

of Open in Embroidery Disk: 

1. Insert the disk into drive. 

2. Open File menu and select Open from Embroidery Disk. 

3. The program will automatically check the format of the file and 

show it in the text box of  Type. 

4. The details of the designs in the disk will be listed in the dialog 

box, such as file name, stitch number, file length, etc. 

5. Click the name of the design and click OK to open it. Or double 

click the name of the design. 

To Rename a Design in Embroidery Disk  

You can rename design or delete it in the Dialog Box of 
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Embroidery Disk 

1. Open File menu and choose Open from Embroidery Disk. 

2. Click the name of the file, click it again and it is selected. 

3. Input the new name for the design. 

The design has a new name. 

To Delete a Design from Embroidery Disk  

1. Open File menu and choose Open from Embroidery Disk. 

2. Click the name of the design. 

3. Press the key of Delete on keyboard. 

And the design has been deleted from the disk. 

25.8 Creating Outing Positioning Tape  

When you have finished a design, you can create the Outline 

Positioning Tape for it. It might be easier for the workers in the workshop 

to set the position of the design accurately on the fabric with the 

positioning tape of the design, and the tape can help to save the 

supplementary materials. 

The Start Point of the Outline Positioning Tape is coincident with 

that of the design, and the file will be is in another window when created. 

To Create the Outline Positioning Tape  

1. Create a design or open an existing design. 

2. Open Pattern and then select Create Outline Tape. And the 

outline for the tape created is as follows(process shown as in 25-8-1): 
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25.9 Send a Design with E-mail  

Using the command of Send you can send the active design as the 

accessory of a e-mail message to one or a series of users directly in 

Design Pro2000. But your computer must be equipped with a correct 

program such as Microsoft Outlook Express or any other a program 

which can be compatible with Messaging Application Programming 

Interface. 

To send a e-mail message 

1. Open the design to be send out. 

2. From File menu choose Send command. The dialog box of 

New Message appears on the screen. The design becomes the accessory 

of the message automatically. 

3. In the To, Cc, and Bcc boxes, type the e-mail name of each 

recipient, separated by a comma or semicolon(25-9-1). 

To add e-mail names from the Address Book, click the To icon in 

the New Message window, and then select names. 

In the Subject box, type a message title. 

Type your message , and then click the Send button on the toolbar. 
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Chapter 26 Print  

The Work Sheet is a document including the necessary information 

about the design. It is very important for the workers in the workshop to 

correctly comprehend the design. You can print it out for the workers. 

26.1 Print Preview  

Before printing you can check the effect on screen with Print 

Preview in File menu. It is possible to check the details with the Zoom 

Function. 

1. Open the design. 

2. Open File menu and choose Print Preview. The design will be 

shown on screen(show here as in 26-1-1): 

3. Click Print to print the design or Close to exit to the interface. 
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Note:  

When the design size is bigger than the page size, you could choose 

to print it in multi pages, click Next Page, Prev Page to view the pages; 

click Two Pages, two pages will be shown at the same time on the screen. 

26.2 Print Setup  

Before printing, you need to select a printer and setup the 

parameter through Print Setup: 

1. Open File menu and select Print Setup. The standard Windows 

dialog box of Print Setup will appear. It varies with the different types of 

printers. 

2. follow the instructions and setup the printer and parameter 

for the present print task . 

3. Click OK. 

26.3  Work Sheet Setup  
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Work Sheet is the link between the designer and the workers. It 

does not only contain the design itself, but the details like size, color 

sequence and stitch number of the design. You can select the details to 

include in the Work Sheet about the design. 

1. Open the design. 

2. Open File menu and choose Work Sheet Setup. 

And the dialog box of Work Sheet Setup appears. There are three 

labeled dialog boxes and you can setup the parameter through them: 

26.3.1 To Setup the Page  

Click the Label of Page and you will get into the dialog box of 

Page(shown here as in 26-3-1): 

 
Select page type in the Comb Box of Template: Default Page or 

Work Sheet. 

Default Print: only the design itself is printed. 

Work Sheet: the design is printed with its details selected. 
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If you decide to print the Work Sheet, you can go on setting 

parameter of the page like the header, footer, margin, font and font size 

etc. 

26.3.2 To Select the Print Options  

Click the Label of Options and you will get into the dialog box of 

Option(shown here as in 26-3-2-1): 

  

Select the items to print by checking the boxes and input the text 

for them when in need. 

Click the arrow buttons behind the columns of Title, Header and 

Footer and select the locations for them and the date and time information 

if necessary. 

If 3-D Simulation is selected, the design is printed in the form of 
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embroidered product. 

You can also choose to include the Start Point and Needle Points 

in the Work Sheet. When including Needle Points, you can choose the 

type of Needle Points: Crosses, Horizontal Lines, Vertical Lines or dots. 

Setup Print Order: click the button of Print Order and the dialog 

box of Setup Print Order will appear on screen(shown here as in 

26-3-2-2):  

   

The names of the items to include in the Work Sheet are listed in 

this dialog box, you can decide the orders for them to appear in the Work 

Sheet: 

The first item you clicked it ordered the first, and in the same way, 

the second till the last. The order is show in a new number when you 

click at the item. 
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Click Order and the items will be arranged according to the order 

you click the items. 

Click Reset when you want to stop the previous setting procedure 

for another round of setting. When clicking Reset button, you will not do 

any change to the ordering, it only provides you another start of the 

setting of the order. 

Click Ok when finish, and you will exit back to the dialog box of 

Options.  

26.3.3 To setup the layout of the Work Sheet  

Click the Label of Pattern and setup the layout and size of the 

design in the dialog box of Pattern(shown here as in 26-3-3): 

 

Maximum within Range: print the design as large as the blank of 

the Work Sheet can hold. 

True Size: print the design at the size at which it will be 

embroidered. 
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User-defined: print the design according to the size you setup. 

Note:  

If the design size is bigger than the page size and you want to print 

it true size, you can choose to print it in multi pages. 

26.4  Printing  

When you feel satisfied with the preview of the design, you can 

print it out in the form of Work Sheet or Default Sheet: 

1. Open File menu and choose Print.  

Or click the button of Print in the Standard Toolbar. 

Or click the button of Print in the dialog box of Print Preview. 

And the dialog box of Print(shown here as in 26-4-1)will appear 

on screen. 

   

2. Setup the parameter and click Ok, and the design will be printed 

out in Work Sheet you have setup. 
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Note:  

You can press the key of Esc to cancel the printing. 

Shortcut: Ctrl + P  

 

 

Appendix:  

  

                 Shortcut Key List 

Shortcut Keys                Functions & Usage 

To Select Objects 

Ctrl Hold Ctrl and click at the objects one by one to select 

them 

Shift  Hold Shift and click the first then the last objects to select 

the series of objects 

Ctrl+ A  

 

Select all objects in the design 

Tab  Select the next object, when no object is selected, select 

the last object. 

Shift + Tab Select previous objects; when no object is selected, select 

the first object. 

Shift + ← Select a series of objects forwards 
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Shift + → Select a series of objects backwards 

Backspace  Shift between Pick Tool and Shape Tool 

F8 Select object at current stitch position 

Shift + F8 Select object at selected stitches with shape Tool 

 

 

To Modify Objects 

Shift 

Press Shift to shift between free and ratio when 

dragging the handles of an object to scale up or down 

an object    

Shift  

Hold Shift when carrying on the command of Copy 

or Move to copy or move an object based on its Start 

Point 

Ctrl 

Hold Ctrl when dragging the handles of an object to 

scale it up or down based on the center of it. 

Ctrl Hold Ctrl when mirroring an object on get a mirrored 

copy of it. 

Ctrl Hold Ctrl when dragging an object to copy it 

Ctrl + ← → ↑ Move an object, edit node or stitch precisely 

Alt +←→↑↓ Copy the selected object horizontally or vertically 

+then ←→↑↓ Copy the selected object once 

To Add Graphic Element 
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Alt +1 Add Direction Lines 

Alt +2 Add Stitch Edge 

Alt +3 Add Vector Texture 

Alt +4 Add Entry and Exit(DRP format) 

Alt +5 Add Satin Texture Edge 

Alt +6 Add Twill Texture Edge 

 

Alt + 7  Add Pattern Texture Edge 

To Zoom objects 

Z Zoom to the double of current size 

Shift +Z Zoom to half to current size 

Z Temporary Zoom when in digitizing state 

F9 Full screen display 

F2 Zoom in all objects in the design window 

F6 Redraw 

To View Design 

Spacebar Display or hide needle point 

F5 3-D Simulation 

F4 Unicolor Display 

F7 Slow Redraw 

Esc Stop Slow Redraw 
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+ Speed up in Slow Redraw 

_ Speed down in Slow Redraw 

To digitize  

Ctrl  Hold Ctrl to input horizontal, vertical or 45 lines 

Backspace Cancel last input node 

Esc Cancel last input 

Shift Shift among the Input Methods 

L Input Lines 

 

S Input Spline 

A Input Arcs 

Q Input Quadric Bezier Lines 

C Input Cubic Bezier Lines 

Shift Shift among the lines and curves in the turn of Line, 

Spline, Arc, Quadric Bezier, Cubic Bezier 

Spacebar Shift between Running Stitch and the selected stitch 

type 

X Insert Trim Code 

To Modify Border 

Shift + S Shift to Spline from Line 

Shift + A Shift to Arc from Line 

Shift + Q Shift to Quadric Bezier from Line 



 347

Shift + C Shift to Cubic Bezier from Line 

Shift + T Shift to Line or shift between Line and Spline 

When there are overlaps on Reference Points, Entry and Exit: 

E Hold E to select Outline nodes 

D Hold D to select Direction Lines 

I Hold I to select Entry 

O Hold O to select Exit 

N Hold N not to select outline 

Tab Select next node 

 

Shift + Tab Select previous node 

To Browse Stitches 

HOME To the Start Point of the design 

END To the End of the design 

PAGEUP To next color 

PAGEDOWN To previous color 

= 100 stitches forwards 

- 100 stitches backwards 

↑ 10stitches forwards 

↓ 10 stitches backwards 

← 1 stitch forwards 

→ 1 stitch backwards 



 348

To Snap 

F 10 Snap to Grid 

F 11 Snap to Guidelines 

F 12 Snap to Objects 

Shift  Press Shift to shift between free or 45 rotation on 

objects 

Scroll Lock  Scroll Lock 

To Draw 

Ctrl Hold Ctrl to draw regular squares, regular polygons, 

regular spirals, regular meshes or circles 

 

When drawing with Compound Curve 

L  

S  

A  

Q  

C  

Shift  

To change Background color 

Ctrl +Alt +W White 

Ctrl+ Alt+ B Black 

Ctrl+ Alt+ G Grey 
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About Layers 

Ctrl+ Alt+ L Greate a new layer 

Ctrl+F8 Shift to current stitch position layer 

Ctrl+ Alt+  Shift current layer 

To input Text 

Esc Finish the input of a string 

Enter  Shift to next line 

Others 

Ctrl +N Create a new file 

Ctrl +O Open an existing file 

Ctrl +S Save current file 

Ctrl + P Print current file 

 

Shift + M Merge files 

D Precise positioning when opening or merging files 

Ctrl + Z Cancel 

Ctrl +Y Redo 

Ctrl + X Cut 

Ctrl +C Copy 

Ctrl +V Paste 

Ctrl+ M Modify Properties 

F1 Help 
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F3 Shift between big cursor and small cursor 

Esc Cancel the commant 

 


